Thermal Printer "not connected" (A04)

I got my A04 the other day and its great, super cool little device! However I have been running into an issue with the printer, which is one of the main reasons I wanted this in the first place. The thermal printer keeps saying “may not be connected” when I try to print anything, unless its the test print from the command line. I am a big noob with Ubuntu/Linux in general so I am sure that’s a source of this problem, but I have reseated the ribbon cable, tried installing new things (which sometimes doesn’t seems to work due to permissions or some directory doesn’t exist but should??), which all has me a bit stumped.

Has anyone gotten this to work?

I have the CM3 and the printer worked out of the box for me, I can print from most applications as well as from the command line using “lp” and the commands here: DevTerm/Code/thermal_printer at main · clockworkpi/DevTerm · GitHub

One issue I have is the paper jamming if I try to print something more complex, like a rasterised photo, but that might be a topic for a different thread.

edit: here’s how it looks in action for me: iCloud

The A04 works that way with the command line too, weird it doesn’t also work with the apps like you have in that image.