Trackball and keyboard not working

My uConsole arrived today. Unfortunately, after putting it together, and booting it up, the trackpad and keyboard don’t seem to be working at all.

I even tried plugging in a USB keyboard, but it wasn’t getting any power and didn’t work either.

Any suggestions.

1 Like

Just dug out an old USB mouse. It’s not getting any power either.

The uConsole boots, and I get the “Welcome to ClockworkPi uConsole A06” message. But I can’t seem to do anything after that.

Make sure you are using the correct image, on the uConsole the USB isn’t powered up without the OS telling it to. If you are using the DevTerm image, it doesn’t happen. My attempts to run the CM3 ended up with that problem.

Hmm…I’m using the memory card that came in the box. Is there an easy way to verify if it’s correct? Or should I just create my own?

If you have another memory card you could just image another. I have the CM3 in my DevTerm and the R-01 in the uConsole. The CM4S is kind of running in the uConsole, but has major issues as the I/O lines have been moved around.

I’m experiencing the same exact issue. I’m going to contact directly and see if I can get some support, but I’m literally experiencing what you described @rikiwarren and also tried a USB keyboard/mouse combo, but nothing.

I’ve even re-opened and tried to re-sit the keyboard pad. When doing that, there’s an LED on the keyboard PCB, and when I click or touch any of the key areas or trackball, it lights up, which tells me that’s not the problem.

Not sure, but this is super disappointing considering I waited almost a year (I was one of the first to pre-order Oct last year) and I literally just received it today. I’ve also had this problem with the keyboard not working on the Devterm unfortunately.

Ok. I downloaded the current uConsole A06 image, flashed it to a memory card, and tried booting from that. But the behavior is exactly the same. It boots fine. The screen’s working. But I’m not getting any response from the trackball or keyboard.

Any suggestions?

Just a random thought, have you tried pressing Fn+Esc? That locks and unlocks the keyboard and trackball. I’m not sure how it would default to off, but it’s worth a try as it’s an easy test.

I did the same thing… fresh install (A06), boots up fine, and screen works, but still no keyboard or trackball functionality. I’m at a loss with what else I should attempt atp.

Thanks for the suggestion. I tried, but nothing.

I was so hoping that would fix it—unfortunately, nothing changed for me either.

So, I found an old post for the DevTerm that describes the exact same problem. Apparently, the issue was a bad connection between the battery pack and the main board.

I’m going to try and make sure the connections are all clean and everything’s making contact–but I probably can’t get around to that until tomorrow.

Ok. That didn’t work. I’m at a loss about what to try next. Looks like the hardware may just be DOA.

Does anyone know how to file a customer support request? I sent a message through the uConsole chat–but I haven’t heard back.

Oh, sorry. I had gotten an email response. I just didn’t notice it this morning. Hopefully I’ll get a solution that way.

Yea, I own the DevTerm and had a similar issue, but it was the pin connection to the batteries. This doesn’t seem to be the same issue imo, as the fit for the uConsole is much better than the DevTerm’s.

I also reached out to support via email a couple days and waiting for a response from their R&D team on what could be the issue. If it is a hardware issue, it’s hard to believe we’re the only two people experiencing this. Especially since our problems seem to be exactly the same. I’ll update here once I hear anything.


I got the keyboard/trackball to work correctly. Clockwork support got back to me and asked to check if the core was seated correctly. When I re-opened the back it seemed fine, but I released the core and re-sat it. When I turned on that fixed the issue. While it looked like the core was sat perfectly fine, maybe it was off a bit or not fully making contact on a pin, because now it works fine. Worth a shot! Hope it works for you. Cheers

1 Like

I have the exact same symptoms and am in despair.
I would like someone to tell me how to solve this problem.

Hey! Typing this from my fully-functional uConsole. Reseating the core fixed it for me as well.

It sure looked like it was all the way in–but taking it out and putting it back fixed everything.