USB-ETH for Devterm

I have a CM3 based devterm is USB gadget mode supported by the h/w ?

Thanks,
Andrew

I can only speak to the A06 - I added USB to ethernet dongal Uni brand - it worked on plug in… from Amazon - USB to Ethernet Adapter, uni Driver Free USB 3.0 to 100/1000 Gigabit Ethernet LAN Network Adapter, RJ45 Internet Adapter Compatible with MacBook, Surface,Notebook PC with Windows, XP, Vista, Mac/Linux

I have a usb ethernet dongle I picked up from Pine64 that works on the my CM3+ DevTerm. Plug and play.

I have an old adaptor which I’m not sure is available anymore (I got mine back in 2015 from Amazon for $12). But it is plug and play too. I generally plug it in before turning on the DevTerm (A06), but it is recognized even after I boot up.

image
(There appear to be newer models of this device that have a 3 port USB hub built in.)

1 Like

Hi,

That’s not quite what I mean. I have used ethernet/USB adaptors with the devterm and they work fine.

What I’m asking is about a ‘USB Gadget’ . Linux has the facility (where the hardware supports) of being an OTG device.

e.g. I connect USB OTG cable into a windows machine, and into a running devterm. The windows machine will see (at least) a USB ethernet. You can configure a dhcp server on the devterm to provide a limited range of IP address, say with a netmask of 255.255.255.252 allowing only two hosts.

This would allow me to remote desktop into the devterm and use the large monitor and keyboard as if it was connected.

I hope that clears things up a little.

Regards,
Andrew

I thought of that also, but it looks to be more hassle than it’s worth. I use Putty with Xming to remotely run individual applications, and X2go if I need a full screen desktop. Both running on cheap old win10 computer.

I have used it before, it’ pretty good. Because it’s, effectively, a private network you easily copy files both ways. You can also set up the Linux system as a router using it’s connection, whatever that may be.

Thanks for the tips.

Andrew

Forgot to mention I use RDP to get a remote desktop, that works well too.

Andrew

1 Like

have you ran RDP on the DevTerm? I tried VNC server but the last time I loaded it to the Clockwork it corrupted my SD card… may have been a bad update/upgrade session - I have flaky wifi and went to the hardwired ethernet over USB since then and have had less problems…

M

I tried tightvnc, and it ran fine. RDP was too slow so I installed x2goserver. I use it on all my Linux boxes, I use the x2go windows client to access. I also use Putty and Xming on windows for individual apps as I previously mentioned.

sudo apt install x2goserver

I also recommend installing the Synaptic graphical package manager. It lists all available packages.

sudo apt install synaptic

It shows up in the menu, but for some yet unknown reason, it doesn’t start with sudo privileges. Haven’t tried figured that out yet. For now I just start it in an Xfce terminal:

sudo synaptic&

Stacer is a good graphical system manager:
sudo apt install stacer

Hi,

I do, it runs really well. Responsive enough for serious use.

Regards,
Andrew

Is there a specific RPD server you use? I’ve only ever used it to connect to Windows machines, and have usually opted for VNC or another solution. But if the performance is good I’m curious about your setup. Thanks!

Take a look at https://linuxize.com/post/how-to-install-xrdp-on-ubuntu-18-04/

Start at “Installing Xrdp” and enter the commands on the devterm

If the machine you are connecting from is also a Linux box, I suggest remmina as the client.

You can also configure a shared drive, which appears on the remmina desktop. This can be used to transfer files back and forth.

1 Like

I think my RDP speed issues are due to the fact that I am using a 10 year old laptop built for win7 to run the remote clients. :slight_smile: …re-purpose, re-use!