clockworkpi

Wi-Fi (wireless) issues

I was wondering if anyone has any fixes for the wireless.

I am unable to connect to my home internet and I am not sure if it’s a hidden network issue, or a dual 2.4/5Ghz issue.

I am not going to ruin all my other devices connectivity by changing everything around… but it would be nice to have a fix for the clockworkPi.

Does anyone have any ideas??

I ended up using an old router to create a separate 2.4G access point in my living room. This gave the GameShell a strong enough signal to maintain its connection without modifying my primary router’s configuration.

Yeah, I was thinking I may need to do the same.

BUT… it really should not be necessary.

I am still hoping someone will come up with a good fix so I don’t have to spend more money to get this connected to the internet.

1 Like

Have you seen these options? How to disable wifi power save to prevent disconnects

That’s not really necessary anymore with the recent Launcher updates. There is now “Power Options” in Settings that accomplishes the same thing.

LasVegas

Yes, the developers added the power_saving off to the launcher. But if his wifi is unstable is most likely he still has an old launcher

I can’t even connect at all on my home network.

If I use my portable WiMAX router (that I use for work) it will connect to the router, but the problem is I do not get wireless on my portable WiMAX router at home ( live in the country) so at best I can just transfer roms from my pc to my game shell.

I took my gameshell to work (in the city where I get internet on my WiMAX router) and updated my gameshell but it still won’t connect at home.

I know it is a hidden network issue or a dual 2.4/5ghz issue, and I am not going to change my entire network setup just for the gameshell.

I also won’t unhide my network as then all the vacationers try to steal Wi-Fi when they hit the beach.

Try this, it works great with winSCP!

Interesting, so you’d like the option to add, manually, your SSID for your wifi AP?
I think we could do that.

I know your network is hidden, but do you have WPA2 enabled?

Yes, WPA2 enabled, dual 2.4/5ghz and hidden (so you need to type in the name of the network to connect).

With the gameshell, it shows [hidden] and the wireless signal strength for the 2.4 and 5Ghz but loops forever in the “connecting” stage.

If I can manually add my wifi (ssid, encryption etc.) that may help.

gameshell uses wicd for its wifi

OK, then how do I edit the wicd file on the gameshell?

you can shell into the device and execute wicd commands:
http://manpages.ubuntu.com/manpages/cosmic/man8/wicd-cli.8.html

OK, still cant get it to connect. I am able to see the “” networks in the command line and get the channel info etc… but not able to get the gameshell to connect. I even unhid my network temporarily to see if it would work and no go.

Really don’t know what to do at this point (I have to do all this with no internet access as I can only ssh into my gameshell using my wimax router which is unable to receive an internet signal at home).

Any help is appreciated.

Try:

sudo wicd-curses

And try to set up the wifi from there

OK, I think it is figured out… what a pain.

I was able to connect to my hidden network last night and ssh into the gameshell with no disconnects.
It did take a minute for the “hidden” network to show up in my list of available connections but once it did, everything was fine.

I still will play around with the connection settings to see what I can do to make it better then maybe I will write a tutorial (if I can remember everything I did to make it work).

1 Like

I would love to see a write-up of how you got it to work. I am having issues with connecting to my hidden network at home. I was able to update to the current interface through my cell phone hotspot but nothing more than that.

Ok, wouldn’t say it is the best tutorial ever but it should get the job done.

You can find it here

Hi Guys,

So I have faced the same wireless issues after unboxing my new precious thing, I could not dumb down my router’s WiFi enough to make it work with it, and I really didn’t want to dig out my old routers for this, and I have eventually found another working solution, to create a hotspot of my laptop.

There are several ways to achieve this, there is a guide which covers most of the methods, I personally recommend Connectify, which would make the task very easy and also provides internet connection sharing from your ethernet to your wifi module (when using a laptop, or having ethernet and wifi on your computer)

This actually tested and working for me using Connectify and Win7 with my laptop connected with ethernet, and providing the hotspot with my wireless module.

Cheers,
xel

Hi, so I have made two little script for the netsh part, I recomment using this only for local connection for transferring files from your computer to the device, without Internet connection sharing.

Wi-Fi AP ON.bat

@echo off
rem Make sure the Wireless adapter is enabled with physical switch
rem before enabling the interface itself
rem netsh interface set interface "Wi-Fi" ENABLED
rem netsh interface set interface "WIFI" ENABLED
rem netsh interface set interface "Wireless Network Connection" ENABLED
rem timeout 5
netsh wlan set hostednetwork mode=allow "ssid=legacy_bridge"  "key=ThereIsNoCowLevel" "keyUsage=persistent"
timeout 5
netsh wlan start hostednetwork
timeout 5
echo ssid legacy_bridge on
timeout 5

Wi-Fi AP OFF.bat

@echo off
netsh wlan stop hostednetwork
rem timeout 5
rem This below disables the Wifi interface
rem netsh interface set interface “Wi-Fi” DISABLED
rem netsh interface set interface “WIFI” DISABLED
rem netsh interface set interface “Wireless Network Connection” DISABLED
timeout 5

1 Like