Wierd Battery, SD and CM4 8GB Upgrade Issues - All Solved

Thought I would share my issues incase anyone else has the same problems.

Problem 1: The device would only power on with USB. The battery showed 0% charge and showed no signs of charging. As soon as USB is disconnected the device would die. Another symptom is that the power/charging LED behind the power button does not light up (I didn’t even know they existed until this was solved).

Solution: The battery board was not connected properly to the motherboard. The connectors are wierd and sit at a 90 degree angle, so what I initially did is sit the battery board flat and push the connectors in sideways. Instead you should push the connectors in at a 45 degree angle and then twist the battery board down so it’s flat.

Problems 2 and 3: I swapped out the CM4 4GB for an 8GB model and also replaced the 32 GB SD card with a 256 GB one. (tip: only upgrade one part at a time!). After doing this the device wouldn’t boot. I could see the screen getting power but nothing appeared on it. I put the original 32 GB SD card back in. Still nothing. I swapped the CM4 back the 4GB and it worked. I put the bigger SD card back in and it didn’t boot again. This was an odd situation where it seemed like the uConsole would only boot with a 4GB CM4 and a 32GB SD card.

Solution: The 8GB CM4 and the larger SD card were actually fine. The issue was how I was inserting the SD card. My SD cards catch the case slightly and it can seem like the SD card is in when in fact it is not fully inserted. I reseated the motherboard to help with this. Basically when pushing the SD card in, it must “click” for it to work. It’s not enough that it appears to be in there.

Hope this helps.


These are great observations and great tips. Thanks for sharing them!

Making sure everything is seated and connected properly is a good first thing to check if you are having weird behavior with uConsole or DevTerm. And just generally good advice for any electronics or kits.

1 Like

I can absolutely second what you said about carefully inserting the battery board at an angle. I didn’t connect it properly on first try and only one battery cell was charging, so my uconsole always switched off at 50% power. :woman_facepalming:

1 Like