clockworkpi

"x11 not available" coming from SDL_GetError() on my GameShell game

Hi I am trying to write a breakout clone using SDL to work on the GameShell.

When I run it on the GameShell, SDL_Init(SDL_INIT_EVERYTHING) fails with x11 not available.
I am running my game like this in the shell script:

SDL_VIDEODRIVER=x11 DISPLAY=:0 LD_LIBRARY_PATH=/usr/lib/arm-linux-gnueabihf/ ./breakout 2> breakout.err 1> breakout.log

If I remove the SDL_VIDEODRIVER variable I get this error: No available video device

Has anyone tried to make an SDL app for the GameShell and run into these errors?

Thanks!

ssh in gameshell and run

ps aux | grep x

check if the xorg is on :0 , if you see :1 or :2 or even more
try to replace the DISPLAY=:0 to DISPLAY=:1

1 Like

Thanks for the response. Looks like Xorg is, in fact, running on :0,

cpi        964  0.1  2.6  49000 26900 tty1     Sl   12:19   0:02 /usr/lib/xorg/Xorg :0 -xf86config ~/launcher/.xorg_lima.conf -nocursor vt1 -keeptty 

Turns out that musl (the C lib I am linking with) does not support dlopen(), which SDL requires. I am going to attempt to link to glibc now

3 Likes