A04 /proc/cpuinfo only showing 2 cores (should have 4)

sudo apt install devterm-gearbox-a04

yes, this installs to /usr/bin

If there are 4 cores, shouldn’t the program’s flag be -4? Why have you done -5?

Oh, I see. The output shows that each numeric entry is a different mode. 5 is “for performance-first tasks”. I don’t understand why this program has linked performance speed to core avaliblity. Shouldn’t the system always have 4 cores, with the speed of the clock able to be changed as needed? According to the output, mode 1 has only one core enabled, mode 2 through 4 has 2 cores enabled at varying speeds, and Mode 5 has all 4 cores enabled at apparent max-speed of 1080MHz. Why can there not be standard modes having all 4 cores enabled at minumum speed (listed as 720MHz) as well as several other modes of all-four cores enabled?

One non-confirmed issue that I haven’t reported is that once I use 4 cores under heavy load, e.g. compilation, the machine may shut down randomly, no matter on battery(the panasonic NCR18650B ) or with charger. Also checked battery board to core board connection, which is perfectly attached.

Using 4-core will also decrease the battery time, a lot.

So I guess there are some reasons why it’s defaulted to 2 cores…

Shutdown under heavy load is most certainly overheating. My A04 DevTerm overheats like crazy, using the stock heatsink. Try a pure copper m.2 ssd heatsink and the fan shroud to better channel air. Also change the fan script by lowering the target temperature and removing the 5 second fan shutdown every 30 seconds.

It got my A04 from idle at 60° down to <40° idle temp.

I’m not so sure about that. During my testing I stressed my A-0604 with all six CPU cores and the GPU enabled at their maximum speeds for a solid ten minutes; it started throttling after just three seconds, but never crashed. It just ran really, really slowly…

It could be the batteries, when the load is too high their protection citcuit (if they have) it triggers.

My A04 shutdown when I was building something with 4 cores. Before shutdown, the last temp shown was 104C… Certainly overheated.

I opened the expansion-port slot and saw that the plastic for the backpanel had melted and left waxy trails all over. Following setting to mode 5 and trying to run a kernel compile.

This is probably due to the fact that the fan is useless because there is no airflow in the device. The fan is just pushing air outside of the machine rather than through it. Someone has made a Fan shroud for Devterm to fix this defect.

It’s also probably a good idea to modify the script that controls the fan to ensure it’s not shutting off every 30 seconds for 5 seconds, and then turning back on. I’m still not sure why that’s the default behavior. (Not sure if it is on A04, but the script on A06 cycles the fan like that.)

I can report that this also occurs on the A04. Throughout the entire Kernel compile (which I am unsure if the system switched to it) the fan was running full-blast repeatedly and routinely shutting off. As far as I can tell it is pointless though because there is no airflow in the device, and the fan is not covering anything to cool down except the expansion card. Is there a chip under the fan?

I’m not sure what, if anything is under the fan. I was kinda hoping the ClockworkPi folks would provide the improved heatsink solution they posted, but I guess it’s on us to source the materials. I’m not a hardware guy so I don’t have this kind of stuff lying around, and it looks like the only way to purchase most of it is in quantities unneeded for this solution.

I probably need to ask a friend with a 3D printer to get the fan shroud made as well, since I don’t have a 3D printer and it seems silly to use a paid online service for something so simple.

While the DevTerm hardware is powerful, it’s a shame it can’t actually be used to its full potential (or even near its potential) without such modifications.

So far I’ve been too afraid to run with all the CPUs on, and I’m kinda glad I’ve been overly careful based on your picture. :frowning_face:

This is my copper heatsink solution (pre fan shroud installation)

1 Like

You have that copper incredibly close to the battery coil. I think that is extremely dangerous. You should break that copper into smaller portions and put it into a different allignment.

Thank you for your advice. While there is still more than enough clearance installed, if the heatsink would become loose, it could potentially be catastrophic. So better safe than sorry.

I have used a rk3399 module before, and that’s the proper heat sink with which I can run 6 cores 80% load.

1 Like

Are there any other parts of the backplate damaged? I am curious because of how far away the part of the backplate in your photo is from the actual processor.

I have not yet taken it appart. I’ve been too preocupied with the framebuffer errors which I still have yet to solve. I’ll dismantle the machine later and upload a photograph.

strange, I tried it but the terminal says command not found

Ha, I have fixed it (well, I am new to linux).

sudo ‘/usr/bin/devterm-a04-gearbox.py’ -s 5