A06 Desktop Evironment / Booting Issues?

Hey guys,

I got my DT A06 yesterday and I love it. Regardless, I am having some issues with the experience and was wondering if you guys have had the same problems as I saw some related issues but not exactly the same. I’m running into kernel panic - like, a lot. Typically, If I reboot 3 times one of the three will work, but the other 2 will fail. I am a Linux user but have not built any kernels so that’s a bit new to me. However, if someone wants some information from like journalctl or something let me know!

The other problem is that I’m getting a lot of freezes. These don’t go away and tend to happen after the device has been on for 5+ minutes. Weirdly, they’re only happening in XFCE, and running a new shell with no DE never crashes, no matter the use case. I uninstalled and reinstalled xfce and lightdm, apt upgraded everything and am still getting this so I’m wondering if my firmware or kernel is messed up somehow. Anyone seen this?

P.S. idk how relevant it is, but the fan has never turned on on this guy - I’ve checked the connections and everything else on the daughterboard seems to work fine. I did see the post in which it was said the default fan threshold may be 80 celsius, but I’m grabbing at air trying to figure this out.

Thanks!

The fan is a systemd service,
DevTerm/Code/devterm_fan_daemon_rpi at main · clockworkpi/DevTerm · GitHub you can check the status of the service with systemctl status devterm-fan-temp-daemon

If its not enabled you can:
systemctl enable devterm-fan-temp-daemon
systemctl start devterm-fan-temp-daemon

Mine never reached 80 so it doesn´t turn, you can edit the script and reload the unit file.

2 Likes

Thanks!

I will give that a try tonight. I did notice going through journalctl there were a number of registering errors with the daughter board component related regulators (USB and fan specifically). My understanding is that this points to drivers / kernel but I did notice a dog hair lodged in the m.2 slot when I tore it down to reseat the board. We’ll see!

Thanks again,

Dan

Can you post the specs on the battery cells? My experience is that the unit is quite fussy when it comes to power draw.

If you can run the unit stable when plugged (with a good solid power supply that puts out enough power) then the issues may point to your battery.

I will post the specs later when I get off work, however that was my thinking too but it is just as unstable when plugged in. Something to consider!

Interestingly, I get “unit devterm-fan-temp-daemon.service could not be found”. Is this something I need to build from source or is it supposed to be working out of the box?

Actually I had the time now - I’m using Hohmlife v4 cells. These are the specs:

Capacity: 3015mAh
Max Charge Rate: 4.43A
Max Charge Voltage: 4.2V
Continuous Discharge Rate: 22.1A
Max 80oC | 3.2V cut-off: 31.5A
Pulse | Peak6: 37.1A
Cycle Life Retention: 500 @ ≥70%, 1000 @ ≥60%
Chemistry Type: QSP Li-NMC

Thanks!

If you do ls /etc/systemd/system you will see all the unit files. I just did it and its actually called devterm-fan-temp-daemon-a06

So:
systemctl enable devterm-fan-temp-daemon-a06
systemctl start devterm-fan-temp-daemon-a06

There are some guides here about fan

So update: I’ve checked and verified the a06 fan service is installed and enabled, started it and changed the threshold to 60 Celsius. However, this has let me desicover the device is freezing far before 60 Celsius, so I’m not too concerned about the fan anymore.

Awesome resources though, thanks! I’ve reflashed the chip with the a06 image and am still having problems so I’m wondering if my TF card is just bad honestly

1 Like

I’ve reimaged the micro sd like 6 times and have still been having the same problems. Journalctl is showing a number of errors including:

“reg-fixed-voltage usb(all): Failed to register regulator: -517” as well as the same error for “vcc3v3 & vcc5v0”

“rockchip-usb2phy ff770000: Failed to create phy”

“fan53555-regulator 0–0040 and 0041: Failed to register regulator”

“OF:graph: no port node found in /syscon@ff770000/usb2-phy@e450/otg-port” and many more.

I love a good project and so far have been enjoying this but definitely getting a little frustrated. Starting to feel like I waited a very long time for a broken unit. If anyone has any ideas please share!

Also, ordered a new micro sd to test but waiting for that to come in. Starting to get some sad thoughts about the hardware though regardless

New SD card didn’t do it. Still having the same errors in journalctl. tail is unable to pick it up before the system crashes. Really disappointed

Just curious - how did you image the new SD card? Same weird errors sounds like same corrupted image to me?

I imaged it by taping it to a cd-rw and burning the Raspbian image of course…

Lol jk but good thinking. I thought the same too but noone else is having this problem with the a06 image! I am imaging using balena etcher and the a06 image supplied by clockworkpi. I’m on my phone otherwise I’d find the image, but I tried to do what others had mentioned was working here on the forum.

On this subject though - I ended up with a 16gb as card out of box. I can’t remember if that’s right for preorder but I know the a06 is sold with a 32gb and the cm3 is sold with a 16gb currently. My sd card had a single blue dot of paint on the face of it, which makes me nervous that something was different about it. Since I’ve replaced the SD card and still having issues, I’m concerned that there is some chip / firmware flashing that happens in in production which may have gotten cm3 firmware instead of a06 firmware. I don’t know the process so I don’t know how likely or how serious that is, but I have accidentally made similar mistakes myself in a small company when programming products and in that case it broke functionality.

Image: http://dl.clockworkpi.com/DevTerm_A06_v0.1.img.bz2

Don’t worry about flashing a new SD card, I did so too and my A06 runs fine. And my factory card had a blue dot too (it’s a 16GB though), they probably use it to distinguish which image is on it.

Honestly, the errors you posted look like there’s something wrong with the hardware. Maybe try taking out the extension board and boot without it, see if that goes better?

1 Like

That was my first instinct! The errors line up with expansion board drivers or hardware that is not present on the main board. Wanted to assume the worst after trying everything else though. I will try that today and post the results

Ha! I always image mine with hammer and chisel, but then again I’m old school. Punch cards are for kids!

Seriously, it does kinda seem like hardware. I also reimaged mine to a larger card (64GB) and it worked fine. The only other thing I can think is maybe reseating the expansion board? Best of luck!