Anyone have RetroArch working on A04?

Trying to get RetroArch running. I’m curious how the wide screen and custom gamepad keyboard buttons in the upper left & upper right will work for games.

Attempt 1: Install using sudo apt install retroarch retroarch-assets.

Result 1: Seems to work, looks right, able to configure input buttons, however, no cores, and building cores seems tricky. Online updater cores would be better…

Attempt 2: Follow the RetroArch Megathread - #63 by eashwar

Result 2: Can’t seem to get the assets right. Online Updater for assets runs, but then still thinks assets are missing. Doing a git clone following this post [RetroArch Megathread - #54 by Gibbon] doesn’t seem to work any better. And, still, no cores option in the Online Updater.

Tips? Suggestions? Anyone have this working?

1 Like

I have it up and running on mine currently with one caveat: SNES ROMs won’t start, but all others seem to work fine. I installed the PPA version and installed cores using sudo apt-get install libretro-* where the asterisk would be which core you want to install. If you don’t know the name of the core, you can type sudo apt-get install libretro- and then hit TAB to prompt the auto completion suggestions. If you install the PPA version and then enable online cores within the UI, it will crash the application in my experience.

Source: Installing Cores - Libretro Docs

Thanks! For anyone else’s reference, here’s what I did:

Uninstall the broken RetroArch installation and remove the git source:

rm -fr ~/.config/retroarch/assets/*
cd ~/retroarch
sudo make uninstall
cd ~
rm -fr retroarch


sudo apt install retroarch retroarch-assets
# browse the autocomplete from: sudo apt-get install libretro-<TAB>
sudo apt-get install libretro-genesisplusgx

Create the directories

mkdir -p ~/retroarch/{games,saves,states,system}

In RetroArch, configure the directories to point to the above directories. My previous controller configuration was still intact and worked.

Everything worked from that point.

1 Like

Would you mind trying out the snes9x core and trying to run a ROM on it to test for me?

Sure. I tried two cores, libretro-snes9x and libretro-bsnes-mercury-balanced.

snes9x: Black screen. First time there was an error on the command line about a missing save file. The save file seemed to have gotten created automatically. The second time, no error messages, but still, black screen.

bsnes: Crashed RetroArch.

Seems like at least those SNES cores don’t work, or aren’t built correctly.

Update: I got SNES working. (Note: The pre-built core linked here did not work: RetroArch Megathread - #263 by infernalmaster)

git clone
cd snes9x2010
chmod -x
sudo cp /usr/lib/aarch64-linux-gnu/libretro/

Sound is pretty choppy (I’ve already increased the Audio Latency to 128 and set the Audio Resampler Quality to Lowest, or Don’t Care – no improvement). But this doesn’t seem to be specific to SNES.

I don’t seem to be able to attach a file here, or I would have attached the working binary.

1 Like