Retroarch on Uconsole

I see that Retroarch is preinstalled, but when I fire it up I do not see the normal (or any way) to install cores, the interface looks super basic.

Have you tried emulationstation

I was able to get most cores to work by manually adding the arm64 core builds from GitHub - christianhaitian/retroarch-cores to the libretrocores folder in Retroarch. This post was very helpful:

However, you can also just straight up install RetroPie on this system, which require less tinkering to get functional cores installed and also provide emulationstation, which is a nicer interface:

cd
git clone --depth=1 https://github.com/RetroPie/RetroPie-Setup.git
cd RetroPie-Setup
chmod +x retropie_setup.sh
sudo ./retropie_setup.sh

Basic Install >> Quick Install

You can also switch the menu driver in Retroarch from rgui to xmb, which will switch to the higher resolution blue interface that’s more familiar from desktop installations (although I personally think the pixelated version has its charms).

Do you know an faq for installing on the uconsole

1 Like

apt-cache search libretro should show you a list of cores that you can install, and you can do, for example, apt-get install libretro-beetle-psx.

That’s the rgui interface. It used to be the default for retroarch. If you want to use one of the other UIs, from the main menu you select Settings, Drivers, then Menu.

THANKS that was a big help!!

that worked great but the screen for emulation station is sideways

Sorry was busy but i dont have a uconsole myself yet so my help would be limiting, my go to retro gaming is emulationstation/retropie, theres plenty of documentation online but its something i wouldnt know how you could apply to uconsole

thx for the hint, however my installation was failed with a bunch of information saying xxxx could not be installed after a long long wait. I’ve searched the internet and found that could be a problem in rpi bullseye, have you encountered any similar problem with that?

I had the same experience as you. I plan to screenshot the missing packages and see if I can get them loaded another way, and then I can try the script above again.