clockworkpi

Custom D.E.O.T. V2.0+/Clockwork OS v0.5 image - With customised DEOT interface, Kernel 5.7, Optional 1400MHz OC, Debian 10 Buster, Retroarch 1.9.0, Mupen64+ plus more! (Current build: 200903)

I already wiped my card out , i dont care I just wanna get N64 emulation working.

My dude. I am trying to help. If you could continue this in the OTHER thread I am helping you on, that would be fantastic.

All i saw was black screen and no light even for power. So i just flashed it again with the 0.5 official image. now getting black screen completely, no LED light or anyhting sigh

now trying to flash it again…

black screen could mean uboot is bad, be sure to unmount properly the sd card before flashing it and make sure write is really over and sd properly unmount after flash and before eject it

it could also be your sd card adapter who’s bad, real sd to micro sd work better than usb, one usb adapter i own cannot write more than 4gb (wtf), try another one to be sure

1 Like

igot it booting up, using the reset button on the mobo . now its working on the latest 0.5 image but still no mupen64 working… my wifi was too slow to dl the dependencies…

(try disable wifi power save, How to disable wifi power save to prevent disconnects

1 Like

Since I wrote that post, that functionality was integrated in the power modes in the Launcher. Check the settings, the performance mode should disable wifi power save.

1 Like

Still , the DEOT images dont work at least none of them did for me. only getting black screen. And i tried every mirror, and downloaded the 0.4 and 0.5 versions, tried them all flashed about 10 times my sd. I can get the 0.5 clockwork image to work , the official one, but this one just black screen. twice now. i just had it working in 0.5 too.

now to go back to that image again and flash it again TRY this wifi power safe bs and see if that works. (btw not using this topics image im using the offficial 0.5 one cause none of the ones here work.

i beleive i had performance mode on anyway

and i dont even know if it was the wifi or if it was just running into errors installing in which case fixing wifi wont matter

it’s strange, as you reset push fixed an issue you could also try disconnect the batterie completely and powering on with usb wire

if you have wifi issue you will see it fast while just type command or transfers files

1 Like

Hi @wayfarer. Could I propose that you please start a new topic, especially seeing as what you’re posting about is not relevant to the image that this thread is about?
a) You’re discussing mupen dependency installation. This is already done in this image. I am literally trying to help you with that in another thread.
b) You’re talking about issues with flashing images, power profiles, and hard resetting. This is something that can have its own topic.
c) Problems don’t seem to be pertinent to just this image, but issues that the user is having with hardware; both with writing the image, and wifi stability.

I’m happy to answer your questions externally, just not in this thread if that’s okay.

And please don’t reply to any of the above points in this thread. They are suggestions for starting a new one.

I want to try and keep this thread tidy. So far, it’s not getting off to a good start.

In other news, here is a mega upload of the same file:

https://mega.nz/#!0rBxgSjC!Shwg888_vv_pRRExN_UmlRMQc3atT_D_7r5jrqLP0to

1 Like

seems need a decryption key for downloading

1 Like

I already have like 5 copies of the DEOT image i dled from basically all the mirrors, and they dont work , i was trying to dl the DEOT images all day from every mirror… i think its cause the file size is too big , google doesnt scan them for viruses or something , dont download right in any browser, i think if it was in a torrent it would work

Thanks for sharing. I brush the machine in the afternoon. The following problems occurred:

  1. SFC simulator cannot find ROM folder, MD simulator cannot find ROM folder, and arcade simulator does not have ROM folder.

  2. When changing the theme, loading will be displayed all the time, and loading will still be displayed after restarting.

  3. If the menu in the simulator can have Chinese, it’s good.

I like playing games, besides being a Chinese. Thank you, brother.

报错

1 Like

Perfect!!! Thank you so much. This was the kind of feedback I was looking for re how to improve the image.

  1. I know exactly what to do to fix the rom directory problems; and what I did to break it! Can you confirm which emulators didn’t work re SFC and MD? I mainly was testing the standalones, so I am guessing it was the Retroarch cores. I will post up updated action.config files, and upload an updated image.

  2. Strange that changing themes does that! I admittedly only changed and toggled the DEOT and Default themes, since I don’t use OP-1.
    Was it OP-1 you had problems with?
    This is possibly related to the custom fonts required of the DEOT theme and the modified skin_chooser.py. I’ll simply restore it to the stock one, and forego the fonts. (And find a better way to use custom fonts!!! Grrrr!!)
    I’ll provide instructions for those who want them, but also update this in the next release.

In a nutshell, just change your skin to the default, then go into ~/launcher/sys.py/UI, then find the file called skin_chooser.py, rename it to skin_chooser.py.bk or something, then rename the file called skin_chooser.py.bak to skin_chooser.py. (Or was if skin config? I’m just writing this from memory in bed haha)
Afterwards, reboot the system.

  1. A lot of the Chinese would have to be hard coded into the emulators, which unfortunately I didn’t write. Also my Chinese is SHOCKING, despite being Chinese myself. If they ever release translates versions of the standalone emulators, I will be happy to include them! :slight_smile:

Again, thank you so much for your HELPFUL feedback!

In other news, @wizz has provided a helpful mirror for the download: https://pcroz.stackstorage.com/s/a26iBYxvkQ5VSgS

@guu - hopefully this mega link will work. https://mega.nz/#!0rBxgSjC!Shwg888_vv_pRRExN_UmlRMQc3atT_D_7r5jrqLP0to
The previous one was one I provided while it was still uploading. I couldn’t get the permissions properly sorted, and was way too tired haha!!

@wayfarer

For those curious of @wayfarer’s problems, the solution was cross posted across a few threads, including this one. Summary: user downloading problems.

Their mupen64 problems were resolved as well.

Hullo! So I had a look at the action.config files for all of the SNES and Megadrive emulators. I thought, maybe I may have forgotten to specify the modified rom directory, but it appears as though I have! I have also provided a screen shot, showing the games directory structure, indicating which directories are where. I did remove the SFC specific rom folder, since it didn’t make much sense to have SNES roms doubled up in two directories, seeing as Snes emulators would have a common folder; and likewise for Megadrive.

Try and push X, or whatever button is required to refresh your rom directory. That could help! Also, just put the roms directly into their respective directories without any subdirectories.

I just flashed a bunch of fresh images onto an SD card, and tried to change to the default theme. It appears to be okay. I then tried to flash the OP-1 theme. No dice. That’s when I got the stuck loading screen. For now, simply don’t use the OP-1 theme. I will get rid of it in future releases, since this theme contains the DEOT theme as the dark alternative.

A fix for now:
Edit the ~/.gameshell_skin file to contain /home/cpi/skins/DEOT (you only need to do this if you attempted to load the OP-1 theme) then invoke a sudo reboot, and everything will load like normal. Then just… don’t use the OP-1 theme.

I don’t think just revising the OP-1 theme is enough to justify a complete re-release of an image, so i will wait for more things to be detected or updated before a new version comes out :slight_smile:

2 Likes

Thank you, brother. I can have a good time.

1 Like

How are you creating the image file? Just curious on what could be done to save space since writing 16GB to an SD card is a time consuming process for many.

Ah yes, this is something I will eventually be implementing, once I get around to setting up later.
This is how I’ll be going about it.

New update on its way! It will come out in a few hours. The 200110 build I think is going to be the one that will stay for a while, and is basically problem free. This is the one to get!

Notes for a previous build that I wasn't happy with

Here are the changes:

Build 200109

Updates: (General cleanups and updates)

  1. Performed a git pull and launcher update

  2. Performed an apt update && apt upgrade on system

  3. Performed a general asset/core update on retroarch

  4. Modified mpd.conf to disable unused plugins, eg Qobuz, Tidal, id3v1 encoding

  5. Pre-downloaded all the retroarch cores used by the gameshell

  6. Performed a chmod +x the expand and mail remove script, just in case it wasn’t

  7. Double checked the relocated core directory (in .config/retroarch) was recognised in all apps

  8. Double checked the action.config files all directed to the same customised simplified rom directories

  9. Moved DEOT extra apps to apps/Menu, and fixed bug with duplicate 20_Retro Games directory

  10. Included the DEOT loading screens.

Fixes:

  1. Power off is now reliable

  2. Removed OP-1 theme, since it was causing more problems than benefits

Problems:

  1. Pico-8 installer doesn’t appear to be as visually verbose initially, no longer asking users to provide the pico-8 zip file. It also needs to be double executed for it to run. At the end of the day, it still works, just with no visual feedback initially. Also, the football button dialogue is incorrect. Not sure if this is just something in 0.5

  2. With Cave story being within the launcher/menu directory, doing a launcher update will inherently break it, given the change of the core directory to .config/retroarch/cores. I’ll deal with this later, adding it to a stash.

  3. In DEOT theme, Airplane mode toggle font is too large, and clips

  4. Substituting the custom volume and sound settings menu options with the DEOT version kept on making intermittent errors, including the power off issue, and freezing. I’m investigating this, which will take a while since I can’t identify what is causing said problems, and boy does it take a long time to constantly start from scratch!

  5. The latest apt upgrade made GL drivers in retroarch no longer valid. All this means is no more XMB or GLUi.

  6. What the heck? Mupen stopped working? This is not cool. Something went wrong with the apt upgrade.

EDIT: In fact, you know what? The apt upgrade broke far too many things, no doubt graphical in nature. Initially, it was just an apt update && apt upgrade. Then things broke, so I thought to try a dist-upgrade/full-upgrade. Nothing much improved.
I am going to let the uploads continue for it, in case anyone wants to try and work on troubleshooting a fully apt upgraded system, but personally I’m going to re-release another image, based on the 200106 build WITHOUT an apt upgrade. Retroarch GL drivers broke. So did the functionality of Mupen64+ which is one of the trump cards of this image.

It’s killing me. I need to fix this now.
I’m keeping the notes above, for historical update purposes. The next image is starting from the same point, basically skipping the apt upgrades, and fixes to contract said problems.

Build 200110
https://mega.nz/#!tuQkAaQL!pY7tRyStfjvl25VWhMemFWJVL8ifJAQLKvakU0kbv6w

https://pcroz.stackstorage.com/s/a26iBYxvkQ5VSgS

A lot more bulletproofing, and allowance for being updated. Generally, fixes this time round.

  1. Same as above, just abstaining from doing a apt upgrade.

  2. Pico-8 Problems resolved - just needed to initially “prime” the app, running it once without the pico-8 assets.

  3. Cave Story update woes mean I just need to keep the so file in the apps/emulators directory. Very annoying, but it’s fixed.

  4. Skin manager has been restored to stock. Unfortunately this means no custom font, but does allow installation of custom skins. I still kept the OP-1 them absent, in case it breaks things later.

  5. DEOT Edge lord apps moved to slots 40, 41, and 42. Despite the redundancy error with 20_Retro Games, a launcher update will unfortunately restore this, thus this should alleviate the problem once an update is invoked.

  6. Kept the custom brightness and volume settings menu as stock. They’re such a minor thing for now, and not worth sacrificing stability or the ability to update.

  7. Everything should be updatable via the settings menu as if it was 0.5 stock with points 3 - 6 changed as they are.

  8. The fancy XMB Retroarch menu is back in action.

  9. Mupen is running. Again! Small optimisations have been made for speed, and the inclusion of state save/load via shift select/start. Menu now does turbo, and quit is invoked by shift and menu.

3 Likes

200110 build: resize in the utility folder doesnt seem to work, i still show 16gb total after running twice with my 256gb card

Edit: disregard. turns out you need to connect to wifi first

1 Like