Custom D.E.O.T. V2.0+/Clockwork OS v0.5 image - With customised DEOT interface, Kernel 5.7, Optional 1400MHz OC, Debian 10 Buster, Retroarch 1.9.0, Mupen64+ plus more! (Current build: 200903)

Hullo! So I had a look at the action.config files for all of the SNES and Megadrive emulators. I thought, maybe I may have forgotten to specify the modified rom directory, but it appears as though I have! I have also provided a screen shot, showing the games directory structure, indicating which directories are where. I did remove the SFC specific rom folder, since it didn’t make much sense to have SNES roms doubled up in two directories, seeing as Snes emulators would have a common folder; and likewise for Megadrive.

Try and push X, or whatever button is required to refresh your rom directory. That could help! Also, just put the roms directly into their respective directories without any subdirectories.

I just flashed a bunch of fresh images onto an SD card, and tried to change to the default theme. It appears to be okay. I then tried to flash the OP-1 theme. No dice. That’s when I got the stuck loading screen. For now, simply don’t use the OP-1 theme. I will get rid of it in future releases, since this theme contains the DEOT theme as the dark alternative.

A fix for now:
Edit the ~/.gameshell_skin file to contain /home/cpi/skins/DEOT (you only need to do this if you attempted to load the OP-1 theme) then invoke a sudo reboot, and everything will load like normal. Then just… don’t use the OP-1 theme.

I don’t think just revising the OP-1 theme is enough to justify a complete re-release of an image, so i will wait for more things to be detected or updated before a new version comes out :slight_smile:


Thank you, brother. I can have a good time.

1 Like

How are you creating the image file? Just curious on what could be done to save space since writing 16GB to an SD card is a time consuming process for many.

Ah yes, this is something I will eventually be implementing, once I get around to setting up later.
This is how I’ll be going about it.

New update on its way! It will come out in a few hours. The 200110 build I think is going to be the one that will stay for a while, and is basically problem free. This is the one to get!

Notes for a previous build that I wasn't happy with

Here are the changes:

Build 200109

Updates: (General cleanups and updates)

  1. Performed a git pull and launcher update

  2. Performed an apt update && apt upgrade on system

  3. Performed a general asset/core update on retroarch

  4. Modified mpd.conf to disable unused plugins, eg Qobuz, Tidal, id3v1 encoding

  5. Pre-downloaded all the retroarch cores used by the gameshell

  6. Performed a chmod +x the expand and mail remove script, just in case it wasn’t

  7. Double checked the relocated core directory (in .config/retroarch) was recognised in all apps

  8. Double checked the action.config files all directed to the same customised simplified rom directories

  9. Moved DEOT extra apps to apps/Menu, and fixed bug with duplicate 20_Retro Games directory

  10. Included the DEOT loading screens.


  1. Power off is now reliable

  2. Removed OP-1 theme, since it was causing more problems than benefits


  1. Pico-8 installer doesn’t appear to be as visually verbose initially, no longer asking users to provide the pico-8 zip file. It also needs to be double executed for it to run. At the end of the day, it still works, just with no visual feedback initially. Also, the football button dialogue is incorrect. Not sure if this is just something in 0.5

  2. With Cave story being within the launcher/menu directory, doing a launcher update will inherently break it, given the change of the core directory to .config/retroarch/cores. I’ll deal with this later, adding it to a stash.

  3. In DEOT theme, Airplane mode toggle font is too large, and clips

  4. Substituting the custom volume and sound settings menu options with the DEOT version kept on making intermittent errors, including the power off issue, and freezing. I’m investigating this, which will take a while since I can’t identify what is causing said problems, and boy does it take a long time to constantly start from scratch!

  5. The latest apt upgrade made GL drivers in retroarch no longer valid. All this means is no more XMB or GLUi.

  6. What the heck? Mupen stopped working? This is not cool. Something went wrong with the apt upgrade.

EDIT: In fact, you know what? The apt upgrade broke far too many things, no doubt graphical in nature. Initially, it was just an apt update && apt upgrade. Then things broke, so I thought to try a dist-upgrade/full-upgrade. Nothing much improved.
I am going to let the uploads continue for it, in case anyone wants to try and work on troubleshooting a fully apt upgraded system, but personally I’m going to re-release another image, based on the 200106 build WITHOUT an apt upgrade. Retroarch GL drivers broke. So did the functionality of Mupen64+ which is one of the trump cards of this image.

It’s killing me. I need to fix this now.
I’m keeping the notes above, for historical update purposes. The next image is starting from the same point, basically skipping the apt upgrades, and fixes to contract said problems.

Build 200110!tuQkAaQL!pY7tRyStfjvl25VWhMemFWJVL8ifJAQLKvakU0kbv6w

A lot more bulletproofing, and allowance for being updated. Generally, fixes this time round.

  1. Same as above, just abstaining from doing a apt upgrade.

  2. Pico-8 Problems resolved - just needed to initially “prime” the app, running it once without the pico-8 assets.

  3. Cave Story update woes mean I just need to keep the so file in the apps/emulators directory. Very annoying, but it’s fixed.

  4. Skin manager has been restored to stock. Unfortunately this means no custom font, but does allow installation of custom skins. I still kept the OP-1 them absent, in case it breaks things later.

  5. DEOT Edge lord apps moved to slots 40, 41, and 42. Despite the redundancy error with 20_Retro Games, a launcher update will unfortunately restore this, thus this should alleviate the problem once an update is invoked.

  6. Kept the custom brightness and volume settings menu as stock. They’re such a minor thing for now, and not worth sacrificing stability or the ability to update.

  7. Everything should be updatable via the settings menu as if it was 0.5 stock with points 3 - 6 changed as they are.

  8. The fancy XMB Retroarch menu is back in action.

  9. Mupen is running. Again! Small optimisations have been made for speed, and the inclusion of state save/load via shift select/start. Menu now does turbo, and quit is invoked by shift and menu.


200110 build: resize in the utility folder doesnt seem to work, i still show 16gb total after running twice with my 256gb card

Edit: disregard. turns out you need to connect to wifi first

1 Like

This is a good point I forgot to mention! Thanks for bringing it up!
It is indeed a script that downloads utilities.
Eventually it will have an automatic expander, like the official 0.5 image, but for now this works. I probably should make it have a verbose dialogue telling people what is going on.
Just wondering how long it takes to do a large card like yours. I only use up to 32GB cards, and that takes about 20 seconds.

In other news, @Wizz has kindly updated their server to host the latest 200110 build image.

I’d say it took about 30 seconds or so for it to finish

1 Like

Thanks! Very useful information I can include, so people know that their unit hasn’t frozen. Seems that duration doesn’t change, regardless of size. Makes sense.

Update! @guu has kindly applied the auto rootfs expand script used in the official 0.5 image, and shrunk it down. What this means is it will be faster to flash the image, and one less step to expand it. Just let it do it’s thing, booting up a couple of times on the initial startup.

Here is the link. I will update the rest of the links to use this image soon!!UcFlSSAK!FrKpbT7e13a1vKiQWH2VaxLKqR7VzOitW7XoXyX3tTg

Update 2: I have updated the OP to include more information to hopefully answer more questions and problems people may encounter. Thanks to all who asked questions and tested the image.

Update 3: encryption fixed up! Link should now work. Also added some instructions on how to rebind keys in the doom and other ID game wrappers.

so far so good, just one thing on my end, anyone else having a freeze up wher trying to use settings then storage to see what you have left? mine locks up on this

I had that problem with the original post, but the latest 200110 build works fine for me

1 Like

im using 200106… hmmm methinks I should redl it :>

Noooo please use the 200110 version, ie the newer one. It freezes and locks up when using the custom settings entries in the previous version 200106, as per the notes I wrote in the issues section of the first post. I will delete the 200106 version to avoid confusion!!! Don’t download 200106.
Download 200110.

That’s what I meant the newer version :joy:

Just a heads up, this version of DEOT OS has the warehouse built in, so you should be able to open it, update it, and try out all of the game jam entries. I highly recommend you do! I have just downloaded them, and am testing them right now!
Just keep in mind, it is assuming an Xbox style BAXY button configuration. This version uses the snes style ABXY format.
A will be B and X will be Y.

Don’t forget, it’s the GameJam19q4 warehouse. It’s ridiculously easy to use. There’s no excuse not to. If only you could vote from within the warehouse! Haha.

I’m going to be dropping a new update in the next few days. Here’s a few features.

  1. Potential speed ups re mupen64plus; rebuilding it with a few changes to some parameters
  2. Retroarch 1.8.4 updated
  3. Possibly including the battery monitoring app
  4. An icon pack upgrade

If there are any bugs that need to be ironed out, from anyone who’s tried the latest image, let me know.

Also I’m always open to some requests to have things pre installed, as long as it doesn’t contain any illegal content. At the same time, probably won’t install every request for a game, since that will make things far too bloated and not to everyone’s taste.


While you are at it, you could fix/remove

1 Like

if you could make this kind of upgrade happen from the warehouse or something, instead of needing a reflash, youd be my hero

1 Like

Omg. Not just for this image but in general, having Retroarch updatable via the warehouse would be a godsend. A lot of the warehouse items install to the .config directory, which is also where Retroarch is located.
Likewise with mupen configs. That would be easy. Although I rebuilt it, installing things in the root directories as opposed to user space, so I don’t think warehouse would play nicely with that.

Let me know if I should host again !

1 Like