Devterm speakers not working

Hi there! Ever since I received my Devterm, I have been unable to get the speakers to work. I disassembled and reassembled the device two times hoping that would resolve it magically but alas! No luck. When I try to check the sound settings, it appears the OS doesn’t even recognize that there are speakers present.

Any ideas how I can troubleshoot this?

clean out the contacts maybe?

I did the mistake of assembling two speakers in the same orientation, when the instructions called out for one speaker to face opposite to each other (if I remember correctly). This resulted only one of them worked. I changed it accordingly so now it works fine for both!

But your case sounds new to me, so check to contacts. If it’s dirty, a small dab of alcohol will fix it.

If you’ve an A-04 model, there’s a known software bug. You’ll need to update the OS. Open a terminal and:

wget -O - | sudo apt-key add - 
sudo apt-key del  57B7A98BBEBA8C10CA4458810DD08811478B1249
sudo apt update
sudo apt upgrade -y
sudo reboot

Your sound should be working after that.


That fixed it! Thank you so much!