Speakers stopped working

The built in speakers stopped working. The headphone jack does work.

I have tried

  • double checking alsamixer to make sure nothing is muted
  • the “sudo apt reinstall DevTerm-patch” fix from a similar post

What are my next steps?

I have the CM4 module.

What os and kernel?

Do a

systemctl enable devterm-audio-patch

And see if that works.

If that does work I’ve worked up at new audio patch that uses the newer way to address the gpio

That did not work.

Kernel is 5.10.17-v8+

So you tried

sudo apt reinstall devterm-audio-patch


systemctl enable devterm-audio-patch

now in /usr/local/bin/ the file called audio_3.5_patch.py back it up and replace it with this.

then run the following again

systemctl enable devterm-audio-patch

let me know if that worked

Ive found the audio settings in raspi-config helps with the issuetoo

I modified the file with no success.

I’m still only getting headphone as the only audio choice

do the following to see if we can force them to work

pinctrl set 11 op dh

then and post the output and tell me if it worked.

pinctrl 11,10

have audio playing while you try this.

I’m getting pinctrl:command not found.

I’m relatively new at Linux, so excuse my ignorance. I did also try the command with sudo

replace the original file you backed up. give me the out put of this.

raspi-gpio get 10,11

then do

raspi-gpio set 11 op dh

then give me the output of again.

raspi-gpio get 10,11
raspi-gpio get 10,11


GPIO 10: level=0 fsel=0 func=INPUT pull=NONE
GPIO 11: level=0 fsel=0 func=INPUT pull=DOWN


raspi-gpio set 11 op dh


GPIO 10: level=0 fsel=0 func=INPUT pull=NONE
GPIO 11: level=1 fsel=1 func=OUTPUT pull=DOWN

Thank you for your help

I suspect it’s not fixed fixed. A reboot will reset it. We got to figure out why it’s not detecting pin 10 being low. Or why pin 11 was set to input.

Sudo apt reinstall devterm-audio-patch
systemctl enable devterm-audio-patch

And reboot for me and reboot for me then run and post the output

raspi-gpio get 10,11

Ran the two commands, rebooted, as requested

GPIO 10: level=0 fsel=0 func=INPUT pull=NONE
GPIO 11: level=0 fsel=0 func=INPUT pull=DOWN

Something is resetting pin 11 to input or the patch isn’t working. You have python installed still?

The last few days of my free time I’ve been working a driver to change the pins for the audio to not have to worry about userland.

Yes Python is installed

have you installed or done anything that might change the gpio pins?
you could compile pinctrl and see it that patch will work. besides that im not sure what could be not letting the script run or changing the gpio pins. as a temp solution you can just use.

raspi-gpio set 11 op dh

I used GitHub - WiringPi/WiringPi: The arguably fastest GPIO Library for the Raspberry Pi to get Pico-8 to run.

You’ll have to reinstall clockworks wiringpi, not sure if the way you got pico 8 setup will quit working or not. But this is the following package you’ll need to reinstall.


If you do let us know if that worked

I did reinstall it, it did not fix the sound issue.

I did get a fresh image on a second SD card, and was able to install and run Pico-8 without issue and the sound is working fine. So I’m equally happy to walk away from the mess that I made as I am to help you sort out what happend so that it doesn’t happen anyone else.