clockworkpi

Full desktop window manager configuration?

Now that I’ve got the Bluetooth working (see @lasvegas very helpful instructions) I tried to make use of the full desktop via the HDMI connection.

I don’t have a Bluetooth mouse so can’t move the focus out of the Launcher window. I tried Ctrl+Alt+t to launch a terminal window. The “Launching…” pop-up appears but I don’t see a terminal appear.

I can see a sensibly configured ~/.twmrc so I know that someone out there is using this as a desktop, but I can’t do anything but navigate the Launcher icons.

Can anyone confirm this, or is this just due to me not having a mouse to change the window focus?

now, that i have a proper micro-HDMI to HDMI cable (instead of bulky angled micro-HDMI to HDMI adapter, that covers micro-usb port and prevents micro USB OTG cable to be used), i can finally use a “desktop”-like approach with usb keyboard and usb mouse… but what the point?.. i expected to see a terminal window, but all i can see is the same “Launching…” pop-up.
i tried with the regular GameShell OS v0.5, and with Custom D.E.O.T. V2.0+, and the symptoms are the same - just a “Launching…” pop-up…

well, i would dream to see smth. like MS Continuum on the GameShell (yeah silly me…), but at least the Terminal should work as this info is on the Wallpaper.
maybe some extra steps are required to make it work?..

seems the launcher failed to start

could you try

cat /tmp/x.log

in ssh when you are under this situation?

checked ~/.xinitrc

it shows that currently dwm is WM for hdmi

nothing suspicious…

cpi@clockworkpi:~$ cat /tmp/x.log
X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.9.0-8-arm64 armv8l Debian
Current Operating System: Linux clockworkpi 5.3.6-clockworkpi-cpi3 #1 SMP Tue Oct 15 17:26:44 CST 2019 armv7l
Kernel command line: console=ttyS0,115200n8 earlyprintk no_console_suspend root=/dev/mmcblk0p2 rootfstype=ext4 rootwait init=/sbin/init noinitrd panic=10
Build Date: 05 March 2019  08:11:12PM
xorg-server 2:1.20.4-1 (https://www.debian.org/support)
Current version of pixman: 0.36.0
		Before reporting problems, check http://wiki.x.org
		to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
		(++) from command line, (!!) notice, (II) informational,
		(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/home/cpi/.local/share/xorg/Xorg.0.log", Time: Mon Aug 17 16:24:07 2020
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(II) modeset(0): Initializing kms color map for depth 24, 8 bpc.
--- request header ---
GET /jsonrpc HTTP/1.1
Upgrade: websocket
Connection: Upgrade
Host: localhost:6800
Origin: http://localhost:6800
Sec-WebSocket-Key: ...
Sec-WebSocket-Version: 13


-----------------------
--- response header ---
HTTP/1.1 101 Switching Protocols
Upgrade: websocket
Connection: Upgrade
Sec-WebSocket-Accept: ...
-----------------------
pygame 1.9.4.post1
Hello from the pygame community. https://www.pygame.org/contribute.html
no skin config.ini file to read
no skin config.ini file to read
('CheckBluetooth:no bluetooth', (0, ''))
state
dbus.UInt32(0L)
Trash:
['']
libpng warning: iCCP: known incorrect sRGB profile

to make it clear, the Launcher works OK, and i can start apps and games on the external HDMI device. but attempt to open Terminal by “Ctrl+Alt+T” just display “Loading…” pop-up, and nothing more happens.

so when you

and then

nothing suspicious?

exactly… nothing new added to “x.log” after attempt to open Terminal.
also, i noticed, that the same behavior without external HDMI monitor/tv: just connected USB-keyboard and pressed “Ctrl+Alt+T”, and saw the same “Launching….” pop-up.