clockworkpi

GameShell OS image files (v0.5)

I’m not able to reproduce such error, let’s try to get the community and maybe @guu to help.

1 Like

you just flash a new sd-card with os v0.5 image ,right?

1 Like

Thanks this messages gone, but still no luck with launcher - just black screen and messages like No Mail…

I upgraded to v0.5 image today. The first thing I noticed is that Retroarch becomes more unstable. When I launch games with Retroarch, it could easily freeze at start up. I can kill -9 the retroarch process to get back to the launcher menu. And the launch is more likely to restart when exiting from Retroarch using the Menu button. But if Retroarch starts properly, I don’t see any problem running any thing.

Is this a known issue? Is it because of the new Retroarch version or new GPU driver?

I built up retroarch 1.8.2 (the 0.5 image uses 1.8.1) on a fresh 0.5 image and I didn’t have too many problems. In fact, it was pretty dang good. You can test it out on the DEOT v2+ 200110 image I made.

That said, I’ve currently done an apt upgrade on the operating system, and then retroarch started to misbehave. I’m doing a rebuild of retroarch right now. Fingers crossed it works out. I’ll let you know.

Edit: And after a lot of rebuilding, I’ve discovered that for some reason, doing an apt update && apt upgrade breaks retroarch’s stability with the GL video drivers. This could contribute to the instabilities mentioned above. The main thing this changes for me is the inability to use the GLUi and XMB menu drivers in retroarch, and have a few specular interface changes. Actual cores aren’t affected visibly.

The fix I found to return stability to retroarch is to change from the GL video drivers to the sdl2 drivers via the retroarch driver settings menu.

The funny thing is, I only had the aforementioned problems after an apt upgrade. Performing an update to retroarch on the stock image had absolutely no problems.

A theory. The 0.4 - 0.5 update itself isn’t inherently flawed. It is something that happens during the apt upgrade process that is a part of doing the update that breaks the graphics drivers, and possibly other things. I’m about to do a bit more experimenting.

I’ve found a potential bug in the file structure of the 0.5 release.

As a general practice, I refrain from putting anything into the /launcher/Menu/GameShell directory, being closely linked with stock files that will be overwritten when doing a launcher/git update.

I put 3 folders in the above mentioned folder for a custom image (Namely 01_MANUAL, 01_OPERATION, 03_MAIL DEOT) without any problems, but decided to move them to apps/Menu/GameShell for the reasons mentioned above.

This technically shouldn’t have made any visible difference; only now the “20_Retro Games” folder stopped being displayed. This was odd, seeing as no folder had taken up the allotted “20” spot in the folder hierarchy.

This was remedied by deleting what seemed to be a redundant directory. The “20_Retro Games” exists in the /apps/Menu/GameShell folder containing an abundance of subdirectories with action.config files essential for running emulators.
The duplicate entry exists in the /launcher/Menu/GameShell directory, and does not contain anything. It appears to be completely useless, and vestigial in nature. This folder was deleted, fixing my problem of a missing folder on the home screen.

Just thought I’d mention it here, in case anyone else experiences similar problems. No point keeping solutions to problems to myself! Chances are someone else will have it too. :slight_smile:

I had same problem with this folder, and yes it was duplicated. I also deleted it

1 Like

@guu @yong attached a video of the issues I’m seeing on my GS after updating to v0.5.

In addition to the Wi-Fi not working, now whenever I power on GS, its screen goes dim and remains as such, even when I’ve set the brightness to max. Also, the UI seems to freeze (can be noticed once or twice in the video) every now and then.

https://filebin.net/1bulvo7i4d8ozeqr/gameshell-screen-dim-wifi-broken-v0.5.mp4?t=o3bbtn5z

By updating, was that an update from 0.4 to 0.5 using the update? Or a complete update and flash of a fresh 0.5 image?
I’m guessing it was the former, but if it was the latter, that is a lot of things to go wrong on in a fresh image, an shouldn’t have.
It might just be worth restoring your backup you made before updating, retrieving all of your Roms and changes, then flashing a new card from scratch. (Assuming your backed up your card before updating as per the instructions)

This was an update of basically the stock image on the sd card that I had received with the GS. Basically, the day before was the first time I did a re-flash of the sd card.

I’m not sure what version was originally on the sd card :disappointed:

I’m guessing it came with 0.4. In which case, you don’t have much to lose. I wasn’t sure if you updated because you had a lot of established files.
In fact, it will be faster to flash a new 0.5 image from scratch. :slight_smile:
I couldn’t view your video for some reason, but your description basically sums up a bad time.

Yeah, not sure what happened with the video. Please refresh, I added the link to the video file as well.

Hang on… when you say update, do you mean updating via the settings menu, or the larger more involved update script mentioned in the earlier posts of this thread?
If it’s the former, that probably wasn’t an update to 0.5, and instead an update to the launcher that was expecting your system to already be at 0.5.
Another user made a thread with this same problem. Sounds like it’s something that needs to be addressed and made more fool proof.

I took out the sd card from the GS, and flashed v0.5 on it via etcher on my mac. I’ve had this GS for several months (I hadn’t used it much), so whatever version was on it was pretty old.

@javelinface are you able to access the video via the link https://filebin.net/1bulvo7i4d8ozeqr/gameshell-screen-dim-wifi-broken-v0.5.mp4?t=o3bbtn5z?

I’ve had this situation before, but it’s rare

I just unpluged the mainboard , unpack and repack it, if that does not help,try to refresh the os v0.4 for testing, if os 0.4 not working, then it must be a hardware issue

1 Like

That seemed to be a valid link to download, although it needed to be clicked as an external link. :slight_smile:

I occasionally had the wifi not work. I just restarted it, and then it fixed itself. Then on times it didn’t activate, again, I just kept restarting it till it did work. This was for an earlier version that I fiddled with a lot.

Just having a think, re: the slow downs. Perhaps it’s taking up extraneous memory, trying to get the wifi started with some kind of cyclic loop.

Another thought. Dimming of the screen could be happening after initially starting, and then applying the setting you have in your system. It boots up at 100% brightness, which quite frankly is way too bright, and drains the battery like mad. As for why it can’t be changed, maybe it’s the wifi loop taking up too much memory, not allowing the hook for brightness adjustment to activate.

Have you tried flashing to a different card? Sounds like there’s a lot wrong, that could almost warrant starting a new thread. :slight_smile:

1 Like

Tried to update and upgrade before running the update script, but the GameShell crashed. Now when I try to start it up it gets stuck on “Loading…”.

Decided to flash instead, downloaded the image but balenaEtcher complains that “Something went wrong. If it is a compressed image, please check that the archive is not corrupted.”

md5 ~/Downloads/clockworkos_v0.5.img.bz2
MD5 (/Users/bjornkri/Downloads/clockworkos_v0.5.img.bz2) = 27f85542d0278f898bfca060c264dc6f

Seems to check out… Any ideas?

EDIT: Leaving this here if anyone else has the problem. Updating balenaEtcher did the trick. 1.5.5 -> 1.5.7

2 Likes

@guu @javelinface thanks for the inputs. I’ll definitely try flashing to a brand new SD card and using that to see if things improve.

Also, I noticed yesterday when I had the GS ON for 30-45 minutes–its back (the area somewhere below the micro HDMI port, I think) was getting extremely hot :fire: (so much so that I wasn’t able to hold it from there)! Is this also expected, or a potential h/w issue as well?

I also had trouble flashing to 0.5 with balenaetcher, even though I’d used it months ago to flash 0.4. I ended up using win32diskimager instead and that worked. Sounds like balenaetcher may have been buggy. :frowning:

The app I actually use for most of my image writing is apple pi baker. It’s meant to be for preparing raspberry pi images, but basically does the job for CPI with a few extra tricks up its sleeve. I hadn’t had to update it in years.


And don’t worry. I’m not like advertising for them. Just saying what I use.

@chalchitra What were you doing for those 30 minutes. For diagnostic purposes, I’ve had my gameshell on for about 12 hours on the homescreeen, plugged in via USB power. It’s no hotter than my cat’s stomach. That’s to say 38 degrees celcius.
When doing something more intensive, eg playing mupen64plus or Quake 2, it gets about as hot as a cup of green tea, or about 80 degrees celcius.
This is actually cooler than what it used to be. I guess it comes down to what people individually perceive as hot.

Also consider there are no heat sinks on the unit. I’ve considered cutting a large portion of the CPI casing, and installing an exposed heat sink plate. So far, I haven’t had any stability, slow downs or error inducing problems due to heat. It’s all within operating specs, which I think was twice as hot. I’ll have to dig up the data sheets but it was around there. Here’s the heat sink type I was thinking of. I needed it for my raspberry pi, otherwise it would constantly crash.

In summary, it gets hot. It’s just something I’ve gotten used to.

1 Like