GameShell OS image files (v0.5)

That seemed to be a valid link to download, although it needed to be clicked as an external link. :slight_smile:

I occasionally had the wifi not work. I just restarted it, and then it fixed itself. Then on times it didn’t activate, again, I just kept restarting it till it did work. This was for an earlier version that I fiddled with a lot.

Just having a think, re: the slow downs. Perhaps it’s taking up extraneous memory, trying to get the wifi started with some kind of cyclic loop.

Another thought. Dimming of the screen could be happening after initially starting, and then applying the setting you have in your system. It boots up at 100% brightness, which quite frankly is way too bright, and drains the battery like mad. As for why it can’t be changed, maybe it’s the wifi loop taking up too much memory, not allowing the hook for brightness adjustment to activate.

Have you tried flashing to a different card? Sounds like there’s a lot wrong, that could almost warrant starting a new thread. :slight_smile:

1 Like

Tried to update and upgrade before running the update script, but the GameShell crashed. Now when I try to start it up it gets stuck on “Loading…”.

Decided to flash instead, downloaded the image but balenaEtcher complains that “Something went wrong. If it is a compressed image, please check that the archive is not corrupted.”

md5 ~/Downloads/clockworkos_v0.5.img.bz2
MD5 (/Users/bjornkri/Downloads/clockworkos_v0.5.img.bz2) = 27f85542d0278f898bfca060c264dc6f

Seems to check out… Any ideas?

EDIT: Leaving this here if anyone else has the problem. Updating balenaEtcher did the trick. 1.5.5 -> 1.5.7


@guu @javelinface thanks for the inputs. I’ll definitely try flashing to a brand new SD card and using that to see if things improve.

Also, I noticed yesterday when I had the GS ON for 30-45 minutes–its back (the area somewhere below the micro HDMI port, I think) was getting extremely hot :fire: (so much so that I wasn’t able to hold it from there)! Is this also expected, or a potential h/w issue as well?

I also had trouble flashing to 0.5 with balenaetcher, even though I’d used it months ago to flash 0.4. I ended up using win32diskimager instead and that worked. Sounds like balenaetcher may have been buggy. :frowning:

The app I actually use for most of my image writing is apple pi baker. It’s meant to be for preparing raspberry pi images, but basically does the job for CPI with a few extra tricks up its sleeve. I hadn’t had to update it in years.

And don’t worry. I’m not like advertising for them. Just saying what I use.

@chalchitra What were you doing for those 30 minutes. For diagnostic purposes, I’ve had my gameshell on for about 12 hours on the homescreeen, plugged in via USB power. It’s no hotter than my cat’s stomach. That’s to say 38 degrees celcius.
When doing something more intensive, eg playing mupen64plus or Quake 2, it gets about as hot as a cup of green tea, or about 80 degrees celcius.
This is actually cooler than what it used to be. I guess it comes down to what people individually perceive as hot.

Also consider there are no heat sinks on the unit. I’ve considered cutting a large portion of the CPI casing, and installing an exposed heat sink plate. So far, I haven’t had any stability, slow downs or error inducing problems due to heat. It’s all within operating specs, which I think was twice as hot. I’ll have to dig up the data sheets but it was around there. Here’s the heat sink type I was thinking of. I needed it for my raspberry pi, otherwise it would constantly crash.

In summary, it gets hot. It’s just something I’ve gotten used to.

1 Like

It appears that my issue with the 0.4 to 0.5 upgrade was caused by the missing theme icons that were added in v0.5.
Missing files prevented the themed OS from loading and resulted in being stuck on “Loading” screen.
Anyway, copying the files below over from /home/cpi/launcher/skin/default to your favourite theme folder should solve the problem:

I have updated my dark theme (and styled new icons) accordingly, so it now works with clockwork OS v0.5

1 Like

To disable “You have new mail.” message:

sudo nano /etc/pam.d/login

comment this line:

session    optional standard

so it looks like this:

# session    optional standard

If you want to disable it for ssh too, edit /etc/pam.d/sshd in the same way.

To get rid of tidal, qobuz and id3v1_encoding warnings:

nano /home/cpi/.mpd.conf

add this:

input {
        plugin     "qobuz"
        enabled    "no"

input {
        plugin       "tidal"
        enabled      "no"

decoder {
        plugin       "hybrid_dsd"
        enabled      "no"

and comment this line:

id3v1_encoding         "UTF-8"

so it looks like this:

#id3v1_encoding         "UTF-8"

save and reboot.


Hey folks, a little help on this one would be appreciated. I’m super new to all this, (got the gameshell as a learning/fun gadget) and am having some issues following the instructions above, and I’ve tried to use the comments but I feel I’m missing something basic.

Steps I’ve taken:

  1. Installed Putty and learned how to ssh into the gameshell
  2. Used sudo apt-get update + sudo apt upgrade - this seemed to update a bunch of files
  3. Used wget command to download the patch file
  4. Got stuck on how to ‘run’ the file, as run isn’t a command?
  5. Installed FileZilla (gui, yay!), confirmed that the patch file is in the root directory of the pi

So I know I’ve got the patch file, but I can’t for the life of me figure out how to ‘run’ it, like the instructions say to. I’ve tried a ‘run’ command, and have rebooted the pi to see if it shows up on the pi’s gui, but no dice.

Like I said, I’m sure it’s something super simple. I appreciate the help!

As in windows, linux has file permissions.
You can find a nice starting point on linux systems here UNIX Tutorial for Beginners

So lets start from the basics.

You can check if the patch script has executable permission with (More info here

ls -l

Probably as you downloaded it from the internet, the patch doesn´t have execution rights for security reasons.

You would have to do

chmod +x

and then to run any script you just need to put ./ in front



Thank you, this was exactly what I needed!

Hello! Welcome to the forums. :slight_smile:
An interesting thing I saw in your initial commands. You did a sudo apt-get update, then a sudo apt upgrade.

It comes down to the apt vs apt-get debate. I prefer to use the former, “newer” version. Very minor differences in the way they handle things.

I’d probably stick to using the same one you used to update your sources for the upgrade, ie,

sudo apt update
sudo apt upgrade 


sudo apt-get update
sudo apt-get upgrade 

It was always my assumption that updating one, then using the other to upgrade wouldn’t ensure having the updated lists.

Hello! I just got done patching O.4 and had to reinstall the Lima drivers and delete the OS 1 theme to get my Launcher booted. Games are running now! Yay! However for some reason my Light Keys aren’t being recognized now. Has anyone else had this issue? They still light up so I believe they’re functioning.

1 Like

In standalone emulators too? The fact that they’re lighting up, I’m assuming individually means that it isn’t a connectivity/hardware problem.
My guess is, the Retroarch config needs to be overwritten for compatibility, and the L and R buttons haven’t been defined yet.

Otherwise test things out, using this.

I haven’t done the 0.4-0.5 upgrade, but can say that a fresh 0.5 image does indeed work with the light key.

Yeah all I had to do was manually edit the retro.cfg file. Thank you.

1 Like

Alright read how to update without erasing, but how would it look to put in code?


I … don’t know what you’re asking.

It would look like an SSH session. I probably would err on the side of caution, doing the 0.4-0.5 update, if you’re not familiar with how to use the command line, as there is a chance you will have more problems arise later that will render your system unusable without some heavy troubleshooting.

This was I was talking about, how would I be able to do this @javelinface

Haha I think you just answered your own question.
I can’t really answer this without repeating what the instructions have already said, but I’ll try.

  1. Download that file to your computer. It’s the files you’ll use later to update your system. You can also use the wget command, but I’m going to assume that you may not know how to do this.

  2. Use the commands in step 2 of what you linked to “prime” your system; updating the files list, then upgrading the system with the latest updates for the underlying system. To do this, you’ll need to SSH into your system from a computer/phone/tablet. That’s where you type in commands etc. This is a standard procedure that most people who use Linux know how to do. You will be asked questions. The answers are most likely in this thread. Heres a refresher on what SSH means: How do you "SSH?" Do you connect your gameshell to a computer using TinyCloud? - #2 by javelinface

  3. Using some kind of file transfer program (or command in a command line interface if you know it), copy the file from step 1 to somewhere on your gameshell.

  4. Using the command line, run the file. This involves first, performing a chmod +x to the file, changing the mode to allow the file to be executed, then running it using a ./ command.
    Probably something like this.

chmod +x

After doing step 2, you may get a whole bunch of error messages regarding MPD, and mail notifications when starting up.
To remove them, follow these instructions.

If at any stage you feel that you don’t know what to answer or what program you need to use, stop what you are doing. You could do more damage than good. I can’t help you, as I don’t know what you have changed on your system, so can’t for sure answer the appropriate response.

The update is definitely targeted at more advanced users. As stated in the description, it is a work in progress, and remember to back up your system before performing the update.

Oh hang on. The exact thing was asked and answered above.

Just want to be as sincere as possible, but don’t forget to read posts, and search things up. There’s a good chance a lot of it has been answered. It’s hard to find at times. But in the case of this one, it was 6 posts above yours.

Oh and here’s another one!

All in this same thread.

Thank you haha, but the download is just the .sh on another page do I just put it on a text document? @javelinface

Keep the file as it is. You might need to do a “save as” to save it as a *.sh file.
It’s a script. Or a set of instructions. It’s written for baSH, and needs to have an extension to be recognised and executed.

The same thing was asked in this thread. Have a read of all of if before going ahead with this update. Please.

Before you get too far, make sure you’re connected via USB Ethernet. You may get a wifi drop out towards the 60% part of the script. Please use the forum search to find out how to do this.

Unless you’ve done some extremely heavy modification to your system, if it’s just Roms you want to transfer over, you might be better off just flashing a new image with 0.5, and re-uploading your files. This process takes A LONG TIME!