clockworkpi

GameShell OS image files (v0.5)

400GB!? Your Gameshell has more hard drive space than my 2018 MacBook Pro. Christ bro.

1 Like

Yeah, I went overboard when there was a sale on the cards last year. :slight_smile:

I figured in addition to ISOs and ROMs, I’d use the extra space as a sort of portable file server and/or “flash drive”. I did use it that way a bit, but I never ended up using more than a few hundred GB anyway.

Also, I wouldn’t recommend putting huge ROM collections on the Gameshell. The default launcher is painful when scrolling through lists of thousands of items, and the startup time take a big hit as well, since I guess the launcher has to index all those files. I still kept stuff on the gameshell for convenience, but used the file explorer on gameshell to move stuff around as needed, if I didn’t have it ready to play.

We have updated the v0.5 image with fixes of a few bugs found in this thread. Thanks!

3 Likes

Do we need to reflash the image or can we just pull from GitHub for the fixes ?

Like @Wizz, I’d also like to know if these fixes can be obtained via update without flashing. (Or are there other manual steps that can be done to obtain the same result?) Also, what are the “bugs found in this thread” that were fixed? It would be useful to know the details, so we can decide if it’s worth reflashing again. Thanks!

according this thread , the bug is the skin/theme issue

and @Wizz yes, just git pull would be enough

and for the last thing

When I was remaking the image I also added the mupen64 dependences

from @javelinface

here is what I did:

https://drive.google.com/drive/folders/1gdp6lrHK1bmBTM_CKiU7RNXKL-W8w0X3

run the mupen.sh to install all dependences

cd ~/apps/Menu && git pull

to update the n64 action.config so that launcher can see more n64 roms with different suffix

1 Like

English is not my native language so maybe I do not understand correctly.
Are you saying that a fresh install work well with the OP-1 theme or is the theme problematic wathever the method?

Which directories do we need to run git pull from? I tried running it from the launcher and the apps directories and both said I was up to date. Updating the launcher from the menu also indicated I was up to date. Are there any other directories in the system that should be updated? Thanks!

the directory is ~/launcher but if all said is up to date
then you should be ok now

1 Like

Yes, it does work! I just flashed a fresh image myself, and am staring at the OP-1 interface.
Don’t be afraid to try things yourself on a spare card. :slight_smile:
You will also need to do an update via the settings menu. This is the developers listening to people, and making updates and changes to make things work.
When you report things, by trying them out yourself, things get done faster; as long as you’re on the latest version. If we all just wait, nothing will happen.

On a side note, do you actually use the OP-1 theme? Or is it a case of having a compulsive tick that cannot live with something potentially not working within an operating system?
The reason I’m asking is that this could be something to change in the future, ie not having any themes installed on the system, and instead having a garage/repository like system where people can upload/download themes.

Another thing re: the OP-1 Theme’s pngs. It’s still using the older FreeDM icon naming convention, rather than the ChocoDM that is currently the norm. Small thing, but worth noting.

For fairness of future Gamejam entrants, would it also be worth while to consider removing the indie games entries, eg. planet busters. Having them all moved to the garage would be a great way for people to add and remove them at their own leisure.

1 Like

Yes I do use the OP-1 theme, I just created more icons for it.
I always forget that I can flash a separate card…

1 Like

Oh nice! I’m keen to see your work, as a graphics designer. In fact, seeing someone with design skills make an entire theme, choosing palettes etc would be very nice. I’d like to see a game jam style event, just for this. A theme jam almost.

Well I do not have nearly enough time to create a theme, the icons I did are made on the fly to fit the OP-1 theme, nothing worthy of sharing I believe. I manage a monthly magazine by myself here full time for a Canadian Association and my main expertise is in 3D and photography for publicity. I do 2D but its rarely something exceptional. I work mainly with C4D, Solidwork, Houdini, RealFlow, Keyshot, Redshift and After Effect. For the magazine I use Illustrator and Photoshop.

1 Like

Hi,
After In place upgrade / patch from 0.4 -
How to Fix This?

Re: the bulk of it, I did a small write up here.

As for the “you’ve got mail” section, have a look at this post:

The instructions generally worked for me. A few tips that folks have already mentioned:

  • If you know how to ssh into your gameshell from a separate computer, its a lot simpler to just use wget to download the patch file within your session. This might take a while since its 84mb (!!)
  • the apt-get commands will take a while. Make sure you’re plugged into a charger and that the gameshell doesn’t go into sleep mode
  • When prompted, I chose “use the config that the package manager provides” as the option. Didn’t seem to affect the ability for the script to execute its update BUT you should probably keep the config as per @javelinface comment below
  • As someone above already mentioned, make sure you use the chmod +x command to make the patch script executable
  • I had made sure to disable the OP-1 skin and switched back to the default skin when updating the launcher from the UI. However when I rebooted I got stuck into the Loading... screen. Luckily I was still able to SSH into the gameshell to poke around. When I rebooted the launcher using the commands listed in this post [SOLVED] Reload Launcher from SSH I saw that a python script was segfaulting socket.error: [Errno 97] Address family not supported by protocol. I don’t know if this directly fixed it but I tried removing all the skins installed under /home/cpi/skins and rebooted the device with sudo reboot and everything worked fine after that!
2 Likes

This is an amazing PSA that any user with problems should refer to!
One thing I use is simply “apt” over “apt-get”, since it gives progress bars, so you know if it’s just taking a long time, or your device has frozen.
Regarding using the package maintainer’s version, I would opt to stick with the existing Retroarch config file, as it is the one that was made to work with the gameshell. Too many cores will break if you overwrite this file.

Interesting! I’ll have to figure out a way to get that config back then. I use the console-specific emulators though so I should be okay for now.

1 Like

True! The standalones won’t be affected. You should be able to retrieve the gameshell Retroarch config with a git pull.
I seem to recall a few retroarch.cfg.bak files in the ~/.config/Retroarch directory. Perhaps one of them was an intact backup? I haven’t checked them to be sure! (Mainly controls will be messed up - but recoverable, amending them with the controls export function in th launcher’s settings menu)

Oh and how rude of me! Welcome to the forums!!! :slight_smile:

2 Likes

Hi, all

I recently updated to this version.

However, after booting up, gameshell is unable to connect to detect any WiFi n/ws. I toggled the device WiFi off and on again, but even after multiple scans, it just shows an empty screen.

This was not an issue with the earlier version.

Anyone else facing this issue?


UPDATE 1

So, I’m not sure what’s going on here. After failing to connect via Settings > Wi-Fi option, I connected to GS via USB, SSH’ed into it, and ran:

sudo wicd-curses

In that, if I keep refreshing (R), sometimes it’s able to detect the networks, shows my WiFi at the top, tries to connect to it but keeps failing.

cc @yong