Gameshell Will Not Power On [SOLVED]

Hello! I have assembled the gameshell as instructed, disassembled, and assembled again but it does not turn on. I have tried it plugged in and unplugged and with and without the SD card inserted. I have also let it sit and charge for a few hours but still nothing. I have pressed the power button quickly and held it down. There is no flicker on the screen, no light activity, no sign that the unit is powering up. I have checked and double checked the battery connection to the mainboard it is secure and properly inserted. Any ideas on what the problem may be?

When you plug it in to charge, do you see a yellow/orange light on the back of the unit turn on or even flicker? I had some issues putting it together where I realized I managed to somehow get some of the cables in the wrong way without them thankfully damaging the ports they are going into. After resetting them it was all okay and that light turned on but I had no video. Then I saw a post on here that made me realize what I was doing wrong with the video cable and after that it was all smooth sailing.

No light, no flicker. I had checked the cables but I’lldo so again just in case.Thanks!

I had the same issue when I first put mine together. What got it to work for me was flipping the power cable, so the end that plugged into the battery was now the end that plugged into the motherboard. Both times I had the cable plugs in the “correct” way, as they really only fit in one way, but maybe there is something about which end connects to which board…
That is my best suggestion, that and try to make sure the plugs are pushed in fully I guess.
Best of luck!

i had same issue, fixed now, try press mainboard downside button… another button like power button here.

1 Like

Thank you all for your help! :robot: So I tried flipping the battery cable without luck. I checked the cables as well and everything looked secure and in the write position.
THIS WORKED: I inserted the SD Card and used the other switch on the MB and it turned on! It now turns on using the top button without issue. Thanks again!

Hi @Kryz_Braun,

I got the same problem with you, in which the GS doesnt turn on at all.
What do you mean by “other switch on the MB”?


To resolved my problem, i try to unplug the battery and the keyboard and start just the screen and mainboard with a usb cable… I try the same with the keyboard plug and after that i try to put the battery… Eliminate all hardware possibilitys

If you remove the mainboard from its case you will find another little switch on the opposite side of the board from where the on/off switch is located. It’s identified as the reset key on the attached photo.

1 Like

Aaahh, got it! Thanks a bunch!

1 Like

My Gameshell does not start after the first assembly. Everything is connected correctly, the cables were also turned around, the restoration was done, there are no lights, not even with usb cable.

What do you mean by this? How were the cables turned around and how was it corrected?

I meant that I removed all the cables again they turned and then connected again. Now everything works, that problem was a completely empty battery.

OMG thank you so much
I am so new to the Gameshell, so when it suddenly stopped turning on I thought it!
Thank you thank you thank you thank you!