clockworkpi

GameShell won't recognize my 64gb card

Yes, there are two partitions on the original SD Card. Win32DiskImager creates an image including both of them.

The drive letter you choose to read from only refers to the drive letter of the SD card itself; not the partitions on the SD card.

hmmmm i used dd if=/dev/mmcblk0 of=/Data/imagename.img bs=64M and synced before extending the partition… also worked

Yeah as long you dd back with the same block size, should work

So if I clone my SD now, and use the cloned image on a new SD it will slow down? Did I understand that right?

Would be easy to clone what I have already, and expand but I don’t want to compromise the system at all

You could also create a 32/64GB img using WinDiskImager and host it. Then the people having trouble could just flash it already partitioned

I have not had good luck cloning a previously booted copy of ClockworkOS. Copying the original ClockworkOS 0.1 image to the memory card and then expanding it with gParted works reliably. After booting the first time, it’s then safe to copy a previously backed up copy of the contents of the home folder (/home/cpi/) using SCP.

Backup:

scp cpi@[TinyCloud Address]:/home/cpi [Local Backup location]

Restore:

scp [Local Backup location] cpi@[TinyCloud Address]:/home/cpi

Be sure to reboot GameShell immediately after restore!

LasVegas

1 Like

thanks for the input man! Restoring everything back to a 32GB card.

What a process to repartition haha wow

is wath i’ve done and im good , thx !

IMG_20181223_155502

Hey there,

I’ve written a setup script that can resize your file system and partition to fill the entire SD. It works on the fly and you don’t even have to reboot :slight_smile:

You can run it by connecting to your Gameshell via SSH and issuing this command:

bash <(curl -s https://raw.githubusercontent.com/hpcodecraft/gameshell-setup/master/run.sh)

To see what else it can do or look at the scripts themselves, check out the repo: https://github.com/hpcodecraft/gameshell-setup

13 Likes

Are these updates compatible with v0.3? Great work btw.

Yes, this will work with 0.3, I use it myself :slight_smile:

2 Likes

To backup your home/cpi folder from 0.3 requires a modified scp command:

scp -r cpi@[TinyCloud Address]:/home/cpi [Local Backup location]

I don’t know why it worked without the -r (recursive) option previously, but it doesn’t now.

I hit y when it asked to resize and it then said “skipped”
Not sure what I did wrong?

There’s a bug in the script. Answering ‘N’ will do it for you.

I should have known better than to try this on April 1st.

1 Like

Does this script still work?

I’m at work, so I don’t have it in front of me. But I tried it this morning and it didn’t work.

I pushed Y and it did it’s think .Took a while. Lost connection several times. Didn’t work.
I pushed any key to go past it, and it timed out a couple of times.

I’m trying to use a 128GB card for this, but of course, it only sees it as 8GB.

I’ve had reports of problems with the retroarch updating functionality, but I had no time to look into that yet. The SD card expansion should work fine though, just skip the retroarch update option.

If pushing Y doesn’t work, you can try to push N for the SD card update. Some users reported they needed to do that, but I was unable to reproduce this :smiley:

First thing, where do I see if I pushed Y or N? Hell, I’m using WinSCP, I just click on the window with the terminal text and it proceeds. I don’t even see that it accepted a Y or N. But this is what I get:

home/cpi/games/MAME$ bash <(curl -s https://raw.githubusercontent.com/hpcodecraft/gameshell-setup/master/run.sh)
mkdir: cannot create directory ‘mods’: File exists
fatal: destination path ‘gameshell-setup’ already exists and is not an empty directory.
e[1;32m e[0m
e[1;32m
e[0m
e[1;32m
Welcome! e[0m
e[1;32m
e[0m
e[1;32m
This installer will now update the lists e[0m
e[1;32m
of packages known to the GameShell e[0m
e[1;32m
e[0m
e[1;32m
Afterwards, it will ask you some questions e[0m
e[1;32m
e[0m
e[1;32m
Type ‘y’ to accept e[0m
e[1;32m
or hit any other key to skip e[0m
e[1;32m
e[0m
e[1;32m
e[0m

e[1;32mUpdating package lists…e[0m
Ign:1 http://cdn-fastly.deb.debian.org/debian stable InRelease
Hit:2 http://security.debian.org/debian-security stable/updates InRelease
Hit:3 http://cdn-fastly.deb.debian.org/debian stable-updates InRelease
Hit:4 http://cdn-fastly.deb.debian.org/debian stable Release
Reading package lists…

Gets to that point and brings up the Host is not communicating window and aborts.regardless if I hit Y or something else

Your Gameshell needs to be connected to the internet while running my script.

You ran the script in the wrong directory, here’s how to fix this first:

  1. Delete /home/cpi/games/MAME/mods
  2. Open /home/cpi
  3. Run the script again

You should have /home/cpi/mods/gameshell-setup after that.
To re-run start /home/cpi/mods/gameshell-setup/setup_new_gameshell.sh

I ran the script a few days ago to repartition my 32gig card, and the update wiped out the PCSX standalone and FreeDM the Doom game that came with it.
I was able to replace PCSX with the Rearmed standalone, but I haven’t attempted to fix Doom yet.

I’m on Mac, what would be the steps to this? Thank you