How to add games to gameshell

tinycloud
network
help

#21

Oh I missed that, yeah that could be the cause here


#22

OMG its true, it worked!! thank you!!


#23

Thanks for the help Godzil :grin::grin: and your patience as well. Much appreciated.


#24

Will they not work if they are unzipped? I have my roms already all unzipped as it is, but can’t get the SNES ones to work at all, so is this the problem? GBA and NES are working without a problem.


#25

Are you using a snes 9x core in retroarch?? This core works for me. Mine are unzipped and work fine


#26

Yeah, that’s what I have installed. It just goes to a black screen for any game I try to start.


#27

Ok I’ll check tomorrow morning and share what I have :wink:


#28

I think whether or not you can keep them zipped depends on the emulator core, btw.


#29

Try the ‘SNES9X Next’ core. That one is working much better for me.

Also, I need to figure out how to configure individual button mappings for emulators/games. I love my light key but this thing would be more portable without it and my favorite GBA games would be fine if I could remap L and R to Y and X for that system only…


#30

Having that issue with GBA, too. I have no idea what the light key was and didn’t get that version for $$$ at the time but I’m wondering if I made a mistake. lol


#31

No you should be able to remap the buttons. You could do so by editing the retroarch.cfg

The file looks like this:

input_player1_l is mapped to the ‘h’ key. So every time Retroarch gets an ‘h’ it interprets that as the L button. If you switch that to input_player1_l = “i” and change input_player1_y = “h” you will have swapped L and Y. But then when you play a system like SNES it’ll be out of wack. It ideally needs to be done on the ‘core’ level. I know that is possible I just haven’t had the time to set it up yet. This is the kind of thing that pretty much has to be done over SSH.


#32

Can we please discuss only about adding games here? (and not button changes or anything unrelated)
Many thanks :slight_smile:


#33

Sure. I’ll open another one for that.


#34

you need to press win+r and then write (\IP adress goes here\games ) and hit enter


#35

What is kinder? I’m on a mac as well. Tried looking for kinder in app store, no luck. I got this for my son for his bday but he’s sick of the 2 games on it


#36

That was a typo. He meant Finder.

LasVegas


#37

For windows users who can’t ssh (like me) use filezilla to acsess the shells sd card without removing it select games, then mgba or the other ones then drop your rom in the cpi is hosted on port 22, btw I wrote a guide on How to install roms (the easy way) so you can go check that out


#38

Thanks, mate it was really helpful.