clockworkpi

How to use RetroArch in Gameshell?

Actually it’s listed as: menu_unified_controls

LasVegas

Hey, @fr500. Where do I put the ps bios file when using pcsx libretro? I have it in my psx rom folder but it wont detect it

/home/cpi/games/RetroArch/System

Thnx man. I cant get it to setup (pcsx_rearmed_libretro.so.zip wont download because its not on the list) so im just using the standalone. :frowning:

Could someone post the original cfg? I somehow messed with it (only wanted to change the gui but it exits immediately) and deleting it creates a new one which is obviously not configured for GameShell…

Thanks!

Ah, I think I found it - presumably (haven’t tested it enough yet) there’s a copy of the original config named retroarch.cfg.blbak .:slight_smile:

You can also find it here: https://raw.githubusercontent.com/clockworkpi/GameShellDocs/master/retroarch.cfg

Yes, I did download it from there, but it’s not configured for the GS (GUI, screen etc). :slight_smile:

Thats the stock one, after downloading it, configuration is as follows: RetroArch Megathread

Yes, seems to be the RA stock config. Whereas retroarch.cfg.blbak seems to be a copy of the one the device ships with.

Thanks! I was able to use this to get a game working! Thanks guys. Took me a while to figure out what was going on, having never used retroarch before.
Seems obvious now lol

Anyone have @fr500 version of gPSP_libretro?

His link is broken and I need it. Build it won’t work.

1 Like

It would be great to have access to @fr500 versions of the cores. His link isn’t working.

1 Like

I’m currently trying my hand at building my own. Complete newbie here, but im diving it. I was in the middle of testing flash ram memory on gPSP… so I kinda need it to work to keep testing it. Someone has to have the file.

In the Clockwork version v0.3 I can not change the hotkeys in the RetroArch settings. However I do not have the same problem with Clockwork v0.2.
Could someone help me with this? I try to put to load the combination Shift + L, and to save the state Shift + R, but it does not do anything when pressing the buttons …

Those keys may already be assigned elsewhere.

In RetroArch, I enter to assign the Hotkeys and when I press A on “Load State” (for example) I get 5 seconds to press the combination of buttons. However, when you press them, the account continues backwards and those buttons are not assigned.
In version 0.2 of ClockworkOS I do not have that problem, so I guess it is a “bug” of version 0.3
Has anyone solved it?
I also have problems with the Aspec Ratio of some emulators like Game Boy, Sega Game Gear, Super Nintendo …
I think I’ve seen a topic related to this a while ago … but I would really appreciate it if anyone could tell me where to look for the solution.
Thank you very much partners!

I’m having the same problem, did you ever get it solved? Thanks!

No … I have not found a solution to the problem and neither does it worry much neither developers nor users in trying to offer a solution for what I see.
I had to go back to 0.2, where we do not have Lima, and here we are … waiting for some day to decide to update this software that for the moment seems like a disaster.

Hey, I wrote a reply in another thread. Hopefully this solves your problem.