I can’t use RetroArch!

I got devterm(A06) and installed RetroArch.
But I don’t know how to fix it.

Oof, looks like you’re missing the assets bundle for retroarch. How’d you install it? Via the Armbian package, or through the Ubuntu PPA?

1 Like

I installed via the Ubuntu PPA.

Ah! I ran into the same thing. I think that PPA copy of Retroarch points it’s config at the wrong directories by default.

I opened up /home/cpi/.config/retroarch/retroarch.ccg and changed these two entries:

libretro_directory = "/usr/lib/aarch64-linux-gnu/libretro/"
libretro_info_path = "/usr/share/libretro/info/"

Once that’s done it should work. If it still looks goofy, try installing the retroarch-assets package from apt.

I tried that.
However, I am in trouble because it doesn’t go well even if I do both.

I’m a beginner and may be wrong.
Could you tell me how to install retroarch-assets from apt?

Ah, not a worry! You can search for things using the apt command:

apt search retroarch

And that prints out:

cpi@clockworkpi-a06:~$ apt search retroarch-assets
Sorting... Done
Full Text Search... Done
retroarch-assets/hirsute,hirsute,now 1.4.1+git20170209+dfsg1-1 all [installed,auto-removable]
  RetroArch assets for XMB, GLUI and Zarch

That last couple of lines tells me what packages that apt found, and retroarch-assets is in that list. So, now that I know the name of the package I’m looking for, I can use sudo apt install retroarch-assets -y to install it:

cpi@clockworkpi-a06:~$ sudo apt install retroarch-assets -y
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
retroarch-assets is already the newest version (1.4.1+git20170209+dfsg1-1).

Now restart RetroArch and it should have the correct logos and fonts now.

1 Like

Is it OK?
But something wrong,

What’s your systemwide language setting? If not English, might be the issue. I think you can set it using “sudo armbian-config”.

Also you can try running the built in Online Updater to get some missing assets:

“Try the 4th icon on the right side on your screenshot, that’s the “Online Updater”, then on that new menu, click the icon with the RetroArch logo (which should be “Update Assets”).”

Okay, I went back and double-checked my config settings, and it looks like I needed to take a few extra steps when setting this up.

It looks like apt installs libretro’s assets to /usr/share/libretro/assets and that folder is:

  1. missing a lot of required assets
  2. not writable by retroarch, meaning that the Online Updater can’t download the missing assets.

So what I did was:

  1. Edited the assets_directory setting in ~/.config/retroarch/retroarch.cfg to point to ~/.config/retroarch/assets:
assets_directory = "~/.config/retroarch/assets"
  1. Opened Retroarch and went to Main Menu > Online Updater > Update assets to download the newest set of assets.

After that, Retroarch has the right fonts and icons in the UI.

Oh! I can use it!
Retroarch has the right fonts and icons in the UI.

Thanks a lot @paul.sweeney and @meszarosb !

1 Like

Oh fantastic! I’m glad that did the trick.

1 Like