Love2d on gameshell

love2d
pico-8
fantasy-console

#21

So. I connected my computer to the gameshell with putty ssh.
Login cpi
Pass cpi

I went to the first directory that you give and create a test.sh with “sudo nano test.sh” (basic for the moment)
Inside the test.sh I just type “love” with no other informations.
I launch a game (cavestory) and go back to the menu to reload the start menu…
The screen was freeze to the loading icone…
The thing saved me was the active wifi.
I undo all the things i made and try again to do exactily what you said…

I copy the poweroff.png to rename it foo.png (i used the same name than in your exemple ^^) and create a file Foo.sh in the good directory.
Same action to reload the start screen… And same problem.
But for now the wifi doesn t work.
Now I m downloading the image of the os to burn it on a SD card. I ll try to use a SD card with more space…

Some on can explain to me where is my mistake ? I really don t anderstand.

Thanks for your help


#22

Don’t use sudo to create the files. sudo creates the file with administrative user permissions and no global user permissions. The launcher runs as the cpi user and is probably crashing with a permissions error trying to read the file. If you just use “nano test.sh” to create the file, it’ll be owned by the cpi user and readable by default.


#23

Oups ! Thanks for the advice


#24

that’s work!!!

really big thanks to you @dddaaannn for your adivice, you make my day!
now i can create all i want with Love!!! (and love ^^)


#25

For people how are curious ^^


#26

Awesome! Still have yet to receive my GS (damn UK delivery!) but am very excited to get my hands on it!

Let me know if you’ve got any questions about building games with Löve, I’ve been using it since last November so have a decent chunk of experience now.


#27

OOOOOH! Congrats <3 It´s possible to play Celeste yet? D:


#28

i think we ll have a little probleme with the key binding and the resolution for celeste


#29

ok, so! next step is to program my first test…

i create a directory call /love/test in the games directory
i put a main.lua file inside
i put this code inside the file
image
i go to the directory of the launcher
cd /home/cpi/apps/launcher/Menu/GameShell
i edit the Love.sh
nano Love.sh
i add the way to my program directory inside the file
love /home/cpi/games/love/test/
i reload the startmenu and launch my love icon
image
et voila!!!

really big thanks to every people how helped me :smile:


#30

Awesome!

Congrats!

I mentioned it on the game development thread but not sure if I posted here. Be sure to check out these tutorials:

https://simplegametutorials.github.io/

They’ve been updated to support Love v11, not much has changed aside from colour values range from 0-1 in v11 and 0-255 in v0.10.

The GameShell looks to be running v0.10 from the No Game screen you posted above (Super Toast)


#31

i just forgot to say:
thanks for you proposition @mccarthy i got a little know about LUA and Love2D but some help ll be welcome ^^


#32

Speaking of Pico-8 and fantasy consoles, I opened an issue on the TIC-80 GitHub to see if we can run it on the GameShell:


#33

Repeating this from the Celeste thread to make sure it’s findable:

Please help me test these instructions and give feedback!


#34

this is what i m going to do with Love2D!!

a small Zelda3 like ^^

image

i hope i can finish this project


#35

Got an action.config work around that allows you an interface to load Love games as you would a rom from the Retro Games folder. First get an ssh ftp program like WinSCP or Filezilla. Connect to the IP with the credentials in Tinycloud. Navigate to “/home/cpi/apps/launcher/Menu/GameShell” and create a folder called “LOVE”. You might want to put some numbers and an underscore before it for formatting. The lower numbers appear first. Mine was 40_LOVE. Inside that newly created LOVE folder create a file called “action.config” and inside it put the following.

  • ROM=/home/cpi/games/LOVE
  • ROM_SO=/usr/bin/love
  • EXT=love
  • LAUNCHER=
  • TITLE=LOVE Games
  • SO_URL=http://vonzippenstein.com/gameshell/love.zip

Here’s an explanation of what it does and what I did. So an action.config file will download an emulation core from the internet then install it. Then it will list roms for you to select. When you’ve selected one it will launch program+core+rom. The love launcher is in “/usr/bin/”. I took the love file and put it in a zip then put that zip online. You can do the same thing and host it anywhere you like or use mine. So the action.config will download that zip and put love back in the folder. Now Love is getting treated like a core. To run just Love we blank out the launcher. In the end it will come out as “/usr/bin/love selectedgame.love”. ROM will be your designated love games folder. Make sure you save that action.config

After that let’s give that folder a pretty icon. Simple as dropping in a LOVE.png.
Navigate to “/home/cpi/apps/launcher/skin/default/Menu/GameShell” and upload the following.
LOVE Rename this to LOVE.png

Next we create our love games folder. Navigate to “/home/cpi/games”. Create a folder called “LOVE” and put your games in here. That’s it. If you want to test it out I have two love files you can put on there.

  1. version.love
    A simple program to show which version of LOVE you’re running, should be 10.2, and will display the keycode of any key you press on the GameShell.
  2. vztetris.love
    A Tetris game I made in love a while back that and updated for the GameShell. Added volume controls.

Throw those and whatever else you’re working on into your “/home/cpi/games/LOVE” and you can select them right from the launcher without having to create an sh file for every love game. Enjoy.


Celeste Game on GameShell
#36

I’m renaming that topic as it is more about love2d than PICO8 and we already have quite a lot of PICO-8 topics


#37

@Godzil no problems i andersand
@vonzippenstein thanks for the information. I ll try it. But as i have seen, it just work with the .love files. Not with the project in construction…


#38

Yeah. My method is probably best for browsing downloaded love games. Not for automated testing. Though I’ve never used any of the build or run functions of Sublime Text. Always tested as .love files. Selected the project files, send to zip, change the file extension, and hit enter thrice to run on my main machine with JoyToKey mapped to mimic whatever device I plan on putting it on. Or using the method above just drag it into the LOVE folder and use the action.config to select and run it.

Update: Tried it with creating creating the .sh file on the launcher that runs the project folder and it is much faster. Can edit and save from Sublime straight onto the device and test it with one button press. Yeah, it is better for construction. Now I just need a new game idea.


#39

Is there any way of updating LÖVE to version 11.1?


#40

I was able to update Love2d to version 11.1 (Mysterious Mysteries). Here are the steps I took.

Check version

First make sure that you are not running the latest version (11.1) already. Let’s check what version of Love2d is currently installed.

love --version

Downloading Love2d

Now that we’ve verified that we are running an older version, let’s download the latest version. As of now, the official debs for Love2d for armhf are not installing correctly. When I tried to install the packages, it failed due to Clockwork OS having older versions of libc6 and libsdl. Thanks to bartbes, from the Love2d discord, we can download the debs that work with the GameShell.

Lets download the liblove package first.

wget https://launchpad.net/~bartbes/+archive/ubuntu/love-unstable/+build/14763963/+files/liblove0_11.1ppa1_armhf.deb

Next lets download the love2d package.

wget https://launchpad.net/~bartbes/+archive/ubuntu/love-unstable/+build/14763963/+files/love_11.1ppa1_armhf.deb

Installing Love2d

Now that we have those two debs packages downloaded, it is time to install them.

Let’s install liblove first.

sudo dpkg -i liblove0_11.1ppa1_armhf.deb

Next, install any dependencies that we might be missing.

sudo apt-get install -f

Then install Love2d.

sudo dpkg -i love_11.1ppa1_armhf.deb

Conclusion

That’s it, Love2d 11.1 will install over the older version. Make sure to double check that you have the latest version.

Resource link

https://launchpad.net/~bartbes/+archive/ubuntu/love-unstable/+build/14763963