clockworkpi

Mupen64 - N64 Emulator running

set the value “ScreenUpdateSetting=4” in .config/mupen64plus/mupen64plus.cfg, then many games can play :slight_smile:

1 Like

Is it possible to show a video of this in action?

Also I’m guessing you mean games run better, and not with a higher compatibility rate. There will still be a few black screen games.

A list of the games that you have running well with this setting enabled would be great. In fact of I remember, I might start a new thread with a mupen compatibility list, and accompanying config file.

On a side note, 40-50fps In OoT is quite insane. Most
emulators natively on PC without tweaking run at about 20-30fps. I am seriously wanting to see your Gameshell doing more! My Banjo Kazooie was running at about 30fps.

Here’s my config for anyone wanting to try, using the above recommendations. It’s my internal config file, so it’s got a lot of undocumented (in this thread) tweaks to it, and I can’t honestly remember what I’ve changed. I can only manage up to 30fps, which for me is pretty much on par with what I’d expect from the GameSH.
Also I modified the action file, as the video plugin didn’t have the .so extension.

Here’s a video of my OoT and Starfox 64 running at about 20-30fps. Sorry, I turned the onscreen counter off, but you can tell visually.
https://share.icloud.com/photos/0R3g0YhT0ahG1fuXhfzX-Sedw#East_Victoria_Park

https://share.icloud.com/photos/0JHrryWzFqA7vzfrJva3WG-vw#East_Victoria_Park
Pardon my terrible playing. I was trying to balance my phone between my wrists!!! And ahem. Controls need a bit of adjusting it would seem.

All this worked perfect for me, and the action.cfg edit you rock.

1 Like

Glad it helped! I’m still tweaking it when I have spare time, in a desperate plea to get rid of any other graphical artefacts. That and trying to get a GUI to work, so it’s a more user friendly experience. For now, it’s a fun tweaker’s sandbox; which I am all for!

1 Like

I find how to save or load the game state, use this config below( /home/cpi/.config/mupen64plus/mupen64plus.cfg):

Kbd Mapping Save State = 269 (shift+select to save game)
Kbd Mapping Load State = 270 (shift+start to load game)
Kbd Mapping Fast Forward = 32 (press select to speed up the game)
Kbd Mapping Stop = 8 (if you want use shift+Menu to quit the game)

1 Like

Does anyone have any success using the other video plugins other than the default one, i just get black screen, trying glide64,

Would like to get episode 1 racer to work without the half screen glitch but idk if its possible. I was surprised that 1080 Snowboarding ran so well though

EDIT: I got episode 1 racer working , you just have to disable the expansion ram in the mupen cfg. But its really slow, obviously, that game needs a fast computer to run at decent speeds/

If I may, I’m trying to get OoT to run better (right now it’s very slow, lots of stuttering especially in cutscenes and dialog. Although I don’t know what I can realistically expect from the GS? Have no experience with emulation). I’m on your custom DEOT OS and just looked into the mupen config, ScreenUpdateSetting is already set to 4, so I assume you already applied your config changes to your version of the OS? Is that correct? If not, could you please elaborate on how to optimise, as the config you linked to in your dropbox is not available anymore. Thank you!

Hello, Yes indeed! The latest version is in my custom image. And strange, it should still be there! Indeed ScreenUpdateSetting is set to 4, so it should run fast. Also, OoT for me is … actually very playable. Hurm. Like, actually smooth. Have you tried different kernels, and clock speeds?

Hi,
I haven’t really tried anything yet apart from checking the ScreenUpdateSetting.
Let me show you a video of how it runs, maybe I’m expecting too much? I feel like this morning it runs much better than last night for some reason. Walking around is actually quite fine, apart from the flickering on the ground. In interiors you can can hear the slowdown / stuttering in the sound mostly. Again, I don’t really know how it should run, so I’m fully expecting your reply to be: that’s how it is :smiley:

Video:

Edit: One more thing, I’m trying to add a OOT launcher icon following this guide


But I’m having trouble figuring out where to link to the mupen64plus as it is not in the cores folder?

Ah, well! That’s what I call very playable. I think it’s just the shadows that are in Kokiri forest that are graphically stupid. Once you’re out of there, it’s all good. Eg, the first dungeon basically plays flawlessly. So yes! That’s how it is basically is my response!

As for making the icon, mupen64plus isn’t actually in the cores folder, since it’s not a core that’s used with retroarch.

Here’s what you can use though: (change the name to your rom file name obviously)

mupen64plus --resolution 320x240 --fullscreen /home/cpi/games/mupen64/zelda_oot.n64

Yes you are right, it is totally playable. For some reason I remember it being much worse last night, or maybe that was just my brain slowing it down :wink: Or, I’ve been playing too much BotW lately and my expectations are way off because I’m forgetting what I’m playing here :wink:

Anyways, thanks for letting me know and thanks for the hint regarding the launcher icon. Will try that out!

1 Like

Hi! I am brand new to Clockwork pi and loving it! I have some experience with raspberry pi’s, but had a quick question for the gameshell. Many games work wonderfully, but i know some are tricky and require tweaking how the emulator runs. Is there a similar setup for mupen64? i am trying to get Donkey Kong 64 to run, but I always hit a black screen and i get kicked back to the starting menu. I’m using this build, if it helps.

Thanks in advance!

Welcome to the forums :slight_smile:

Ah! This is to do with the 4MB expansion toggle.
If you go into the config file located in ~/.config/mupen64plus, you can edit the section under “core” to enable the 4MB expansion.

From memory I had it disables to allow Star Wars Episode 1 Racer to work. But to be honest, that ran kinda terribly anyway, and really isn’t that fun on the gameshell.

Donkey Kong 64 surprisingly does run quite well! It does stutter a bit with extended audio, eg the DK rap, and when there is extended voice acted dialogue, eg the first cut scene. The game pad mapping using my custom OS has the game pad X(SNES) as Z to crouch and A(SNES) as R to straighten the camera. Y(SNES) is B, B(SNES) is A, and shift + ABXY is mapped to the C keys.
You can state save with shift select, and state load with shift start.

I’m currently playing with my gameshell overclocked using the 5.5.9 kernel. It could work with it a stock kernel and clocks, but from what I’ve tested, it runs nicely with what I’m using.

I’ll go ahead and add that to my todo list for the image, ie putting the 4MB expansion pack support back in. Thanks for letting me know! Enjoy spending hours collecting an insane amount of collectibles!

1 Like

works like a dream! There goes what’s left of my weekend. BTW, thanks for the amazing custom image. the tutorial was easy to read and understand why things were set up in a particular way. Now to fiddle with overclocking for my next project!

1 Like

There’s a great thread that covers just that here
It’s what I’ve based the overclock in my image off of, just enabling a few extra governors. Just watch out re: a screen flicker issue that some people have had, using an alternative Kernel. I’m still waiting on a different revision board to arrive in the mail (R16-J as opposed to my two R16 boards) to see if it makes a difference.

Hey @javelinface how would one go about activating the 4MB expansion for the mupen64 plus I tried to play smash Bros and it did not load passed the opening cut sceen

Hey, smash bros. Isn’t a game that ever supported the 4MB Expansion pack so enabling it won’t actually do anything.
That would be another setting we’d need to fiddle with.
Work has picked up again so I’m getting quite busy, but if I have some free time on the weekend I’ll look into it.
I’d just be doing changes to the config files one at a time, testing it as I go, and rolling back when it breaks. Crude I know. It will be time consuming.
You’re not the first to have a problem with smash bros. In particular.

Here’s a good resource for what settings to tweak.
Note that smash bros is listed as a game that cannot be played on the raspberry pi. I would assume the same for the gameshell unfortuantely. But who knows? Give it a shot.

https://www.raspberrypi.org/forums/viewtopic.php?t=58395

Oh snap, well then nevermind on that then lol. I will poke around to see that I can mess with but I will be carful this time lol

Just keep a backup of your config. (In my custom os I have a spare mupen64plus.cfg.bak in case you mess it up)
Also, strange! I can get past the opening cut scene, and start a match, but 3 seconds in, just the video freezes.
Looking through all the comments on that link above, you can see that it’s a case of fixing one thing leads to breaking two more. At the end of the day, smash bros was more of a fun party game to play with friends. It’s not that enjoyable to play solo on the Gameshell. I wouldn’t try and spend too much time fixing it with this in mind. That’s not saying I won’t anyway :).

Yeah, your right back to OoT then and MM with starfox in the wings(pun definitely intended)

1 Like