clockworkpi

Need help getting Mupen64 working

Hey ive downloaded the DEOT images for 0.4 and 0.5 like 10 times and they arent working for me, idk why, theyre the right amount of bytes. It says google cant scan for viruses on all browsers when you download them, so they come blocked, maybe that has something to do with it.

The image i got towork was the official 0.5

So since that is just not working. im using the 0.5 gameshell official images which actually WORK and flash correctly . So i shjpould be able to install Mupen 64 using the script. But that doesnt work, it keeps freezing while building the core.

They tell me its because my wifi power save needs to be off, so i tried the command from here to turn it off but that didnt work.: How to disable wifi power save to prevent disconnects

iw wlan0 set power_save off

doesnt work gives an error.

also dont post to mirrors of the DEOT images because dled those all day and they dnot work and i have like 5 copies of them and htey dont boot they arent recognized by balena and gives all kinds of errors and dont download right. You need to put them in a torrent or something. Thats how i got the gameshell 0.5 image i think.

EDIT: Okay i got the wifi power save set OFF. so i narrowed that down. its not the wifi.
Its still crashing while building the core of mupen, with the setup script…

Did you remove the .bz extension from the file and/or have you unpacked the tar file so that it becomes something like *.img before using balena or the likes ? I made that mistake once…

Yes, I unpacked them, unzipped them, tried the img.

Its really frustrating because im now dling tghe DEOT AGAIN and its doing the same thing , hanging up at the end up the dl and not completing

Use sudo

sudo iw wlan0 set power_save off

But nowadays that is integrated in the launcher, one or more of the power options in settings should set that one.

Just posting the solution to the problem here … again, to resolve and hopefully mark this as solved. It was cross posted across a few threads.
In a nutshell: incomplete download problems.

This thread is a duplicate/continuation of this one:

Getting back onto mupen core problems. Like I mentioned in another thread, you need to be patient. Just on the mupen core compilation, it can take 10-15 minutes. This is compiling. There is no verbose feedback. You just need to wait it out. Same thing applies to download. You gotta be patient. Perhaps don’t download more than one thing. Consider purchasing a network cable, and connecting to your router directly. This is for your computer laptop, since you appear to be having problems just downloading the image.

I don’t recommend you use the DEOT v2.0+ 0.5. It is in its early days. I will be posting hot fixes, updates, and version revisions. This will require lots of redownloading. You will be going back and forwards with questions.

EDIT: okay, i think you were right about download issues on my end, but its just the megaupload and google drive hosts that werent dling right, i found one that is downloading from this host https://pcroz.stackstorage.com/s/a26iBYxvkQ5VSgS

so hopefully that image will work.

Just warning you in advance; please don’t be upset when a new version comes out in a day or too. Or if I post up hot fixes for fixing up things the community find needs tweaking. It will require you to download another file. You may feel as though you are wasting your time.
I strongly recommend that you download the DEOT v1.0+ version, unless you plan on using the warehouse function.

Nope, its still not downloading, its freeizing at 2.8 gb and not finishing the dl

Weird let me check some things here …

1 Like

Honestly, it sounds like you’re having problems with data packets dropping either with your modem, or with your wifi signal. Please actually try all of these troubleshooting points.

All of your problems seem to be somewhat related. The fact you downloaded the 0.5 image comes down to both sheer luck and that they are hosted on higher speed commercial servers; something I don’t have access to.

I have no idea what kind of modem you are using, but if you’re using ADSL potentially try using a shorter phone cable from your wall to your modem.

If you have fibre optic, and have some kind of shared node, you might just need to wait till whoever is sharing it reduces their bandwidth. Or have your FTTN box looked at.

If it’s a fibre to the premise, you may need to get your provider to check the integrity of your FTTB box.

If you’re on some kind of data sim router, then I guess try moving it to a window or something? Or use if in a place with less phone reception congestion.

If you definitely can’t get your hands on a simple cat5 or 6 cable, try changing your wifi channel. 1, 6 and 11 are usually good bets if you live in a congested wifi area.

Try and use your computer as close to your router as possible. Also see if you can use wireless G over N (or AC) - for the sake of stability.

Disable any power savings modes in your computer. Download only one thing at once. Don’t do anything else on your computer while downloading your file.

i have disabled all power settings in gameshell and in winscp,

my computer is already right beside my router… i wasnt downloading anything else at once.

i HAVE cat5 cables (ethernet cables?) but i still dont want to set up usb ethernet that seems like a whole other nightmare. Installing more packages just to get that to work. If i cant install packages well to begin with how ami gonna dothat…

i really dont thjink the problem is with my wifi since its freezing at the exact same point every time, im pretty sure the problem is with the SETUP SCRIPT

Before touching anything on your gameshell, I was more implying to change the power profile in your computer. This is just to download it; nothing to do with l winscp.

Try and use a cat 5 or better yet a cat 6 Ethernet cable, especially if your computer is right next to your router.

You won’t be able to install the image until you have a complete image downloaded.

I’m going to take a guess here and say that once you do get all of this set up, you’re not going to be 100% happy with the N64 emulation. It doesn’t have a user friendly GUI interface, you can’t toggle settings from within an app, you can’t easily change controls without converting keys to numerical codes, and there isn’t a 100% compatibility rate for Roms.

If it’s taking this much effort just to download the image, I fear there is going to have to be a lot of follow up posts, with complaints of things that the community is working hard to work towards, but hasn’t currently been attained. I’m just giving you forewarning to not be upset with the results being less than what you have expected .

I have never had any problems downloadng any other files on this computer, to complettion. So i have no idea why simply changing my power profile is gonna make the files download ???

BTW , I was already on best performance mode

i just downloaded a 3.6 gig file earlier today from another site with no problem at all , along with movies, and countless other games, ive downloaded without any problems on this computer without having to use an ethernet cable so idk how that is gonna help

can we confirm that theres anyone else whos actually downloadd this image on windows (not mac or linux) actually has it working because ive tried dling it on multiple computers and browsers and hosts…

I’m just trying to help, seeing as you’re having trouble downloading from so many places.
For troubleshooting, you might want to also state what kind of an internet connection you’re using, what speeds you are normally used to, what country you are downloading from, actual download speeds/times (not exaggerated), operating system and browser configurations, ie, which ones, antivirus setup, modified hosts files, content/ad blockers,

i really dont think its my internet i think the script just desnt work, watch me go waste my time hooking up an ethernet cable for no reason and it still wont work…

im pretty sure the script is broken

its not gonna magically wor kif i just go and plug a ethernet cable into my laptop

at this point im just gonna give up i really dont think its my internet i think its the script

Just on a side note, could we please keep the general tone of this thread civil, and less frustrated pre-emptively at advice I am trying to give with good intents? The more aggressive the tone gets, the less I feel compelled to want to help in this thread, and in future posts you may have, no doubt pertaining to wanting Mupen64 to run faster.
I mean this as sincerely as possible. Let’s try and keep this a happy positive place. Please.
I don’t know anything about your setup, besides downloads not working. These are standard procedures to take to solve a standard problem, short of simply asking, “have you tried turning it off and on again?”
I normally would want to keep helping people till the end, but I think this is taking up far too much energy from both parties.
This is the script that the community has come up with together. One of the devs here has used it on 0.5 and has gotten it working. I have discussed it working with other users. There is something wrong with the way you are using it. I have suggested telling you to use USB to Ethernet in the past. The notion of having to set it up turned you off. This is just what you need to do unfortunately.

1 Like

but setting up USB to ethernet involves downloadng additopnal packages, thus, we are back to the same problem, of packages not downloading…so if my problem is packages not downloading, how am i gonna solve that , by downloading more packages for USB ethernet?? if i cant … see what im saying here

Downloading of said packages is possibly related to a previous build, ie probably 0.2. The packages I believe you need to download are on the windows side of things. That and setting things up. Perhaps send your queries to a relevant USB to Ethernet thread, using windows.

Have a read of this post within one of the threads:

okay that thread says This is outdated,in os image v0.3 or later,usb network is already included,just flash the os image so im on 0.5 should work but doesnt woooooo

Just reading those threds on stting up USB ethernet seems like a whole other nightmare i could be

Have you set it up on the windows end, downloading drivers, identifying the device and changing the gateway?
At this rate, I’m strongly recommending you to go to an Internet cafe, pay for an hour and just sit there downloading files. There’s clearly something wrong with your setup at home, and if you’re not prepared to take some time to follow some threads to fix things, this will be the next best thing.