My GameShell's LCD won't power on

Recently I’ve been trying to resurrect a GameShell I bought back in 2020 or so. The charging port was snapped off, I tried resoldering a replacement but the one I got didn’t have a compatible footprint. So, I attached a compatible charging circuit (harvested from a book lamp) to the battery module so I can charge it externally. The ribbon cable was torn so I got a replacement on Amazon from this thread:

It arrived today, so I connected it and then I flashed a microSD with the new v0.6 gamma image. Power on, the green LED is lit but it’s a bit dim! No image on LCD… I will try the DEOT OS instead and see if that works.

I tried the DEOT image, still no dice! I tested the continuity of the screen to the mainboard and they’re 100% connected. I also get the same behavior whether a microSD card is inserted or not… strange. My mainboard must be defective :crying_cat_face:

I can’t remember, it’s been a couple of weeks since I played with mine due to the damaged cable. But I think if you get a light, it’s loading the kernel but something else must be happening. Try v0.5 and see if it boots? Or, perhaps you have something going on with the power. I think there are a few places you can check for 5V and maybe 3.3V to make sure you are getting enough power. Do you know how many amps the charging circuit can put out? If I remember right, it needs like about as much as a Pi 3.

The green LED lights up (dimly) even without a microSD inserted, so it can’t mean the kernel is loaded. As for the charging circuit, I only use it to charge the battery after it’s dead. The battery should be at full charge now but I’ll try powering up purely off USB.
I’ll test v0.5 and check the schematic to see if there are test points to verify power supply. The green LED isn’t as bright as I remember so it could perhaps be a sign of power troubles?
Also the board gets toasty so it must be doing something.

No luck with v0.5 either. There is an inductor on the board with a chip in its ceramic.
Screen Shot 2023-12-09 at 10.38.04 AM
Looks like it’s part of the power circuit, even though it’s chipped it appears to still be able to work but I guess not. I’ll furnish photos when I can

That may change the magnetic properties of the inductor. If you still have the break out cable for the connector on the board next to the reset, you can check 3.3v and 5v on that connector. It’s in the schematic I think as a debug port.

I didn’t have the breakout connector so I just took my multimeter and measured from the debug port’s SMD traces. The 3.3v (VCC-3V0 on schematic?) line measured as exactly 3.00v (red probe on VCC-3V0, black probe on ground). 5v rail was 5.15v which should be within spec.
I’m gonna email Clockwork support and see if they can hook me up with a replacement mainboard, just in case I can’t fix this one. I guess I have to find someone near Washington, DC who can do board-level repairs (nobody yet) and I’d also need a replacement for that particular broken inductor.