Need help getting Mupen64 working

Have you set it up on the windows end, downloading drivers, identifying the device and changing the gateway?
At this rate, I’m strongly recommending you to go to an Internet cafe, pay for an hour and just sit there downloading files. There’s clearly something wrong with your setup at home, and if you’re not prepared to take some time to follow some threads to fix things, this will be the next best thing.

i mean mupen wont DOWNLOAD but i had NO PROBLEM downloading PCSX rearmed and other standalone emulators

Mupen was never working. It is something I have discussed with guu, and he has provided a fix, only requiring users to run that same script you are having so much difficulty with.
Perhaps there will be a future 0.51 release with if included. For now I have made an attempt at doing exactly that, but you have had trouble downloading it.
Go to an Internet cafe. Try there.
The standalone emulators you mention don’t require additional dependencies. Mupen does. It also requires building. The other ones don’t. You just whack in an application, and run an action.config file.

why cant you put the depencencies into a zip format and just upload them so we can just drag them into the GS rather tha nrelying on everyones poor wifi connections to sustain themselves long enogh to dl the files

… I did. Let me find the post.
Ugh. You’ve kinda cross posted in way too many threads, that I can’t find the post it’s referenced in. Look in the same place you downloaded the initial script.
Here’s the problem.

The script is, well, scripted to download the files. You’ll need go modify the script to not do this, and simply decompress the zip files and build them. Any update that does it for you would require you to do the same. The easiest way to do it is to have it all done for you.

Try starting a thread asking someone to torrent one of the pre made images for you, or to host it somewhere. I can’t help you with that. I’ve done all I can with the links I’ve provided; none of which seem to work.

You haven’t told me the details from this post. I can’t really help without knowing more.

i knew it was the script , not my wifi, i spent all this time trying to make my wifi faster. but it was the script.

Well i give up. im not gonna modifyh the script if it doesnt work, that too much work and beyond my skill level, ill just wait or just give up iDK

Oh my goodness it’s not the script. I’m just saying, if you want to drag and drop the zip files yourself, it will be a redundant step to redownload it via the script.

The script has instructions.

  1. Download the dependencies
  2. Decompress the dependencies
  3. Move the dependencies
  4. Build the dependencies

It’s a set of instructions. A recipe. It is an order of things. I’m just trying to help you not waste time. I have a feeling your problems lie in step 4; not being patient. Please. Just try running the script. And leaving the console and your laptop alone for an hour. Maybe two.

Here is the script. It’s the same script. It’s just here so you can read it to know what it does.

I cant just let it run , its disconnecting itself . thats what s sop frustrating.

It has a timeout after 60 seconds. It wont even wait 5 minutes let along an hour… Thats the whole problem

Back in like, the 90’s when I used to use windows, on dialup, I used to use a program called putty for SSH use etc. It’s just what we used at University.
I honestly can’t help you with how to use winscp or whatever. It’s not what I ever personally used.
Here is a link to putty.

As a side, I have attempted and succeeded to download all of the images from a windows machine. I have flashed each downloaded image to an SD card. The images work. So too do the download links. I was using windows 10, the stock Edge browser, the Internet explorer browser, and Chrome. I don’t use Firefox because I like having free memory/resources. I was using a boot camp partition on my MacBook Retina. The fault appears to be at your end I am afraid.

I know about Putty, havent tried it . WIll give that a try, thats a good idea.

I guess im having trouble dling the images, I figured it was just me since others seem to have been ableto download them, Anyway. The best solution is not to have to flash again at all, since ive got a 0.5 image on there working now with a few emus set up.

I will try installing Mupen64 with Putty and see how it goes…

Okay, It appears ive got it working . After using PUTTY. it installed fine. so the problem was winscp being slow for dling packages( i think i had issues with it before) Anyway. I now started up Mario 64 and its working. Thanks for all the help …

1 Like

Great that you got it working.

I’m assuming that you have also moved the custom action.config file and the mupen64plus.cfg file to their respective places? They have been optimised for use on the gameshell.

Just wanting to possibly interject, saying it wasn’t that winscp wasn’t downloading the files correctly. It came down to winscp disconnecting, while trying to build the files.

I really did try and help as much as I could. I am just going to smile, and assume the subsequent ellipses are a coy mannerism inherent in your nature.

I’m glad you have something working. I’ve tied up the loose ends of the cross posting in other threads, so hopefully others who might be experiencing your woes can have some closure. If you want to mark them all as solved, that would be fantastic; if indeed they are solved.

Hey man. Any idea how copy over save files from my N64 games when changing to a different OS? It would be awesome to not lose all progress in games when I change over to your custom DEOX 0.5.

Thanks again.

Yes indeed! Thanks for the suggestion! I’ll put it in the main instructions.
Mupen settings are held in ~/.local/share/mupen64plus/save
Save rams are the *.sra files AND/OR *.eep files. Some games use one or the other strangely.
Memory pak data are the *.mpk files.
State save slots are the *.st0 files.

Which brings up another point! That custom OS has a slightly optimised mupen config that runs a bit faster, and now has state saves. Save using shift+select, and load using shift+start. Menu no longer instantly quits out. Use shift+menu to quit. The menu button is now a turbo button. Great for getting past those long unskippable cutscenes. I’m looking at you, Banjo Kazooie!

Did you ever upload your custom key layout? I’d be happy to include it in the next release, even as a separate key binding just for Banjo Kazooie/Tooie.

The specific key layout I use? I did not, thinking some might have other preferences. But I can, if you like!

1 Like

Yes please! :smiley: Any contribution would be great! To be honest, I spend more time playing RPGs, and FPS’s on the gameshell, so I don’t usually require the Lightkey. Any setup I use would be optimised to not use it. An optimised setup coming from someone who actively uses it would be much appreciated! Plus someone who has played through most of Banjo Kazooie on the Gameshell, since while unlocking abilities, you will no doubt find inherent control layout optimisations.

Is there any way to get access to your custom OS files (and changes you’ve made, like the mupen config mentioned here), other than flashing the entire image? I decided to go with the official 0.5 image, because I’ve been tinkering with other things, but I’d like to be able to use your new mupen config. (And it might be useful for grabbing parts of other things too.) Thanks!

100% yes!! The original DEOT v1+ 0.4 has a plethora of links showing how each thing has been applied. I actually strongly recommend and encourage people to build things themselves. I didn’t provide the same links in the DEOT v2+ 0.5 OP since they’re basically identical. Although that reminds me! I should put the Picodrive reference up!

As for the mupen64plus config, installation script, action file and dependencies, they can be found on the same google drive link I post the images on. Here’s a direct link.

The rest of the bits and bobs I did can be found in a whole heap of other directories.

That’s most of them. You’ll need to go through the notes in the OP of the two DEOT image threads to understand where to put most of the files. Or just ask me in the relevant thread. :slight_smile:

Basically, I got sick of all of the negative posts slamming the devs, asking for things to be done for people, that I decided to try and solve as many problems as possible in a positive light. I just want to keep things happy and moving. Negativity just makes people disinclined to do anything.

1 Like

I’ll go ahead and send my config via PM since I’d rather other use yours since you said it’s faster. Or should I modify your faster one with my key layout and send it back to you?

Also, will replacing my config with yours delete all my current saves or no?

1 Like

It shouldn’t delete the saves, since they’re held in a separate folder, and I haven’t specified any differently. Should be good! And PM received! Thanks!