clockworkpi

How to get mupen64+ to run?

could you offer a way of just the n64 emultaor and not making us flash our entire OS just to get mupen64? i dont really wnt to have to format just for that and shouldnt have to and if it doesnt work it will just be a waste

There is a way, and boy have I tried to help many people.

Here’s a post I made on the 0.5 thread.

It should be simple enough, and I have no idea why so many people have difficulty getting it to run. I think it comes down to user error, not typing the correct syntax or not waiting for things to fully build/compile. That and not applying the correct permissions to scripts, or doing things only partially.

I can try and guide you through the process if you would like.

Otherwise, wait for me or someone else to pre package it all to be easily installed using the new garage system in 0.5.

Edit: Oh!! Hahah as of 5 mins ago, I’ve been DMing guu! Looks like it’s going to be integrated into the official release!! Well there you go! It might even be updatable, although people have had hit and miss results with updating. See how that goes!

Any hopes of getting Mupen64 to play super smooth on the Gameshell? That was my dream when purchasing it and it would be amazing to see it one day. Anyone have it running awesome? Banjo Kazooie was okay, but not perfect. OOT Can be super patchy. anyone have a better experience?

Potentially, you should be able to tweak the config file more. Try fiddling with things, one at a time to discern changes. Depending on which game, some things may speed up, but may break some graphics for other games.

Think about the settings that slow down PC games, ie shadows, anisopteric filtering, smoke/fog etc. There are usually corresponding config options.

Some changes will just make mupen crash outright, but that should happen far less with the most recent driver changes.

The changes to settings I’ve made are a balance between speed and accuracy. Naturally, demanding more speed would mean less accuracy.

Oh! A silly question but have you changed your power profile to “Performance?” That should give you a bit more speed. I don’t know if it actually does anything, but also try activating airplane mode.

One more thing re: Zelda. You won’t be able to make use of the “stone of agony” item, since we don’t have a rumble pak attachment… yet. ;).

I already found that my self on your google drive before you posted that and tried it. i couldnt get the mupen.sh script for the dependencies to run. i cmodded it and it didnt run.

when you say cmodded it, did you mean chmod?
I’m also guessing you meant mupen.sh.
Any small typos made when doing a command would result in things not working.
Assuming you put it in the home directory;

sudo chmod +x ~/mupen.sh
./mupen.sh

Sorry, i saw you had the instrucitons on how to run the .sh install in your other post. So im doing that now. its downloading dependencies but its had to abort one thing but it kept going…

it keeps screwing up in winscp downloading the mupen and saying host not communicating more than 15 seconds try to disable optimized buffer or something , which i did… still; trying to dl all the depencendies

1 Like

it keeps disconnecting while dling the dependencies and aborting in winscp… ive tried like 50 times now it gets stuck on mupen64core

I think its got everything downloaded but it wont build it.It starts building the core then screws up

Try connecting via ethernet over USB. I can’t unfortunately make the wifi more stable at your end. Don’t forget to change your network gateway switch in settings.
You can find the USB-Ethernet IP address in the tiny cloud app.

Are you sure you tried 50 times? If you managed to attempt it that many times within 22 minutes, then there was probably something wrong with your initial syntax, and/or your wifi in general is messed up. That’s going at a rate of 2 mins 30 seconds per attempt which is FAR too short. I would doubt everything is downloaded. You have to be extremely patient. It takes A LONG TIME to build. I’m guessing your 50 times was just a figure of speech.

On another note, it is now included in the 0.5 update. Guu followed the same instructions I provided you, and had it working. There appears to be something wrong at your end, and I am happy to help you work it out, if you were adamant on not using a fresh image.

i cant connect to ether net by USB , that would need a special cable or something and i dont have it
i odnt want to flash the 0.5 image . since that might brick it. and also wil lbreak all my other emulators.

i tried to upgrade from guu’s sh script to 0.5 but of course that didnt work either guess my wifi is too slow.

I am just going to flash the 0.5 image and see if that works.

The cable is the same one that you would use to charge your game shell. Nothing special is needed thankfully.

If you can buy a spare SD card, which costs about the same as a cup of coffee, you don’t need to worry about bricking your system.

What other emulators are you referring to breaking?

yes but my router doesnt have usb ethernet connections on it

You plug it into your computer, that I’m assuming is connected to your router. It’s USB to Ethernet.
There are some threads on the forum. Have a read through them, and hopefully you can get it working.
https://forum.clockworkpi.com/search?q=usb%20to%20ethernet

i already flashed the new 0.5 image since u said mupen64 worked on it, it still doesnt work, says invalid when i try and load a game, wont even set up the engine lol

It still doesnt work in the 0.5 release. I think i need the custom deot image by guu. you said it was in the 0.5 update so i got that but nope.

You need the 0.4 deot image i guess i have to dl anothe 2 gigs and flash it again whoooo

In fact theres even people in that thread saying it doesnt work in the 0.5 update

Also im on 0.5 now (was 0.4 before maybe thats why it wasnt working) Now tryingf to update the script again. Also what if im plugged in USB ethernet to a laptop. which doesnt have ethernet?

i have no computers right now hooked up via ether net its all wifi

I just looked up how to actually connect USB-ethernet and it is NOT just a matter of plugging it in., you gotta install a bunch of packaged first just to setthat up lol. im just gonna use the DEOT image which SUPPOSE to have mupen64 working

Have you tried updating it? Here is the post referencing mupen working on 0.5: GameShell OS image files (v0.5)

The custom DEOT image was actually by me. It is based on 0.4. I am currently in the process of doing my next custom release based on 0.5, with mupen installed and whatever else people seem to need.

You don’t need to have anything connected via ethernet. As long as you have something that can bridge an internet connection, say via wifi, you will be able to do it.

I don’t use windows machines, so I have no idea what you need. On top of that, a lot of those threads are potentially out of date, and things DO change. A lot of those packages potentially come pre installed. I left those links there for you to peruse, as it would be a waste of my time to do so, since these days I just plug it in and it works.
My computer is a mac. I just plug it in, and it works. I have no idea what your scenario is. I was just hoping to point you in the right direction.

I’m not sure what kind of tone you’re using with your current posts, or if it is a language barrier; but it sounds as though you are getting a bit aggressive towards me. I am sorry. I am just trying to help.

If you are frustrated with the 2GB download being slow, or anything, I have had a lot of helpful users also provide alternative mirrors that may be faster depending on your location.

Please be calm, drink some water and try not to be upset. I am here to help you.

1 Like

I’ve provided a link with MANY mirrors to the DEOT V1.0+, build 191122 based on 0.4. From the other DEOT V2.0+ thread, it sounds like you are having trouble with download speeds re: google drive.

Unfortunately, the link gets buried with small back and forth messages, so I’ve provided it here for you, and anyone else who might be wanting to get mupen working, but just wants a complete image.

This image is the final of its build. It is considered old stable.
Judging by the problems experience here, and the abborrence of being told to flash a new image as things get updated, the new DEOT V2.0+ image is better suited to someone who enjoys troubleshooting. The DEOT V1.0+ image is for someone who just wants to set an image up, and not have to worry about things.

I can only do so much from my end re: uploading. I depend upon the help of others, as my bandwidth is limited. There’s no way I could have expected someone else to both download, and reupload my files in a short space of time.

I hope this makes things clear for you. I hope you understand.

i tried all those mirriors for the 0.4 deot image. seems like the tar.gz arent dling right. they arent completing. im trying mega upload now to see if that works

edit:
I tried everywherei could to dl the images for the 0.4 deot image and they dont seem to dl right. if they are completed , i extracted one and got just the img file and it wouldnt work in balena. it says its n invalid image.

I had no problem dling the official 0.5 img (not DEOT) and flashing that with balena , but it was an img file.

icould still TRY to flash it, but it says its not bootable and doesnt appear to have a partition table

(edit: Tried flashing with the image anyway and got no power just black screen)

I believe that in first boot it runs the auto expand script which may take a while. I will also download and test it for you.

1 Like

Only because your same issues were cross posted across numerous posts, I am just going to post your reply here, and realisation; for future readers who may come across these posts.

The same user above has made another thread, continuing the same problem as above. Here is the link, for future people following this thread.

They ended up resolving it, using Putty.