PLEASE HELP. All but one emulator crashes

Most apps once open just take me back to the main menu. Is there a way to factory reset this? Only the ps1 stand alone emulator works. I am using windows.

If you have put the emulators on the gameshell, did you give the correct file permissions? You have to make them “executable” for them to work.
Also, which OS version are you using?

its just the standard emulators. iam using the newest version of the os on the newest game shell

Did you set up the emulators from retroarch?

I have not touched it

All you gotta do is open retroarch on your gameshell, and download all the cores to the corresponding emulators

It is not an retroarch issue. The gameshell apps themselves are crashing. All except the native psx emulator.

select Settings->GPU Driver Switch->FBTURBO

The latest launcher update has a retroarch core manager. Update it via settings->update launcher while online.

Not necessarily a factory reset, but if you manually delete all of your cores etc via this menu

, it will prompt you to download and “install” the cores as required.

Most of the apps in retro games, besides the ones with a plus sign, and the PSX emulator depend on Retroarch. I’d check your retroarch config while you’re at it. There was a bug when using certain scripts to “auto configure” your retro arch according to settings pertaining to an older version.

I dont have the update? Can I do this through another program? I tried updating and it says its up to date. thanks

Are you using 0.4? This update possibly would be one for the current clockwork OS.

These were my last two launcher versions.


I would recommend to view logging first. See if you can pull the logs via SSH from:

/dev/shm/runcommand.log (Leave the original logs and copy them elsewhere)
/home/pi/.emulationstation/ (Leave the original logs and copy them elsewhere)

Comb through the logs and see if you can find anything in particular stating why the emulators are crashing. It could be worth reinstalling the Emulators via Terminal. Then a full kernal reinstall if no go.

How can I reinstalled the full kernal. Nothing has worked. Something as simple as resetting the damn thing should have been a feature.

maybe reflash the whole SD-card with an os image


HOw would I be able to do that?

Hey, here’s a post with a similar question:

There is a link further down in the post given by @guu with a custom 0.4 image that will auto expand to take up your entire SD card.

@Rebusmind made a great custom 0.3 image with extra emulators. They provide instruction on how to expand their image, along with how to set up a few other important bits and bobs.

Hopefully you’ll be back and running soon!

1 Like

get the sdcard out of GameShell

download the image!IUkxQSjB!d_H9leVSSl6tDP4X0oWnag

insert SD card into PC

use etcher or win32DiskImage ( if you are on windows ), I think etcher is easier to use

  1. select the downloaded image as source
  2. the inserted sd card as target
  3. flash it
  4. when it done, unplug sd-card from PC , re-insert into GameShell

took a etcher screenshot from @javelinface

1 Like

I do not have an adapter for the micro sd card.How Can I do this without that? Thank u

maybe to buy an adapter?

1 Like

Do you mean an adaptor to insert a micro SD card into to make if a standard SD card? They usually are bundled with SD Cards when you buy them.
A lot of laptops have an SD card built in.

If you don’t have an SD card reader, some SD cards come with a micro SD to USB adaptor. Some Lexar ones I’ve bought come with this.

Otherwise, if you know pretty much any technologically minded person, or even a computer shop, they will no doubt have them scattered in drawers in their house, and will happily give it to you. Heck. They’ll probably burn the image if you let them play with the gameshell a bit.

As @guu said though, you can just buy one online for probably less than a dollar. They’re just that cheap.