RetroArch Asking for Login

Let me start off by saying that I am an amateur at this. But I have been proceeding carefully, reading and searching the forums for answers, and really had a mostly flawless experience so far.

Long story made short: In my final steps of setting up, RetroArch was updated and now is asking for “clockwork pi login:” followed by a password.

Not having a keyboard attached makes it impossible to enter anything.

Before I uninstall RetroArch and reinstall it, I wanted to see if there was an obvious answer that I am missing? It seems like a start up parameter was dropped during the update, but I have no idea how to reinstate it.

It is asking for a password ON the gameshell? You aren’t ssh’d into the device or anything?
Provide some pictures if you can.

PS - This might be more suited for the retroarch megathread RetroArch Megathread as it pertains specifically to retroarch.

If this login prompt is shown on the GameShell screen upon rebooting then this is not related to the RetroArch.

This means that the proper boot sequence is not working as expected. This is normal for a linux system, which is what the GameShell is. Normally, you would not see this, it should start the Launcher and you would see the “normal” GameShell screen with the icons.

My only recommendation is that you backup anything you might have put on the GameShell and start over by putting the Clockwork OS image on the SD Card again.

Gameshell works as expected. The system boots up with no issues, presents the same menu as usual. When I select RetroArch on the menu, it starts the app, then comes up with the log in screen.

What I did:

  1. Assembled the Gameshell.

  2. Plugged it in to charge the battery.

  3. I was going to give it time to charge, but it autobooted.

  4. Everything worked. Set up wi-fi, transferred some files through WinSCP. Tested it out. No issues. Did an update through the GS.

  5. I had a bigger SD card available. So I downloaded the latest GS image. Used Etcher to prep the SD card.

  6. I disassembled the GS to switch SD cards. Booted. No issues. Everything worked as expected.

  7. I went through some of the steps above again. Set up wifi, moved some files, tested it. Everything checked out okay.

  8. I did an update through GS and tested again. No problems.

Here is where I think things went south.

  1. I used a command I found on the forum to expand the memory partition. This command: GameShell won't recognize my 64gb card
  2. During the process one of the prompts asked if I wanted to update RetroArch. I figured it couldn’t hurt. So I let it.
    11 Rebooted. SD card was now fully available, but RetroArch was presenting this log in.

The same problem as me,just yesterday after I update OS 0.3 and use the gameshell-setup,include the RetroArch update.

Anyway,I think you can try to cover the RetroArch’s retroarch.cfg by tool,for example
the WinSCP. HERE it’s my file,and it’s works fine on my GS.

the file location is:


hope to help

1 Like

That seems to have worked, thanks!

Had the same problem a few days ago, also solved it by uploading a backup config file.

I could be wrong, but the retroarch.cfg loaded by the above mentioned script includes the line:
video_driver = “gl”

Using a fresh cfg file in retroarch, I have been able to replicate this same dumping to the login screen, changing the video driver manually in the GUI and restarting retroarch. Similarly, manually editing the line into the cfg yields the same results.

This seems to happen, regardless of what GPU driver switch is set to; FBTurbo/Lima, on both clockworkOS 0.3 and 0.4.

Changing the line as follows results in being sent back to the launcher. (Albeit not a login screen)
video_driver = “xvideo”

Changing the line as follows in the cfg file restores functionality.
video_driver = “sdl2”

There have been a few cases of people having this problem, without much resolution - although I may not have been searching hard enough.

Can anyone confirm whether or not this fixes up their retroarch, allowing it to run?

Apologies if this has already been covered.

Another interesting thing that I can reproduce on OS 0.21:

Within the Retroarch menu, under Driver, the Video Driver is initially set to “SDL”. But if I scroll left or right to see the other options, SDL gets replaced by SDL2.

If I exit Retroarch (which automatically saves settings), I won’t be able to get back in unless I edit ~/.config/retroarch/retroarch.cfg and manually change video_driver back to “sdl”.

I ended up reflashing my OS a couple times before I figured this one out.


I’ve met the same problem as in this post. Recovering

works for me.

These days, with the 0.5 image with optimised Lima drivers, you can actually use the GL video driver. You may need to rebuild and update your Retroarch, including the GL parameters. This also lets you use the XMB menu driver.

Do you had this problem?

This was the problem people had, trying to change the graphics mode fo GL on older builds. My guess is that the older builds didn’t have the GL dependencies installed, so threw that error message.
I’m guessing you changed your graphics settings? In which case try manually editing it to change it back.

just call a file in bash will execute it, this is a text file not a program so it not have the execute bit set (chmod +x)
so bash just say you you don’t have permission to execute it, it’s not an issue

posts upper talk about editing the config file or restoring it to an old backuped state, that’s pretty different

you may go learn some linux shell basis

1 Like