RetroArch Megathread

Thanks for the great tutorial which I’ve completed fully (well except for what I’m about to ask) but for some reason I’m stuck and I’ve no clue why. I have a few questions if peeps could help as I’ve never used RetroArch and find it pretty confusing if I’m honest.

1 - I can’t seem to make sense of your directories. I’m fine with the folder structure however not what’s in it or what folder is selected in the directory config.

So you have


In the ‘system folder’ have you copied the original contents of the retrorarch folder into this? Then set the System/BIOS location to this system folder?

I mean all of these files:


2 - Have you set the ‘File Browser’ location within the directory config to the games folder?

3 - Within the ‘games’ folder do you put games for all systems in here? Or are the folders separated out?

4 - Has the ‘retrogames’ icon on the home screen got anything to do with RetroArch or is this another thing that’s been added to the GS? If it’s not related then can it be removed as everything is on RetroArch?


:wave: can someone post their final retroarch.cfg after changing the keybindings? Mine somehow got all mixed up and I cannot select anything in the retroarch menu. Thanks!

Hey I updated my database on “Online Updater” now my “Download Cores” list is super different.

How to revert?

Database can’t change anything it’s just for the rom scanner.

What I did was I added the retroarch folder in /home/cpi/games (so it should be on /home/cpi/games/retroarch which is completely separate from /home/cpi/retroarch).

The folder /home/cpi/retroarch contains the source code that you have to “make” to update the RetroArch application which came shipped with your GameShell.

The folder /home/cpi/games/retroarch is the one that will contain the files needed to run games on Retroarch. This is the folder that you need to reference while configuring RetroArch and this is the folder where you will have to put your games/roms in (so if you are following the folder structure so far, it should be on /home/cpi/games/retroarch/games).

As for the “retrogame” icons, these comes shipped with GameShell and so they are already there whether you have updated RetroArch or not. These “retrogame” icons are just shortcuts to the various emulators (instead of opening RetroArch and navigating through its menus).

Just note though that you have to manually add new shortcuts for emulators you want to use if you want them to show up as an icon in the GameShell menu. To do that (or if you want to remove an icon), just follow the steps here.

Hope this helps.


Just a follow-up question on setting up directories.

After creating the four folders:

It’s not clear which directories I’m supposed to choose for which option.

The thread recommends setting up these options: System, Savefile, Savestate, File Browser

Can you just clarify which option goes with which folder?

Is this right?
Savefile TO /home/cpi/games/retroarch/saves
Savestate TO /home/cpi/games/retroarch/states
System TO /home/cpi/games/retroarch/system
File Browser TO /home/cpi/games/retroarch/games

Do you recommend setting up more directories?
I see you have set up Downloads. Which folder is it attached to? Did you just create a Downloads folder (/home/cpi/games/retroarch/downloads)?

It doesn’t matter what goes where so long as YOU remember what is going where…

If that made any sense.


Hello. Thanks for this tutorial… everything worked fine until I tried reconfiguring the keys… I messed it up, now I have no working “Enter” key… I tried removing the config.def.keybinds.h file and other config files… to no avail. How can I reset the keys to the XBOX original configuration? Thanks!

you have to remove ~/.config/retroarch/retroarch.cfg

Thanks a lot! That didn’t seem to work, but I finally figured out how to reset the RetroArch keys to XBOX style from the GS Settings > Buttons Layout (choosing this option offers to reset Retroarch!)

Is there a way to change the rate at which the volume goes up or down when you change it? It seems to go up by 0.5db at a time but it happens SO fast

Hi everybody!

Today I flashed a new SD card and I’m trying to reinstall Retroarch from this guide. Mind you, I had already done that successfully on the original SD card. But this time, when I execute:

I get a lot of 404 errors like this:

E: Failed to fetch 404 Not Found

And at the end:

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
E: Failed to process build dependencies

What should I do?

I still can’t get

sudo apt-get build-dep retroarch

To work. It shows a bunch of 404 errors in the Terminal. I’m guessing due to that this line doesn’t work either:

./configure --disable-vulkan --disable-ffmpeg --enable-xmb --disable-materialui --disable-flac --disable-parport --disable-vulkan_display --disable-videocore --disable-videoprocessor --disable-v4l2 --enable-x11 --disable-wayland --disable-vg --disable-jack --enable-kms --disable-discord

It says that KMS is not available.

Is the server down @fr500?

@uke run this first:

sudo apt-get update

then start over with

sudo apt-get build-dep retroarch
1 Like

thanks wohali!
works now.

I know this is quite old, but if any one is having issues to get 60FPS for PCSX-rearmed on the gameshell.

Here is a recompiled .so that is compiled on the gameshell, I was able to reach 60FPS for Mega Man X4, the Core Updater .so only managed to get 22fps.

Just copy it under ~/.config/retroarch/cores/ and load it in retroarch and enjoy smooth gaming.


This is great, I was having that issue and could only make it work via the standalone. Will try this later.

@fr500 the link to your files is broken. I need to download your gPSP because the one on buildbot is broken

Any chance you’d be into working on a that will work!?


well… I got quite disappointed at the lack of solutions for GPU acceleration so I haven’t really used my GS too much.
That said the easiest thing to do would be to build it! I think building it in the GS itself yields the best results.
Anyway I’ll check this weekend.

1 Like