clockworkPi

RetroArch Megathread

retroarch
howto

#187

I must admit, I had wondered, and was going to try it out. glad to know it works, thanks.


#188

States don’t work, but saves do. Just rename the file and you’re good to go.


#189

Hi,
I am ok with other emulators. Just confused with the MAME. How can I run it? Every time I try to play Metal Slug 6, the retroarch just jumps back to the home screen.


#190

The Version of MAME in GameShell’s RetroArch requires ROMs for MAME 0.78. Any Romset much older or newer likely will not work.


#191

Out of interest, which version of MAME is your metal slug 6 on?


#192

There is no reason for states not to work.
The Pi and GS are both big endian systems, states should work across both platforms just fine.


#193

Tested a save and a state for the same title. Save worked. State didn’t. :man_shrugging:t2:


#194

I followed your guide on configuring RetroArch. Thanks a lot!
But has anyone found a good config for GB© with working sound? I noticed that Gambatte works well, save states and lots of options, but when it comes to sound, it sucks. Sameboy runs with high performance, also the sound, but no save states work at all!


#195

Sound works fine for me on everything. I run a latency of 80-96


#196

Thanks for the great tutorial which I’ve completed fully (well except for what I’m about to ask) but for some reason I’m stuck and I’ve no clue why. I have a few questions if peeps could help as I’ve never used RetroArch and find it pretty confusing if I’m honest.

1 - I can’t seem to make sense of your directories. I’m fine with the folder structure however not what’s in it or what folder is selected in the directory config.

So you have

/home/cpi
|
|—retroarch
|-------|-------games
|-------|-------saves
|-------|-------states
|-------|-------system

In the ‘system folder’ have you copied the original contents of the retrorarch folder into this? Then set the System/BIOS location to this system folder?

I mean all of these files:

2 - Have you set the ‘File Browser’ location within the directory config to the games folder?

3 - Within the ‘games’ folder do you put games for all systems in here? Or are the folders separated out?

4 - Has the ‘retrogames’ icon on the home screen got anything to do with RetroArch or is this another thing that’s been added to the GS? If it’s not related then can it be removed as everything is on RetroArch?

Thanks


#197

:wave: can someone post their final retroarch.cfg after changing the keybindings? Mine somehow got all mixed up and I cannot select anything in the retroarch menu. Thanks!


#198

Hey I updated my database on “Online Updater” now my “Download Cores” list is super different.

How to revert?


#199

Database can’t change anything it’s just for the rom scanner.


#200

What I did was I added the retroarch folder in /home/cpi/games (so it should be on /home/cpi/games/retroarch which is completely separate from /home/cpi/retroarch).

The folder /home/cpi/retroarch contains the source code that you have to “make” to update the RetroArch application which came shipped with your GameShell.

The folder /home/cpi/games/retroarch is the one that will contain the files needed to run games on Retroarch. This is the folder that you need to reference while configuring RetroArch and this is the folder where you will have to put your games/roms in (so if you are following the folder structure so far, it should be on /home/cpi/games/retroarch/games).

As for the “retrogame” icons, these comes shipped with GameShell and so they are already there whether you have updated RetroArch or not. These “retrogame” icons are just shortcuts to the various emulators (instead of opening RetroArch and navigating through its menus).

Just note though that you have to manually add new shortcuts for emulators you want to use if you want them to show up as an icon in the GameShell menu. To do that (or if you want to remove an icon), just follow the steps here.

Hope this helps.


#201

Just a follow-up question on setting up directories.

After creating the four folders:
/home/cpi/games/retroarch/games
/home/cpi/games/retroarch/saves
/home/cpi/games/retroarch/states
/home/cpi/games/retroarch/system

It’s not clear which directories I’m supposed to choose for which option.

The thread recommends setting up these options: System, Savefile, Savestate, File Browser

Can you just clarify which option goes with which folder?

Is this right?
Savefile TO /home/cpi/games/retroarch/saves
Savestate TO /home/cpi/games/retroarch/states
System TO /home/cpi/games/retroarch/system
File Browser TO /home/cpi/games/retroarch/games

Do you recommend setting up more directories?
I see you have set up Downloads. Which folder is it attached to? Did you just create a Downloads folder (/home/cpi/games/retroarch/downloads)?


#202

It doesn’t matter what goes where so long as YOU remember what is going where…

If that made any sense.


#203

Hello. Thanks for this tutorial… everything worked fine until I tried reconfiguring the keys… I messed it up, now I have no working “Enter” key… I tried removing the config.def.keybinds.h file and other config files… to no avail. How can I reset the keys to the XBOX original configuration? Thanks!


#204

you have to remove ~/.config/retroarch/retroarch.cfg


#205

Thanks a lot! That didn’t seem to work, but I finally figured out how to reset the RetroArch keys to XBOX style from the GS Settings > Buttons Layout (choosing this option offers to reset Retroarch!)


#206

Is there a way to change the rate at which the volume goes up or down when you change it? It seems to go up by 0.5db at a time but it happens SO fast