RetroArch Megathread

git clone https://github.com/libretro/gpsp
cd gpsp
make -j 2
1 Like

Thanks man. The build was a success! I was however unsuccessful in it running. Same old crashing.

Whenever you have some time, if you could take a peek I’d appreciate it. I can’t tweak it because I don’t know about any of that stuff.

I got quite disappointed at the lack of solutions for GPU acceleration so I haven’t really used my GS too much.

Uhm … I think that 0.21 have lima driver integrated:

Did anyone succesfully install a Sony PSP emulator core and would be willing to do a write up ?

XMB kills the battery real quick I think, as well… but it is damn sweet.

Bumping this thread also for picodrive libretro core:

alright so there is a new image, gonna try it out, adjust and maybe build mupen/ppsspp :stuck_out_tongue:

2 Likes

aaaaand… not gonna happen, doesn’t even allow XMB with lima so PPSSPP will not work

so I configured with these parameters now:

./configure --disable-vulkan --disable-ffmpeg --enable-xmb --disable-materialui --disable-flac --disable-parport --disable-vulkan_display --disable-videocore --disable-videoprocessor --disable-v4l2 --enable-x11 --disable-wayland --disable-vg --disable-jack --disable-discord --disable-langextra --enable-mali_fbdev

make && sudo make install

then I ran this on ssh:

sudo usermod -a -G input `whoami`

Then I changed my drivers to:

  • input: udev
  • joypad: udev
  • video: gl

then I run

sudo chvt 2
retroarch

Now it’s using mali, but it’s inconvenient to say the least.

This is all with cores from the RA updater:

  • Beetle NeoGeo Pocket is full speed now (it wasn’t before), it has a weird issue with some stuff being cut out of the frame though
  • mGBA is full speed (it skipped frames before)
  • snes9x mainline is fullspeed
  • gpgx is not fullspeed
  • pcsx rearmed: sloooooow, not built with neon, gotta build it proper
  • picodrive crashes, gotta build it properly I guess
1 Like

ok, I’ll post a small guide on building cores, so hopefully someone will make a repo of cpi enhanced cores:

always run this first:

export TARGET=~/.config/retroarch/cores/
mkdir -p ~/repositories/cores

picodrive working perfect, full speed on sonic 3

cd ~/repositories/cores
git clone https://github.com/libretro/picodrive.git picodrive
cd picodrive
git fetch origin && git reset --hard origin/master
git submodule update --init
make -f Makefile.libretro -j2 platform="armv neon hardfloat"
cp -v *.so $TARGET 

pcsx_rearmed working perfect, full speed on ridge racer type 4

cd ~/repositories/cores
git clone https://github.com/libretro/pcsx_rearmed.git
cd pcsx_rearmed
git fetch origin && git reset --hard origin/master
make -f Makefile.libretro -j2 platform=classic_armv7_a7
cp -v *.so $TARGET 
3 Likes

Thank you so much for this!!!

Seems mali only works with GL instead of GLES with this lima driver
Shame, because that means no mupen, no PPSSPP.

If I force GLES

[ERROR] [Mali fbdev]: EGL error: 12297.
Segmentation fault
1 Like

I tried to build mGBA more ways then one and it just wouldn’t run 100%.

I just used the one from the online updater

I’m talking about before the GPU update. 0.2.
I haven’t messed with 0.3 to much yet

My flavor of picodrive core is built with the following params:

make -f Makefile.libretro platform="armv neon hardfloat" -j4

Don’t know if it makes any difference better or worse comparing to yours build command

make -f Makefile.libretro -j2 platform=raspberrypi

On thing to note is that raspberry platform builds for armv6 (GameShell’s cpu is armv7) and without neon

You’re right that’s better, updated!

1 Like

I updated to 0.3 as my GS stopped loading and now when I try to bing the keys for User 1 it doesn’t register any buttons I press. I even tried the bind all to no avail. Anyone come across this and know how to fix?

for the new update, if you want to change any key, you need to go to setting, not from the retroarch, and change the button layout from the “Button Layout” menu.
after changing it, if you click y key, it will send to retroarch then you can customize your own.

Will give this a bash! Thanks!