RetroArch Megathread

I updated to 0.3 as my GS stopped loading and now when I try to bing the keys for User 1 it doesn’t register any buttons I press. I even tried the bind all to no avail. Anyone come across this and know how to fix?

for the new update, if you want to change any key, you need to go to setting, not from the retroarch, and change the button layout from the “Button Layout” menu.
after changing it, if you click y key, it will send to retroarch then you can customize your own.

Will give this a bash! Thanks!

Hi guys, I am on 2.1 (and Linux noob…)
I followed the guide at the beginning of the thread, but I can’t make this line work:

cd retroarch
./configure --disable-vulkan --disable-ffmpeg --enable-xmb --disable-materialui --disable-flac --disable-parport --disable-vulkan_display --disable-videocore --disable-videoprocessor --disable-v4l2 --enable-x11 --disable-wayland --disable-vg --disable-jack --enable-kms --disable-discord
make -j4
sudo make install

Any idea why it does not work? I am just typing what I see, I maybe be doing a very obvious mistake

Why doesn’t it work? What does it say when it doesn’t work?

I tried different things, but mainly it says that ./configure does not exist
So I guess I am not in the right folder? Like I said, I am a noob.

Yes I think that is probably the issue. If you’re trying to do what I think you’re trying to do you should be in the ‘retroarch’ folder which will be in your home folder (which you can access with the simple command “cd”).
You can change which folder you are in by typing “cd foldername”, obviously replace foldername with the name of the desired folder.

I will try again from the star now, thank you

It’s working now, I should have missed some steps before that point

I’m getting a lot of crashes and freezes in retroarch 1.7.5 and 1.7.6 on 0.3 Lima. They don’t seem to happen on Fbturbo. Is anyone else in the same boat? I know people mentioned Lima is unstable, but I couldn’t find any mention of what that instability is.

Also, if I compile retroarch, it seems to use Lima regardless of GPU setting, so crashes are abundant.

Yes, totally. It’s really frustrating. I’m on 0.3, using lima and I compiled RetroArch myself. When I try to load a game it seems to be a 40% chance of it running. I can try to load a game and it crashes to the launcher, try it again (doing exactly the same) and somehow it runs.

It reached a point that I’m not using the Gameshell at all (after a really frustrating 2-3 days) and I’m waiting for any kind of update (from the RetroArch side or Clockworkpi).

RetroArch was my only reason to buy this system and I’m really disappointed by it’s performance. I hope better days are in the horizon.

I use the stable version and things work just fine, they have mentioned that 0.3 is unstable but they are working on it so with patience this device will turn out great

That’s fair. I heard it was unstable, I just wasn’t sure how much and whether what I was experiencing was unique to my unit or not. If I use fbturbo it seems stable, but the screen tearing and judder are a bit too much, so I power through with Lima.

Well, this was a pleasant surprise.

WHEN it works, since Picodrive is very fast (although less accurate than Genesis Plus GX) it can (should) be used with Run Ahead at 2 frames. This removes the input lag in a lot of Mega Drive games!

There are some games with 3 fps of input lag, and games that are a 30 fps, witch basically doubles the problem (Chakan for example I think it has 3 real frames of input lag + 3 of nothing because of the framerate). But all in all this is a total game changer.

You can bind one key to the “Frameadvance” option and check for yourself with/without.

Hello partners. I wanted to ask you a question. I am following the great tutorial of this thread on how to add emulators to the menu through RetroArch, and for the moment everything is perfect. But of course, the issue is that it depends on the Core that is used for each emulator, we get a better or worse performance. Is there a list with the best Cores for each system? And the last question … With the mGBA Core, I have problems with sound. I have not been able to play much, but the truth is that the performance is quite good, however the sound can not say the same. Anyone else with this problem that could have solved it? I use the Core that was posted in the forum a few days ago along with that of PSXRearmed.

gPSP is crashing for me every time while mGBA is working. Any ideas?

I’m on 0.3, maybe it’s GPU driver related?

Did you download it through retroarch or through the forum links?

1 Like

I’m using the GBA core that you put yourself in the forum a few days ago. However, the sound is not perfectly fluid. Tested with A Link to the Past and Wario Ware in OS 2.0 (the one that came with the GameShell, I tested version 3.0 before and it gave me a lot of problems and I prefer to wait for a more stable version with Lima)

The mGBA core has glitchy sound, however the gpsp core that has been optimized for the gameshell runs flawlessly for me

that optimized gpsp core … can it be downloaded from retroarch directly? or where can I find that optimized core for GameShell?