RetroArch Megathread

retroarch
howto

#227

Thank you so much for this!!!


#228

Seems mali only works with GL instead of GLES with this lima driver
Shame, because that means no mupen, no PPSSPP.

If I force GLES

[ERROR] [Mali fbdev]: EGL error: 12297.
Segmentation fault

#229

I tried to build mGBA more ways then one and it just wouldn’t run 100%.


#230

I just used the one from the online updater


#231

I’m talking about before the GPU update. 0.2.
I haven’t messed with 0.3 to much yet


#232

My flavor of picodrive core is built with the following params:

make -f Makefile.libretro platform="armv neon hardfloat" -j4

Don’t know if it makes any difference better or worse comparing to yours build command

make -f Makefile.libretro -j2 platform=raspberrypi

On thing to note is that raspberry platform builds for armv6 (GameShell’s cpu is armv7) and without neon


#233

You’re right that’s better, updated!


#234

I updated to 0.3 as my GS stopped loading and now when I try to bing the keys for User 1 it doesn’t register any buttons I press. I even tried the bind all to no avail. Anyone come across this and know how to fix?


#235

for the new update, if you want to change any key, you need to go to setting, not from the retroarch, and change the button layout from the “Button Layout” menu.
after changing it, if you click y key, it will send to retroarch then you can customize your own.


#236

Will give this a bash! Thanks!


#237

Hi guys, I am on 2.1 (and Linux noob…)
I followed the guide at the beginning of the thread, but I can’t make this line work:

cd retroarch
./configure --disable-vulkan --disable-ffmpeg --enable-xmb --disable-materialui --disable-flac --disable-parport --disable-vulkan_display --disable-videocore --disable-videoprocessor --disable-v4l2 --enable-x11 --disable-wayland --disable-vg --disable-jack --enable-kms --disable-discord
make -j4
sudo make install

Any idea why it does not work? I am just typing what I see, I maybe be doing a very obvious mistake


#238

Why doesn’t it work? What does it say when it doesn’t work?


#239

I tried different things, but mainly it says that ./configure does not exist
So I guess I am not in the right folder? Like I said, I am a noob.


Crackling sound issues
#240

Yes I think that is probably the issue. If you’re trying to do what I think you’re trying to do you should be in the ‘retroarch’ folder which will be in your home folder (which you can access with the simple command “cd”).
You can change which folder you are in by typing “cd foldername”, obviously replace foldername with the name of the desired folder.


#241

I will try again from the star now, thank you


#242

It’s working now, I should have missed some steps before that point


#243

I’m getting a lot of crashes and freezes in retroarch 1.7.5 and 1.7.6 on 0.3 Lima. They don’t seem to happen on Fbturbo. Is anyone else in the same boat? I know people mentioned Lima is unstable, but I couldn’t find any mention of what that instability is.

Also, if I compile retroarch, it seems to use Lima regardless of GPU setting, so crashes are abundant.


#244

Yes, totally. It’s really frustrating. I’m on 0.3, using lima and I compiled RetroArch myself. When I try to load a game it seems to be a 40% chance of it running. I can try to load a game and it crashes to the launcher, try it again (doing exactly the same) and somehow it runs.

It reached a point that I’m not using the Gameshell at all (after a really frustrating 2-3 days) and I’m waiting for any kind of update (from the RetroArch side or Clockworkpi).

RetroArch was my only reason to buy this system and I’m really disappointed by it’s performance. I hope better days are in the horizon.


#245

I use the stable version and things work just fine, they have mentioned that 0.3 is unstable but they are working on it so with patience this device will turn out great


#246

That’s fair. I heard it was unstable, I just wasn’t sure how much and whether what I was experiencing was unique to my unit or not. If I use fbturbo it seems stable, but the screen tearing and judder are a bit too much, so I power through with Lima.