clockworkpi

RetroArch Megathread

you’ll probably need to ssh into your GS and delete the retroarch.cfg

Try this.
cd ~/.config/retroarch/ && rm -f retroarch.cfg && wget https://raw.githubusercontent.com/clockworkpi/GameShellDocs/master/retroarch.cfg

I don’t want to remove it. I prefer to edit it) I just found an answer. The search here is not very good.
Thanks anyway!

lol nothing is never perfect m8.

Hi, my version of RetroArch is v1.7.0. (Factory versión) Should I upgrade to version 1.7.3 before starting this guide?
I try to follow the guide but it always gives me error

I used this:


Worked for me.

Ok, i will try and tell you
Thanks

And then, Do i try the RetroArch Megathread guide?

As I understood it is makes process automatic. No need to do it twice

Ok, sorry but i don’t undertand english, i use translator.
I’m too new with Linux and the language is hard for me to understand too :sweat:

I tried to build the latest version today to no avail. It’s hanging at CXX deps/glslang/glslang.cpp after a few errors in the previous cpp file. I hope there’s a solution to this soon :(.

Give me a few, I’ll give it a shot

try adding --disable-opengl_core to the configure line

Edit:
Configure like this:

./configure --disable-vulkan --disable-ffmpeg --enable-xmb --disable-materialui --disable-flac --disable-parport --disable-vulkan_display --disable-videocore --disable-videoprocessor --disable-v4l2 --enable-x11 --disable-wayland --disable-vg --disable-jack --disable-discord --disable-langextra --enable-mali_fbdev --enable-opengles --disable-opengl_core --disable-opengl1
1 Like

Why not have a video tutorial

Video tutorials are a waste of time.
You have to pause, copy stuff from video description, etc.

Also, it would take me a couple hours to make a decent video, I’d rather offload that onto the readers :stuck_out_tongue:

3 Likes

Or maybe a repo with precompiled stuff, why waste electricity? and be part of the global warming? :stuck_out_tongue:

if this was something that was done up and maybed added to the repository (see other threads) it would be quite useful.

I followed the guide and was able to configure retroarch with no issues. However, when I try to run any games from an emulator it boots back to the launcher menu. I have used a few different versions of snes9x for SNES and tried mGBA, Meteor and gpSP for GBA. I also tried changing the GPU driver to Lima. Any help would be much appreciated!

1 Like

after i run this line it tells me that there are 3 apts that need to be upgraded
“0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.” so i enter sudo apt upgrade, but then it tells me that i can’t do that “Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?” and i try that, i type in “apt-get update”, the result is " Failed to process build dependencies". I just noticed as i’m writing this that retroarch is already installed, so now my question is what is the deal with these 3 apts?

when i enter make -j4 i get this:

Makefile:10: config.mk: No such file or directory
config.mk is outdated or non-existing. Run ./configure again.
Makefile:190: recipe for target ‘config.mk’ failed
make: *** [config.mk] Error 1

I have this exact same problem. The emulators in Retro Games work fine, and Retroarch loads cores without a problem, but loading games causes a short loading screen, a less-than-a-second black screen, another loading screen for a few seconds, and back to launcher. I’ve tried games zipped and unzipped. I’ve tried every core I have games for. I followed the setup instructions verbatim, and even tried a new memory card. Nothing works. I have 1.7.7 - perhaps an older version of RA works better on ClockworkPi?

[EDIT] Welp, now almost no emulators work. The MGBA, Nestopia, and MAME options in the Retro Games folder all load games, but they all have the screen freeze around 30 seconds after starting - I can still hear sound, but the only thing I can do to get out of it is power down the unit. Changing the GPU driver had no effect. So, now the only working emulator I have is Pcsx. I tried using the gPSP core available in another topic, no change. I think all three of these use Retroarch as a launcher, so I’m betting that’s the culprit, but I have no idea how to fix it. I followed the setup instructions exactly, so maybe I have a bad Clockwork Pi?

[EDIT 2] I attempted to rebuild Retroarch, and got an error that EGL was disabled. This didn’t happen the first time. I added --enable-egl to the list of commands in the .configure, and it installed okay, but nothing has changed. I still cannot load games in Retroarch, and attempting to run them through the emulators in the Retro Games folder results in a frozen screen after a few seconds.