RetroArch Megathread

retroarch
howto

#42

It’s just all the text that was shown during the compilation process


#43

Oh. That was lost awhile back, since I closed the window to try out RetroArch. >.>


#44

:frowning: Doesn´t work for me. Still can´t use “A” to enter the subfolder in the menu of RetroArch.


#45

Well if you followed the guide, you should be able to, I really dunno what to tell you.


#46

Sorry i´m a beginner…
i deleted the config file…
and then tried to copy it:
“scp https://raw.githubusercontent.com/clockworkpi/GameShellDocs/master/retroarch.cfg ~/.config/retroarch/retroarch.cfg”


#47

I re-explained input in the guide, try reading it again I guess I added some more stuff


#48

@fr500, thanks for the easy tutorial! IDK about you, but when I ssh'd into my GameShell both git and build-essentials were up to date - was it not for you?

Anyways, found some old SFCs on my hard drive and SFTP’d them onto my GS, they work like a charm :sunglasses:

Thanks again!


#49

Excellent setup guide! But there’s one problem. What do you use for the L and R buttons in RetroArch?


#50

The lightkey module…


#51

Or you can copy past the retroarch.cfg.bak to retroarch.cfg in the same folder :).


#52

Thank you for updating the way to restore the retroarch config file…
That helps me to restore my manual not working keyboard layout to default.

you save my day…:wink:


#53

For those who wants to get back the volume configuration, you have to set these lines in ~/.config/retroarch.cfg:

input_volume_down_btn: "subtract"
input_volume_up_btn: "add"

Don’t forget to close RetroArch before any modification of this file.


#54

For those who see the black squares in the XMB menu driver:
in RetroArch online updater -> update Assets
or
ssh to your cpi

git clone https://github.com/libretro/retroarch-assets
mv ./retroarch-assets/* /home/cpi/.config/retroarch/assets/ #or wherever you have set your assets directory

#55

You can also bind those from input hotkey binds


#56

I didn’t find it trough the GI, so I did it in commande line :p.
Thank you for this info.


#57

The same thing happened to me too. After following your guide for input setup, A, B, X, Y buttons stop functioning. Deleting retroarch.cfg and copying the default .cfg file did not solve the issue for me.
Edit: FIXED Turning on Unified Menu Controlles fixed the issue.


#58

You must have missed a step.
And if the default cfg doesn’t solve it then it’s not a config issue.


#59

@fr500

I was able to get into the ssh and I was able to begin the process, but when it came to the cloning part for github I ran into a problem. It said I needed a username and password to login. I used my own username and password, but this did not work and I could not find a username and password in your directions. I am a beginner with retroarch and this kind of programming, so I am trying to learn through the different forum posts on how to do this. I have included a picture of where I got stuck to help explain where I am at.


#60

that’s really weird that shouldn’t happen, ever.
Maybe you’re banned from github for some reason?

Try again I guess


#61

@fr500 I shouldn’t be banned. I just signed up for the account today because it had asked me for a username and password. I created the account because I assumed that it had to be my username and password for github. Is that what you used, your github username and password? Or did I do something wrong in the coding?