clockworkpi

RetroArch Megathread

After building, I had to SSH in and open ./config/retroarch/config.txt (whatever the config file is called I’m being speedy)

Change video_driver from “sdl2” to “gl” it should load up

Hullo! Welcome to the forums. :))

By default it installs it into the root of your home directory. All of the shortcuts in the launcher refer to it being in the .config directory.

Either change all of your emulator’s paths to the newly installed retroarch, or move the newly installed retroarch to .config, replacing the old version.

Is 1.7.8 better then 1.7.7? Maybe aspect ratio issue had been fixed/gone somehow? Or something else changed besides new features?

Well, doing a fresh install of any version will give you a few more perks. Control input problems seem to be fixed. As does actually being able to change the graphics driver to GL instead of just SDL2. Mine seems to take a tad longer to load, but that could just be because I’ve enabled too much junk.

The AI Feature looks interesting. Ie hitting a key go send a screen shot of the game to an external server, and having it identify the tech on the screen and return a super imposed screen shot back, translated to whatever language you have set. It would be great for import games!

So I guess it has more “stuff” but whether it’s better or not probably depends on whether you use retroarch, or just standalone. I actually prefer retroarch over standalone due to unified features Etc. I am also probably in the minority.

XMB needs extra assets that aren’t installed by default. If you just do a full fresh install/update you’ll get everything. The script for updating listed above works well.

It runs, but boy is the resolution going to need go be tiny!! It’s also a tad “chuggy”
image|666x500

Ok, I tried to update with method from first post but it doesn’t work. Could someone update tutorial?

ok tried that and got the 404 error, has it been updated yet?

Could you post a picture of what the 404 error looks like?

@podmaz - if you’re having trouble blue you could use HPcodecraft’s script. Same one people use for expanding their file system. There is an option to update retroarch.

Technically it’s installing it completely from scratch; fresh. It will be installed along side 1.7.7.

That said, the included 1.7.7 is a slimmed down version with unnecessary assets omitted, since they run suboptimally. Likewise, some unused instructions that aren’t compatible won’t be there anyway.

didnt get a picture, was a 404 error, usually means the page cant be found

Sorry; what I wanted to see was what you were doing that gave a 404 error for.

Ie, was it updating assets, running the update script, following the update instructions, checking the retroarch GitHub page, loading someone else’s comment from somewhere in this thread etc.

Were you then asking if the 404 error/server status has been updated? Or rather, if your retroarch has been updated, despite the 404 error?

I updated retroarch on a spare card last night for fun, and I didn’t have any issues.

Using the script above with the using Bash command to run the website to get the setup script is when I got the 404 error

Right. I actually did it manually, but script is the same.

I added to the config parameters “–enable-neon”

ok so far so good, all seems to have gone well

1 Like

what else is needed to update retroarch?

I’m not sure I get what you mean.
Did you manage to update successfully to 1.7.8?
I guess once you’ve done that, you’ll just need to either change the path that the retro emulators find retroarch, move the retroarch folder to .config, or create symbolic links.

If you have it running, in the online updater option, update assets. And add cores. Then edit the settings as needed. If you want the XMB interface, go into drivers and choose xmb in the menu driver section.

Did that cover what you needed?

I did this

I’ll keep this thread up-to-date with RetroArch news and changes. For now, I’ll start with a guide to build an up-to-date RetroArch I assume you can SSH into your GS already. Setup First let’s setup the build environment sudo apt-get install git build-essential sudo apt-get build-dep retroarch Then let’s clone the repo git clone https://github.com/libretro/RetroArch.git retroarch Enter the directory and run the following commands cd retroarch ./configure --disable-vulkan --disable-ffmpeg…

I added to the config parameters “–enable-neon”

The formatting of the forums makes the double dash merge. I should have put it in a code box.
Use this.

--enable-neon

Is it running? Did it update? Or are you just asking for other things to customise, like installing cores, or changing what the interface looks like? I’m not sure I’m following what you’re asking.

im trying to update to 1.78

Right. So did it manage to update? It takes a really long time.

nope, still on 1.77 not sure what im doing wrong