RetroArch Megathread

You can check these threads; How to transfer files with TinyCloud through SSH and How to add new emulators (Gameboy, SNES, etc.)

Hi I tried your steps and tried to run a MAME game but it says failed to load content, what format should roms be to move into and where can I find it

Hi, i unfortunatley do not have my gameshell at hand now, but will check when i get home and let you know ! I think they are *.zip based so your action.config file should contain that as file type.

Thanks for info Whizz and if you can please share a link to roms which are in zip

Probably shouldn’t be asking for roms here.

definitely shouldn’t, anywhere tbh.

Ah thank you! Stupid mistake… Fixed now…

I’ve been working through your instructions and everything seems to work fine until I run make -j4 Then it reaches this point and hangs. Please could you let me know what I need to tweak. Thanks

1 Like

I’m having the same problem as you had,

I’m a bit confused as to when you did this, or what you did to get it working?
thanks in advance!

sure thing…

so you just want to run this command:

bash <(curl -s

that will download a setup script for you.

after that, you may have to set executable permissions on that file. to do that, use this command:

sudo chmod +x

once that is done, you can run the setup script like so:


then the thing should just run and uhhhh you’ll be good to go. could take a while to compile everything. iirc i had to leave mine download/compiling for 15 minutes… maybe more?

1 Like

Great, thanks so much! I’ll try it as soon as I can!

Just noticed the website sends a 404, I’ll look for a mirror

It does? Let me know if you need me to grab a backup from my gameshell.

Hi to all,
please allow me a total noop question.
I have tried to follow your guide.

  1. i opend the ssh connection to my GH -> works fine
  2. the command: sudo apt-get install git build-essential -> works fine
  3. the command: sudo apt-get build-dep retroarch -> works fine
  4. git clone retroarch -> i dont have seen any error messages, so i think -> woks fine
  5. the command: cd retroarch -> No such file or directory
    do you know what i have done wrong?
    And Retroarch is now gone from my Start Menu and even when i browse all dirs via FTP i dont have a Retroarch dir… :frowning:
    Thank you for your Help :slight_smile:

Several times later i found out it works,
but each time GS freezes at line : CXX deps/SPIRV-Cross/spirv_parser.cpp
rally, each time…
i have already burned several cards…
Any ideas regarding these error messages…?

Did all the step and retroarch just crashes. :frowning:

im trying to setup a fresh install of 0.21 and some weird things are happening when I start to build the environment. never occurred before. is it outdated? am I forced to use 0.4 now?

Figured it out. Good to go on 0.21 with RA 1.7.8

cant get XMB working at all, keeps reverting to the defauly setup, but I can change the color pallete…

What was the issue? I cant get 1.7.8 to load at all, but 1.7.7 works without issue