clockworkPi

[Solved] No power on with cable :(


#1

Hey guys,

I made my device however it does not appear to be turning on.

I have plugged it into 2 computers with 2 cables and the computers recognise that somthing has been connected, but says that the drivers are unavailable so I can not access the SD card.

The screen doesn’t turn on either when plugged in.

I have tried to go through the manual again however I still get the same problem. Do you have any idea if I have done anything wrong? Should there be any leds lighting up on the main board?

Cheers for the help!


#2

I think most likely issue is the SD card; I would make sure it’s fully inserted. I don’t suppose you’ve got a MicroSD reader you can plug it into and use it directly on your PC?


#3

Could be the picture but it seems as if screen cable is upside down as well…but would have to take apart mine to check. If everything is assembled correctly and power is put on device (batt or usb), there should be a led blinking for start up. Otherwise follow manly stump to reflash the image on sd


#4

So, I pressed the reset button and the LED turned on and seems to be working fine now lol.

Thanks for the help!


#5

please review item.3 this post Forum category, tags and policies


#6

It doesn’t appear that your display connector is locked into place. Without the locking mechanism latched, you run the risk of the connector coming loose and damaging the display electronics.

Also your A/B and X/Y buttons are reversed.


#7

I faced this issue but I have found a main point of failure is how the power socket is connected to the box’s case. Over time the electrical contacts can become lose and pushing it in normally to reconnect it can be the straw that breaks.

— URL Removed really look like spam to me —