Sunvox on Uconsole CM4

Hi,

I got my uconsole last week and would like to use sunvox.

Does anyone have a list of steps to follow? I’m bit of a Linux noob.

I’ve tried following a few guides online and have been through this forum but no luck. when I have it installed and try to launch it, nothing happens.

I have tried the latest version and also sunvox 2.1c as per other comments.

What am I missing?

Is sdl2 installed? ……

Thanks for responding,

Yeah, the uconsole already has libsdl2-2.0.0-2.0.14 installed and I have tried reinstalling it

Which SO? Kernel? Launching from tty, terminal…?

Hi,
I’m using the sd card that came with the uconsole it has Linux 5.10.17-V8+ aarch64. I’ve tried running it from the terminal and just straight from raspbian

And I just got it to work.

You need to use sunvox_2.1c (as others have mentioned) and run the linux_arm64 versions from the terminal screen using ./ before the program.

The standard linux_arm oned don’t appear to work on the uconsole

cool

Hi!
The last version of Sunvox can work on the uConsole, if you use a 6 + kernel. You can download a custom (and clean) image created by @Rex here:

https://forum.clockworkpi.com/t/bookworm-6-6-30-for-the-uconsole-and-devterm/

It’s work great for me, just think to edit the config file for screen! (details in thread)

2 Likes