Super Smash Bros freezes on mupen64+, how to adjust controller map for Pokémon Stadium via SSH?

I downloaded 2 games for the mupen64 emulator on the GameShell, Super Smash Bros. and Pokémon Stadium. Super Smash Bros. operates normally, without any strange glitches. However, sometimes when you use certain moves and characters, the game completely freezes but the audio still plays in the background. The only thing you can do to remedy this is to press MENU+Shift, which restarts the entire match from the beginning and furthermore it’s very hard to actually make any progress. I have also noticed that if you turn off the experimential GPU LIMA driver, mupen64 just crashes. Moving on, when I play Pokémon Stadium, there is no freezing but slight lag, especially when your Pokémon or your opponent’s Pokémon uses Dig. The only problems are that trainer faces and certain icons just glitch out and are displayed as a random jumble of pixels just like MissingNo. I don’t mind this, but for some stupid reason when you try to use the directional buttons on the GameShell keypad, they do nothing but they DO work in Smash. So I found a topic about remapping the buttons (Mupen64 Controller Mapping for Gameshell), but I just don’t know how to modify the mupen64plus.cfg file via ssh, cause I am used to adding games and stuff using the server GUI on Mac.

If you do it purely using SSH, you’ll have to either use nano, which is great, but very command prompt intensive. You can technically push and pull files between your computer and the gameshell using commands, but unless you’re already familiar with using a command prompt it’s just too much trouble.

You can instead use a GUI based program to do all do your file manipulation. Eg. I use CyberDuck on Mac. There might be something better, but it’s just what I’ve used for the last 20 years.

The mupen config is located in a hidden folder, .config. So make sure you’ve got hidden files visible.

I’ll have fo fiddle with some settings in the mupen config. It’s about a balance of having it both run smoothly, not look terrible, and not have any major glitches is freezing.

I have a feeling that using dig slows things down, due to the sheer number of particle, smoke and shadow effects in play. Try using earthquake. I believe that’s also a fairly intensive move, and I guess if you’re using ground moves, is probably just as effective; if the slow downs are that game breaking. Oh wait. It’s your opponent. Not you. And ugh. Yeah. They use dig A LOT.

If you’re using shift+menu on my custom config, that completely quits the game. Try using “shift + select” to do a state save intermittently, perhaps at the start of each match, or when you KO your opponent. That way you can push “shift + start” to do a state save in case it ever locks up. Not ideal, but a workaround.

I’ll try and get the mupen config tweaked, but working online basically doing video conference calls 9 hours a day has been both physically and emotionally draining. Ugh. I’ll see what I can do! But also, there must be some other people on here who would be able to help! It’s just a matter of changing settings in the config file. You could even just fiddle and test it yourself. :slight_smile:

I see. Oh, and by dig, I meant when your opponent’s Pokémon/your Pokémon burrows underground. However, it doesn’t really cause much lag, its still bearable. Ill see if I can find the hidden folders :slightly_smiling_face: :ok_hand:

Ok. So I used the command “defaults write AppleShowAllFiles TRUE” so that I can see all hidden files, but when I go into the server GUI window nothing new shows up.

How do you access these folders using a GUI tool? IDK about you but I think its way more convenient to use a GUI for stuff like this.

You’re just using the finder to access your gameshell, which is only good for adding games and music, according to what’s shared; I think using SMB. Even revealing the hidden files won’t show the entirety of the gameshell’s file structure.
(As a side note, a pro tip re: MacOS toggling showing hidden files: push CMD+SHIFT and the period (.) button; it’s easier than typing “ defaults write AppleShowAllFiles TRUE/FALSE” each time)

I personally use a GUI called CyberDuck if I ever need to access my gameshell. It may not be the best one out there, but it’s what I’ve used for the last 20 years and I’m used to it. There are some things that the GUI are good for, but that’s mostly just copying files and moving things around.

The majority of things you’ll want to do on the gameshell will still require you to use a command line. Some things can only be edited with a command line, using super user or root privileges. That would be using nano, vim or any other editor. Vim also has parameters and commands colour coded to make things easy to navigate. Some other things, like making symbolic links are just easier to do as a typed out command.

At the end of the day it’s no different to using text edit; albeit without a mouse. GUI’s may be convenient, but less powerful.

Relevant picture:

Well, alright. I already know how to access my GameShell using, but idk what command you use to edit files. Can you give me a basic tutorial on how to do stuff via SSH?

for editing by ssh, check vim

to transfer files i recommend using rsync

instead of you may wanna check the marvelous iterm2

If there’s a file that requires you to know how to use a command line interface to edit with super user permissions, I would honestly recommend not touching it if you don’t know how to use a CLI. Simply because far too much damage can be done for system files that aren’t supposed to be touched.
Just stick to using a standard text editor.

As for a quick tutorial, if just using a standard terminal on Mac

  1. determine if the file being edited requires super user permissions.
  2. if it does, suffix your commands with sudo; if not, then don’t worry.
  3. choose your edited. Eg, nano.
  4. type the path of your file
  5. run it, make your changes, write the file (ctrl+o) and choose its name, then exit (ctrl+x)
  6. pray you haven’t broken anything.


sudo nano /home/cpi/something

If you’re wanting to know how to copy, move, make links etc to files, you’ll need to know some syntax.
It generaltl follows a “operation parameter source destination” format.

But to be honest, this is like trying to describe to someone in an online forum how to replace the calipers of a car’s disc brake pads. Seemingly simple, but requiring a lot of background knowledge, tools, and additional related maintenance that needs to be done on the side.

You’re better off finding some resources online that can show you how to use Linux. A great start would be to search “basic Linux commands”

Just a small update - smash bros works, if you edit the mupen64plus config, changing this line:

# Enable game-specific settings from INI file
EnableHacks = True

It still runs fairly chuggy mind you.

I guess ill try it?

Also, I did actually figure out to beat link after a LOT of battles. Ya gotta make sure that you use Pikachu or Kirby, Then just keep increasing his damage until you can fling him off the map, then when you fling him fling him AWAY from the edge of the map so that he can’t just jump up mid-air. And then the Yoshi Team is pretty easy. BUT after you get to Star Fox the game just freezes when you press Start. I hope enabling hacks will fix this. oh, and I still can’t figure out how to get the d-pad working with Pokémon Stadium. I tried going into mupen64plus.cfg, but nothing I’ve tried works. the d-pad works fine with other games tho. What’s so special about Pokémon Stadium that makes it so the d-pad doesn’t work?
Honestly, I think Clockwork needs to remap the Lightkey buttons, too. You can (theoretically) play Ps1 games without the Lightkey module, just buy using Shift and pressing A/B/X/Y. However, the N64 has more buttons, so to emulate it you need more keys. If they made it so the Lightkey buttons correspond to different keys, then fully emulating the N64 on the GameShell could be possible. Maybe ill post a rant about the GameShell hardware/software and what they need to fix.

Ok. I know it’s been a while since i last posted on this thread, but after a few months I finally got Pokemon Stadium to (almost) fully work. The thing is, Pokemon Stadium and Pokemon Stadium 2 use the N64’s d-pad to move. I simply just SSHed into my GameShell, Then using

ls -a

I was able to get to the mupen64plus.cfg file and edit it. I made the C Buttons (Shift + A/B/X/Y on the GameShell) also control the d-pad, and finally I was able to move. I also replaced the Mempak in controller 1 (R.I.P my LEGO Racers minifigures) with a Transfer Pak, allowing me to use my Pikachu from Pokemon Yellow in Stadium and teach it Surf. However, it seems that the GameShell is rendering N64 games using only 1 sample. for example, in Mario 64 the Mario head in the idle screen doesn’t seem to look as realistic as in the actual game played on an actual N64. The head in the actual game has a plastic-subsurface scattering look to it, while the one on the GameShell looks the same as all the other 3D objects in-game. Also, the carpets in Peach’s castle have a ton of z-fighting, along with all the shadows, etc. however, in Pokemon Stadium 2, this is not the case. the Scizor in the cutscene looks glossy, and even the white table thing from the first menu looks super realistic, and causes quite a lot of lag, too. thumbs up to Game Freak for pushing the Reality Coprocesser to it’s limits. the only problem, though, is that if you try to play your Game Pak in GB Tower, after a few seconds of just a blank white screen it’ll say that the Game Pak isn’t set correctly and force-disconnect all controllers, forcing you to restart the GameShell manually. I’ll post my modded config file soon, after I make some minor modifications to allow for a less clunky button layout.

1 Like