Thermal Printer does not connect ...?

cups printers reads on the job “Unable to open serial port: Permission denied”.

what is the output of

ps aux | grep cups

root 1477 0.0 0.5 83612 11628 ? Ss 15:54 0:00 /usr/sbin/cupsd -l
cpi 11896 0.0 0.0 16788 764 pts/2 S+ 16:29 0:00 grep --color=auto cups

sudo cat /etc/cups/printers.conf
?

# Printer configuration file for CUPS v2.3.3op2
# Written by cupsd
# DO NOT EDIT THIS FILE WHEN CUPSD IS RUNNING
NextPrinterId 3
<Printer devterm_printer>
PrinterId 2
UUID urn:uuid:1c4ef472-e706-320d-420d-61be040f6d61
Info devterm_printer
MakeModel Clockworkpi CPI-58
DeviceURI serial:/tmp/DEVTERM_PRINTER_IN?baud=115200+bits=8+parity=none+flow=none
State Idle
StateTime 1641856349
ConfigTime 1641856349
Type 53252
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy retry-job
</Printer>

everything seems right

I dont have a clue right now

have you tried

sudo chmod 777  /tmp/DEVTERM_PRINTER_IN 

?

I have tried this before, but I will try it again. I am able to print from the terminal, just not from any other applications, so I know that the printer works and is installed correctly. I will have to try to print again in about an hour when I get home as I left the thermal paper at home.

1 Like

still didn’t fix:
held since
Wed 12 Jan 2022 01:50:45 AM UTC
“Unable to open serial port: Permission denied”

ID Name User Size Pages State Control
devterm_printer-25 Unknown Withheld 1k 1
Description: devterm_printer
Location:
Driver: Clockworkpi CPI-58 (grayscale)
Connection: serial:/tmp/DEVTERM_PRINTER_IN?baud=115200+bits=8+parity=none+flow=none
Defaults: job-sheets=none, none media=custom_57.86x64.21mm_57.86x64.21mm sides=one-sided
1 Like

Adding that I am also experiencing the above. Printer worked for a day when I first built machine, stopped working, I have completed all the steps above and printer is printing from echo straight into DEVTERM_PRINTER_IN but not from cups.

2 Likes

I’m using an A06 and have had the same issue since day 1: I can print test commands from the terminal, but no luck via CUPS. Print jobs are held in the job queue. A brief message flashes across the bottom of the printer status window to the effect of Printer 'devterm_printer' may not be connected when I try to release the held job.

2 Likes

This is exactly that I encountered. Even I can print normally after I re-flashed the card, I am still confused about this. What I can confirm is:

Before re-flashing, I have

  1. Built the device
  2. update the system manually by flashing the card using the image file downloaded from disk collection. (I cannot connect to GitHub).
  3. Update the keyboard firmware manually. (Had to download the .sh file and run it in terminal).
  4. install snap and flatpak, but just the main program, I haven’t installed any software yet.
  5. Install Tilde.
  6. Try to print something from MousePad, and it doesn’t work.

Then, I’ve tried everything that guu said. And I cannot re-install the printer via terminal, cus I cannot connect GitHub. Therefore, I went to re-flash the card. This time:

  1. Update the keyboard firmware manually, again.
  2. The printer works fine from MousePad, and LibreOffice.

So, which makes me wonder, does snapd and flatpak have influences onto the printer?

1 Like

Several people seem to have reported a problem with the printer after installing snap. I know I’ve seen it mentioned, like on this thread:

For what it’s worth, on my A06 I’ve never installed snap and the printer still works.

I don’t think any official response has come from clockworkpi on this, but it seems like there’s some kind of conflict with snap.

OK this is interesting. Last night I reimaged the card, made sure printer was printing test pages fine, did apt update and dist-upgrade to get everything up to latest, set my wallpaper, set my terminal to transparent, installed snapd and snap core. Powered down.

Powered up the following day and printer no workie.

Edit- just read above post and that follows. The common element here is I installed snap.

Bingo! going through my install notes I used snap to install jami - then I ended up not using jami… :woozy_face:

Let’s throw a curve ball into the mix.
I have snapd installed, having used it to install Retroarch.
My printer is fully functional.
Snapd was one of the first things I remember installing.
I’m using an A06 Devterm.
I’ve generally kept my Devterm updated via the OS’s prompts, and apt update/upgrade.

Perhaps it’s whatever people are installing using snapd that causes things to stop working?

I took your advice and re-installed my OS and didn’t install snapd, printer has been working fine ever since. Thanks for the research!

Same issue, just installed snap and printer failed. Shall I just uninstall snap?

Looks like the problem may have been solved on this thread. Hopefully clockworkpi will provide an update eventually, but until then it sounds like snapd can be fixed manually. (I have not tested it myself as I haven’t found any reason to install snapd yet.)

2 Likes

FIRST - thank you adcockm!!!

for those of us who speak limited linux:
from terminal: (use nano so you can edit the read only file)

cd /etc/apparmor.d

sudo nano usr.sbin.cupsd

add two lines:
" ‘pound sign is a comment’ " don’t use the double quotes!

“# devterm printer /tmp/DEVTERM_PRINTER_IN”
wr, /dev/pts/1 wr,

must be between statement
/usr/sbin/cupsd flags=(attach_disconnected) {

and

}

of that block …

works! thanks !!!

1 Like

As I said in my post, I haven’t actually tried this myself because I didn’t encounter the problem (I never installed snapd).

I would recommend clicking through in the link I provided. Those were not bash commands, and the formatting is not the same as what was shared in the "preview’ that the forum software provides.

The screenshot below of @marrrk 's post has the proper formatting (which you can also get to at the link above). I would recommend asking on that thread for clarification.

I was kind of hoping this would have been addressed by the ClockworkPi folks, but since I saw this was an issue many were experiencing, I figured sharing the post with a possible solution might help.

3 Likes