uConsole not starting

Finished assembling my uConsole. with the A-06
I tried powering it on. The green LED lights up but the screen never turns on. I tried using the using micro SD card and I’ve also tried imaging my own SD card. There have been some posts about the LTE module causing issues so I’ve tried it without that without any difference.
I’ve tried plugging in an external monitor by HDMI in case it was the screen, but there is no output.
I’ve tried removing the batteries and running this directly off a USB-C charged, but still only the green power LED is lit.
Any ideas for next steps in troubleshooting?

Not sure how the screen connects to the mainboard, but if you can maybe try reseating the ribbon cable.

Okay, I tried that and we are still not powering on

The display ribbon might be upside down. I had this problem with my gameshell. There was a batch of game shells where the ribbon was placed upside down or reversed. Worth a try

Thank you for the suggestion. I tried this and powered it on and foul smelling smoke came out of my unit.

1 Like

Well, if it wasn’t dead before, it surely is now.

1 Like