Updated launcher from git, EPIC FAIL

Few days with no update in the launcher, i connected to ssh and updated through git:
git pull

many updates in the files, but the launcher is not working, the screen is freezed in “loading…” There is some IMAGE that I can download to flash the SD card?

I try launching the “run.py” script but there is an error:
cpi@clockworkpi:~/apps/launcher$ python2 sys.py/run.py
Traceback (most recent call last):
File “sys.py/run.py”, line 40, in
from UI.title_bar import TitleBar
File “/home/cpi/apps/launcher/sys.py/UI/title_bar.py”, line 16, in
from fonts import fonts
File “/home/cpi/apps/launcher/sys.py/UI/fonts.py”, line 24, in
fonts[“varela10”] = pygame.font.Font(fonts_path[“varela”],10)
IOError: unable to read font filename

some help? :relieved:

I checked the launcher last stable version here: https://github.com/clockworkpi/CPI/blob/master/launcher_ver.json

Well, I get the code with this:

cd /home/cpi/apps
mv launcher launcher.bak
git clone https://github.com/clockworkpi/launcher.git
git reset --hard 4ad8806
git pull

still the same result, I think that is a gnu/linux problem :S

you need to move launcher to /home/cpi

checkout this:

Well, I tried the instructios of these post, and now It freezes in “loading…” screen and I can’t conect to ssh ._____.

Well, where I can find an image to flash the sd card and start from 0? Thank you

I dont know your level of knowledge on flashing or this process, so I kinda am going to shotgun you with forum posts. Sorry if you already know some of this.

:floppy_disk: Image

This would be a good start here to download the image file needed for GameShell.

:zap: Flashing

For help with reflashing the SD Card, refer to this forum post here:

TL;DR - “Use something like https://etcher.io to flash your sd card”

:question: Troubleshooting: SD cards bigger than 8gb

I also found this forum post with issues on a 64gb SD-Card,


I usually flash it with “dd”, thank you very much :*

I guess you did not install bluez

days ago ,some one had the same problem

I had installed bluez, but don’t worry :_D

I flashed SD with the image, I put it into the clockworkpi and there is no power, well i suppose that it has no power, checking with the tester the battery gives 4V, I plug the microUsb connector to charge it, and probe it pushing the power button, nothing happends. I have the clockworkpi charging for a long time, and the pcb is hot, but is not powering on. I unmount all the things and mount again, but I’m not lucky. WTF happens with this??? I’m snooty??? Some help??

Problems with SD card, i tried flashing the bz2 :man_facepalming: now is working MOTHERFUCKERS YEEEAHHH

1 Like