clockworkpi

Custom D.E.O.T. V1.0+/Clockwork OS v0.4 image - With Updated Kernel 5.3.6, Latest Lima Drivers, RA1.8.1, Mupen64+ and much more! (Current version: 191122)

Ha, don’t thank me. This is exactly how @guu had it written out a few posts up. I merely pasted it in. Full credits should go to him.

Like I said above, the idea behind this thread is to get a whole bunch of great ideas, and compile them into one image that is easily accessible by everyone. Instructions that are as clear as guu’s often get lost, since people find it hard to know exactly what it is they’re looking for. I’m glad the community could all come together and help like this.

Was there anything in particular that you have installed and use on your image that justifies not having a fresh installation like the one in this thread? Just so I can have some kind of inspiration of what to include in a future image.

您好,我在系统中没有安装很特别的程序,只是下载了很大量的仿真器,而且tf内存卡的大小是128g的所以,能希望在不换系统的情况下更新lima的驱动程序。

您好,我还是更新失败了,在 install the mesa master branch 这些步骤中频繁出现错误,但我下载了您上存的系统映像了,针对n64运行的情况与之前的版本对比效果有所增加,我运行了1080度滑雪,贴图不再黑暗,音频清晰,运行帧数有所提升,遗憾的是距离完美运行的程度还有很长,再次感谢您的付出让我看到了n64完美运行的希望,谢谢

1 Like

Haha that’s another reason I made this image. Particularly mupen64, I’ve tried to help people get it working in other threads, but without knowing their exact system configuration etc, there was no way to diagnose individual problems. So having an image with it all built saves that hassle.

Try building mupen64 again from scratch after upgrading the Lima drivers, as suggested by @shell a few posts up. Sounds like shell was also having some problems with mupen64 using the Lima drivers.

I’ve tweaked my mupen a little bit here and there, including but not limited to my config file. If you just want to try and modify your existing 128GB card, I have uploaded a few files that could get you started.

https://drive.google.com/drive/folders/1gdp6lrHK1bmBTM_CKiU7RNXKL-W8w0X3

Put the config file in the .config/mupen directory.
Replace the action file in the apps/menu/(then wherever your mupen is) directory
The mupen file is the one I’m using. Put it in apps/emulators.

It’s still not 100% ready for prime time with every game, but the compatibility and black boxing issues have certainly improved like what you mentioned!

With the progress that has happened in this thread, my guess is that a new 0.5 release is right around the corner! Might be a good idea to have a backup plan for saving all your games; ready to re upload them to a new image.

As for issues with installing the Mesa master branch, try just doing the first line of code only:

sudo apt install g++ meson python3-mako zlib1g-dev libexpat1-dev libdrm-dev flex bison libx11-dev libxext-dev libxdamage-dev libxcb-glx0-dev libx11-xcb-dev libxcb-dri2-0-dev libxcb-dri3-dev libxcb-present-dev libxshmfence-dev libxxf86vm-dev libxrandr-dev

You may get asked a y/n prompt. Answer Y. Occasionally it will just timeout and say abort. Be on standby at this step, ready to hit Y as soon as possible. Eventually it will work. I’m not sure if it’s a timeout problem or just random luck. Either way, persevere!

I haven’t actually tried this on anything but my image, so there could be a chance this is using a dependency I have previously installed. Again, it’s hard to know everyone’s individual setups.

感谢,看似在我的gameshell上依靠您的提示安装成功了,再次感谢您的付出。

1 Like

Glad we could all help. :slight_smile:

On a side note, if anyone has been having trouble downloading the image from the google drive link from the OP (I can’t change the original post, since it’s now older than 1 month), I’ve provided some alternatives.

The image has kindly also been shared by other users in the forum, so try those as well; especially if you’re having trouble with download speeds, or regional firewalls etc.

@javelinface’s link: https://www.dropbox.com/s/4l1467cdy670j5d/deot_v1%2B%20191122.img.bz2?dl=0 (includes both guu’s modified image, and the original one without an expansion script) and https://drive.google.com/drive/folders/1xjuLFPvbtcq3FDDYCX-GI1wTCXX4XB7n
@Wizz’s link: (Europe)
https://pcroz.stackstorage.com/s/a26iBYxvkQ5VSgS
@guu’s link: https://mega.nz/#!9AliFIJa!QTTiI_VCPiD009DcqMAPGUHhVcI6BW_WqNVZkyMuVPM
@shell‘s link: (China)
https://pan.hanwangsoft.com/f/f76f2d0501094d5ca7e4/?dl=1
@CommanderKitler’s link: https://siliconlollipop.com/nextcloud/index.php/s/AYMFq9xRsjBbHba (Europe)
Alternative mirror of @CommanderKitler’s link: https://mega.nz/#!U6IknSpS!gKR8linzvUA6GHLwWUGnu4b4pdgIpV-ZlxvpbQq9s3A

The file should be 2.96GB. I believe @Wizz’s private server link is great if you live in Europe. @Shell’s file is suitable for people who are downloading from China. The others are just the standard mega, google and dropbox locations. @CommanderKitler’s image is a customised image, testing out some features, but also breaking a few others - It’s a WIP, so only download it if you are interested in development etc. See the link for more info: Custom D.E.O.T. V1.0+/Clockwork OS v0.4 image - With Updated Kernel 5.3.6, Latest Lima Drivers, RA1.8.1, Mupen64+ and much more! (Current version: 191122)

Don’t forget that you need to decompress the *.bz2 file before writing it to an SD card. The image will need to reboot twice in order to expand the partition, so let it do it’s cycle the first time.

Some people who have had trouble have had to perform a fsck. Not everyone does, but just going to mention it here just in case.

请问以上这些代码是更新lima驱动的代码么?我的系统是0.4的内核5.3.6

Is the above code a way to update Lima driver ?My system is 0.4 kernel 5.3.6。

Yes it is. But do a backup first. I have no idea what else you have done to your system. You could also just download the image and test it for yourself.

Like @guu said, it’s a way to “test” it, since it’s installed in the user directory. This means that if there are ever future pushes updates, they will get overwritten.

If you’re not sure of what you’re doing 100%, either wait for the official release, or test it using the image I’ve made.

Hmm I flashed this image to a 32Gb Sdcard but does not seem to work. It boots with to a Gcores Indusries splash but does nothing else.

Is there something I need to do to get it to work ?

It is the deot_v1+ 191122.img

Any ideas?

1 Like

Theoretically it should just be able to be written as an image and all should work. I haven’t tested the zeroed space and auto expand modified version. I’ll do that as soon as I get home.

But thank you so much for reporting this problem!!

I have a theory meantime. The boot partition might not have been written. It could be using an old kernel.

Also. Try rebooting. It could be the expander script doing its thing. Maybe write the image again and wait it out.

Its bad practice to run processes without user input, or without status indication.

Its possible to show the status on boot before loading the splash-screen. Because its basically the TTY, if you click buttons you will see the letters writing on the terminal.

1 Like

Thanks @Petrakis
The original version uploaded a while ago actually had a separate expansion script that the user could run to expand the space as required.

The one currently up is using @guu’s expansion script. In his original incarnation of this, he mentioned that the gameshell will reboot twice, then fill up the space. Unfortunately I couldn’t provide this info in the original post, since I can’t edit them after a month.

I’ll include a separate version that doesn’t automatically expand without user input if people would prefer; on top of the existing one. It will just be sitting in the Dropbox.

On a side note, after allowing the Gameshell to reboot twice on a freshly baked image, it is fully functional. I’ve tested it on three SD cards. A Sandisk 32GB ultra, the stock sandisk 16GB ultra, and Toshiba 16GB card. They are all class 10. I’m using a MacBook Pro’s SD slot, and the app ApplePi-Baker. I usually use and recommend etcher, but I’ve been using the former for a few other projects recently.
Possibly try again, or try a different card?

Let me know how you go @develroo.

1 Like

I did notice on the card /boot was empty I am guessing that was supposed to be a mounted partition. But the card only had one partiton on it. so…?

EDIT. OK so I re-imaged it… and then fsck. Boots fine now… But… I just noticed the A & B buttons are either reversed or the prompts are. Bug or feature? :wink:

EDIT 2: OK so they were set up as SNES by default that is what threw me. It is nice skin and works very nicely… Have no idea what the extra icons do as they are all in Japanese or something… But as far as the usual functions works perfectly. Cheers.

1 Like

If you send me the edits, I can edit it.

1 Like

Hello, I installed the most recent image about 15 minutes ago. I figure this was unintentional, but it would seem a copy of Megaman 3 was left in the NES folder.

1 Like

I tried to flash the image 5 times now but my GameShell refuse to boot…
Tried image from Guu link and Javelinface link.
I am using a 256gb card that was working before.

1 Like

Thank you so much for letting me know! I hate it when I leave files behind like this. It was meant to be cleared out!! I’ll get onto sorting this out ASAP, legality wise.

For @lix and those that are having trouble making an image, can you let me know what program you’re using? @develroo when you burnt the image the second time, was the boot partition still empty? Sounds like it could be a hit or miss thing in that regard depending on the flashing process. Also apologies re: control inputs!! I ran a poll a bunch of posts up asking which control interface people use, and the SNES interface came out on top. Hopefully you got it sorted. You can change it in the settings.

@Petrakis Basically, the edits made were the ones made by @guu a few posts up. He zeroed the empty space to make the image smaller, and added an expand_rootfs script. Custom D.E.O.T. V1.0+/Clockwork OS v0.4 image - With Updated Kernel 5.3.6, Latest Lima Drivers, RA1.8.1, Mupen64+ and much more! (Current version: 191122)

The only edit I would add would be adding something as you said in the form of an echo display prompt to say that it’s expanding. Also, I’d get rid of the mega man 3 rom haha. I’m only using VMs and USB boot sticks, and since my initial image is 16GB, I’ll need to make a larger environment to properly edit the images, since the expand_rootfs automatically culls itself upon execution. I’ll look into it later, but if you’re happy to help out, that would be great! For now, I’ve just provided an alternative file without the modification above applied.

Yeah… I ddrescue it in the end and fsck’d it after just to make sure. Seemed too work ok. So maybe just bad luck first time.

Otherwise seems to work ok. Just not sure what the whole extra things are. The Manual and all the apps are in Chinese so no idea what they are referring to. Is it just an effect or something ? Is there an English translation for it ?

1 Like

Ah sorry, I forgot to reply to that part. Yeah, they’re all just “for fun” and to add to the cyber edge lord hacker appeal. It was a part of the whole DEOT experience in the last game jam, and matches up with the DEOT edition of the gameshell. It literally stands for Dimension Engineering Operation Terminal.

You can pretty much just ignore them, and not worry about translating them. For all intents and purposes, having them in a foreign language (Chinese) adds to the whole mysterious appeal of having acquired a cyber punk hacking device.

So yeah, it’s just an effect really. As for a translation I believe they are all written in Love, so you will need to know how to write in that language to make any translations. They’re all images from what I can gather, so it wouldn’t be a quick copy paste of a text file. If anyone wants to translate it, that would be great!

1 Like

Thank you so much for letting me know! I hate it when I leave files behind like this. It was meant to be cleared out!! I’ll get onto sorting this out ASAP, legality wise.

Also check the GBA, MGBA and mupen64 folders if you haven’t yet. There seem to be a couple of roms left behind.

Great firmware image otherwise, good work.

1 Like