Custom D.E.O.T. V1.0+/Clockwork OS v0.4 image - With Updated Kernel 5.3.6, Latest Lima Drivers, RA1.8.1, Mupen64+ and much more! (Current version: 191122)

Awesome news. Thanks @guu

1 Like

So I have been on Debian Buster for a few months now on regular v0.4 OS image. I just downloaded the .tar.gz file, extracted it, ran the ./instasll.sh, and it finished in about a minute. I rebooted and lima works great now! Hardware acceleration and low CPU usage in NES and GameBoy games which is what I use mine for.
Thanks @guu! And @javelinface, your retroarch config is fantastic. Having menu as the menu instead of quit is quite nice!

2 Likes

Glad the config works for you! :slight_smile:

On another note, I am super excited about the 0.5 OS release! From here on out, with the new Garage feature, there shouldn’t be any need for me to make a pre made installation. Theoretically, any modifications should be applicable in the garage.

I am just about to install it, but from what I’ve gathered, the 0.5 release possibly doesn’t come with: (not that much left to add! Basically just the theme! :))

  1. Global Volume controls in standalone emulators
  2. ChocoDM wrappers etc
  3. DEOT Skin
  4. Change to a more centralised debian repository
  5. Added a PicoDrive+ Standalone emulator
  6. Updated retroarch to 1.8.2 with all options installed

Currently being added to 0.5 already, so I don’t need to worry about them! Possibly a bit of tweaking of the below.

  1. Mupen64+ installed and configured
  2. Modified action files to support zip/7z formats, and cleaned up the rom directory name structure (settings list item for managing cores has been updated to reflect this)
  3. Unified core directory location (re: pcsx and bios) including nyan and cave story

Can’t wait to work out how to use the garage system! It sounds perfect for what I wanted, and should make installation SO MUCH easier for everyone, while keeping releases less fragmented.

5 Likes

Thank you very much, looking forward to release.

1 Like

one thing I noticed in the 0.5 release is the standalone PocketSNES, but picodrive was just a retroarch core. I prefer the standalone emulators.
I remember in your previous release you used the standalone PCSX Rearmed and Picodrive, right? Will you include other standalone emulators in the 0.5/DEOT mix?

PCSX is in everything from 0.4 onwards I’m fairly sure. I

I haven’t installed any extra cores, but hey! If you wanted a pico drive core, I guess it would make sense, given the other cores use both RA and standalone versions.

There are instructions meantime on how to install it.

Thanks for the link! I’ve previously set it up as a standalone, and I’ve got another SD card that I’ve customized quite a bit (including Kodi, Shadow Warrior, Duke 3d, Commander Keen, and a lot more), but it’s on a much older image. The thing that attracts me to your image is that it combines so many useful features, would update the firmware, and save me a lot of time!!

just had a strange thing happen, my gameshell works fine except anything needing retroarch, it lags MAJORLY, doom and all that play fine as does PSX, but anything else, and including Tic-80, lags badly (on both the deot and new .05) using both GPU drivers

Probably a bit off topic being posted here, but nonetheless, sounds like a potential electrical current problem.
Check the integrity of both the cables, connectors and also ribbons connecting component; especially the battery.
Changing the SD card basically means having to half disassemble everything. Chances are something came loose.
Im assuming you meant the 0.5 image, and not 0.05.
It’s strange that it’s only Retroarch that is afflicted. Try changing the graphics drivers.
Contact customer support meantime if you suspect it’s a fault with your hardware.
help@clockworkpi.com

@detourne
I probably wouldn’t be able to include stuff like keen, duke nukem etc, simply because it would be needing to install things that may be a legal Grey area. The only reason I included doom etc is because the wad wrapper files were already included; just not configured. I didn’t want to include too much software other than what was already included.
Also, the thread pertaining to it is very out of date, and no longer valid. From memory, keen/duke etc is still current and easily user installable.
In hindsight, since the picodrive instruction are intended for 0.2, it may be out of date. I admittedly haven’t tried installing it, since I don’t play sega games much, and there isn’t really any reason for me to use a standalone over the Retroarch version.

1 Like

Found my original .4 version and ran that and everything runs fine on that so it’s not hardware. A plus on all of them PlayStation one runs fine doing runs fine it’s just the retroarch stuff doesn’t run fine, however on .4 (my original 64 gig card I was using) retroarch is also acting weird but I never got that working right on that one

Try making an image of your working SD card, then writing it to the one you were using for 0.5 that didn’t behave. From what I recall re: some of your previous posts, you’ve had troubles with SD cards in the past. You can only read/write to them a finite number of times, and doing a complete image overwrite uses up a lot of those lives. SD Cards care super cheap. Given that this is essentially a hacking device, it will give you a much better quality of life experience having multiple cards, and buying new ones to troubleshoot with, when things like this stop working.
That said, the fact that everything besides retroarch works makes me wonder what is going on.
Is there ANYTHING that you have changed on the image? I’m talking, small settings you don’t even think are relevant, like changing a theme in retroarch, editing a config, files you tried to move onto it when on your linux machine, even changing the date etc.

wasnt me with the sd issues I dont think, I think I narrowed it down to the retroarch on my deot card, everything on it outside retroarch works normally, anything in retroarch (including moving in retroarch menus) is VERY slow, never made changes to it, was quite happy with how it was working

Great, so did you change anything at all? Is this on a fresh image? Are you using the XMB interface? I need a bit of information to help you here.
If indeed it’s not hardware related, theoretically it should be happening on my machine too.
And if your old 0.4 image worked fine, then something has definitely changed on your end.
Like literally, anything you’ve changed as small as you think it might be could be the culprit.
Edit: oh hang on, you said you never got retroarch working on your original 0.4 card either. Right. Lets try and find out what you have changed. Please? :slight_smile:

was using XMB but til yesterday had no issues with it, not til I tried the .5 (on another new sd), after looking at the .5 clockwork os, I put my deot back in and thats when the issues started, again, only things using retroarch

Right. So can you tell me what settings you have changed in retroarch? I can’t really help you unless I know what has been changed on your end, besides putting a new SD card in. Unless you somehow managed to flash an EEPROM between changing cards (you couldn’t have unless you knew you were doing it), there should not have been anything that could have changed, just changing an SD card. The only other thing I can think of is that you have jiggled a cable loose/frayed or something similar.

Also, can you please test things using a freshly flashed SD card?

thats just it, aside from setting XMB I didnt change anything, loaded cores in retroarch is all

plus is I frayed a cable, the original .4 sd would also have the issues

With the newer lima drivers, and proper implementation of the GPU, there could be an increased demand in a consistent current; hence why I was wanting you to double check the cable integrity.

Have you tried flashing a fresh image? If you haven’t changed anything, then theoretically it should be the same. If you don’t want to do that, then I guess try and overwrite the retroarch configuration file with the one I put together.

https://pastebin.com/vxR3SW45

ill try that, im short on sd cards right now and on a budget for a few weeks lol, where do I paste your cfg?

I mainly pasted it here so you could compare it to your own to see what you have changed.
This is where the config is stored:

./config/Retroarch/retroarch.cfg

It might just be easier for you to copy paste it from here, if you didn’t want to find out what was wrong. It would be useful if you did though, since this will be good information to help other in the future.
https://drive.google.com/open?id=1xjuLFPvbtcq3FDDYCX-GI1wTCXX4XB7n

oh ok, i’ll take a look then, ill be back in a bit