Gameshell Display Issue

Hi guys, I have just received my first Gameshell yesterday and I have managed to assemble it today.
I am working as a Hardware Engineer. I am pretty sure I have connected all wires correctly (especially the Display FPC). I have applied an USB meter and the board current consumption is looking normal as it is not turning ON.

The Gameshell is unavailable to UP no matter what I have done as shown below:

  1. Double check the orientation of FPC
  2. Measure battery voltage level (3.9xx - 4V)
  3. Disconnect all modules except mainboard and display board
  4. Unplug and replug SD card
  5. Re-flash SD card (original A) with New GameShell OS Image v0.6 gamma OS image
  6. Try connect a micro HDMI - HDMI to my desktop monitor
  7. Re-flash another SD (B) with Custom D.E.O.T. V2.0+ OS image
  8. Try connect a micro HDMI - HDMI again to my desktop monitor
  9. There is NO display output signal can be found
  10. Confirm that the ON/OFF switch is workable (two pins are shorted when pressed)
  11. Confirm that the reset switch is workable (two pins are shorted when pressed)

None of these above approaches can bring my Gameshell alive.
I suspect my mainboard and display board are defected.
Please share your opinion if you have solved this issue before, thanks a lot.

There is an orange color LED when I charge the battery via mainboard, no other LED flashes in any circumstances when I disassemble the battery from the mainboard. No display output signal even I plugged a micro HDMI to my desktop monitor.

I have tried 3 SD cards, all are workable but the Gameshell keeps staying dead. The middle one was provided by Gameshell package.

Try using a different tool to flash your SD image. The Gameshell is kinda picky and if the image isnt exactly right it wont boot. If it doesn’t boot fully you wont get any screen output, the blinking green light, or any other obvious signs of life.

With that said, this could be a bad mainboard. I had this same exact issue with my Gameshell. I contacted support via email and they sent a new one after some quick troubleshooting. Make sure you include all the info you have here if you end up needing to contact them.

I have tried using Etcher and Raspberry pi image flasher. Not working at all. Thanks for your info though.

Hi @guu , @yong ,
Sorry for rushing but I have been waiting this beautiful device for almost 4 months. I am desperate to bring it alive asap.

Any solution/suggestion, thanks a lot.


try email to for after sales

maybe need a replacement

and next time ,flash the os v0.5 is enough

0.6 still has issues

1 Like

Hi @guu ,

Thank you very much. I have sent an email.
Hopefully it wont take too long.

Hi @guu ,

Thanks for your help, now my gameshell finally alive!

1 Like