Custom D.E.O.T. V1.0+/Clockwork OS v0.4 image - With Updated Kernel 5.3.6, Latest Lima Drivers, RA1.8.1, Mupen64+ and much more! (Current version: 191122)

just had a strange thing happen, my gameshell works fine except anything needing retroarch, it lags MAJORLY, doom and all that play fine as does PSX, but anything else, and including Tic-80, lags badly (on both the deot and new .05) using both GPU drivers

Probably a bit off topic being posted here, but nonetheless, sounds like a potential electrical current problem.
Check the integrity of both the cables, connectors and also ribbons connecting component; especially the battery.
Changing the SD card basically means having to half disassemble everything. Chances are something came loose.
Im assuming you meant the 0.5 image, and not 0.05.
It’s strange that it’s only Retroarch that is afflicted. Try changing the graphics drivers.
Contact customer support meantime if you suspect it’s a fault with your hardware.

I probably wouldn’t be able to include stuff like keen, duke nukem etc, simply because it would be needing to install things that may be a legal Grey area. The only reason I included doom etc is because the wad wrapper files were already included; just not configured. I didn’t want to include too much software other than what was already included.
Also, the thread pertaining to it is very out of date, and no longer valid. From memory, keen/duke etc is still current and easily user installable.
In hindsight, since the picodrive instruction are intended for 0.2, it may be out of date. I admittedly haven’t tried installing it, since I don’t play sega games much, and there isn’t really any reason for me to use a standalone over the Retroarch version.

1 Like

Found my original .4 version and ran that and everything runs fine on that so it’s not hardware. A plus on all of them PlayStation one runs fine doing runs fine it’s just the retroarch stuff doesn’t run fine, however on .4 (my original 64 gig card I was using) retroarch is also acting weird but I never got that working right on that one

Try making an image of your working SD card, then writing it to the one you were using for 0.5 that didn’t behave. From what I recall re: some of your previous posts, you’ve had troubles with SD cards in the past. You can only read/write to them a finite number of times, and doing a complete image overwrite uses up a lot of those lives. SD Cards care super cheap. Given that this is essentially a hacking device, it will give you a much better quality of life experience having multiple cards, and buying new ones to troubleshoot with, when things like this stop working.
That said, the fact that everything besides retroarch works makes me wonder what is going on.
Is there ANYTHING that you have changed on the image? I’m talking, small settings you don’t even think are relevant, like changing a theme in retroarch, editing a config, files you tried to move onto it when on your linux machine, even changing the date etc.

wasnt me with the sd issues I dont think, I think I narrowed it down to the retroarch on my deot card, everything on it outside retroarch works normally, anything in retroarch (including moving in retroarch menus) is VERY slow, never made changes to it, was quite happy with how it was working

Great, so did you change anything at all? Is this on a fresh image? Are you using the XMB interface? I need a bit of information to help you here.
If indeed it’s not hardware related, theoretically it should be happening on my machine too.
And if your old 0.4 image worked fine, then something has definitely changed on your end.
Like literally, anything you’ve changed as small as you think it might be could be the culprit.
Edit: oh hang on, you said you never got retroarch working on your original 0.4 card either. Right. Lets try and find out what you have changed. Please? :slight_smile:

was using XMB but til yesterday had no issues with it, not til I tried the .5 (on another new sd), after looking at the .5 clockwork os, I put my deot back in and thats when the issues started, again, only things using retroarch

Right. So can you tell me what settings you have changed in retroarch? I can’t really help you unless I know what has been changed on your end, besides putting a new SD card in. Unless you somehow managed to flash an EEPROM between changing cards (you couldn’t have unless you knew you were doing it), there should not have been anything that could have changed, just changing an SD card. The only other thing I can think of is that you have jiggled a cable loose/frayed or something similar.

Also, can you please test things using a freshly flashed SD card?

thats just it, aside from setting XMB I didnt change anything, loaded cores in retroarch is all

plus is I frayed a cable, the original .4 sd would also have the issues

With the newer lima drivers, and proper implementation of the GPU, there could be an increased demand in a consistent current; hence why I was wanting you to double check the cable integrity.

Have you tried flashing a fresh image? If you haven’t changed anything, then theoretically it should be the same. If you don’t want to do that, then I guess try and overwrite the retroarch configuration file with the one I put together.

ill try that, im short on sd cards right now and on a budget for a few weeks lol, where do I paste your cfg?

I mainly pasted it here so you could compare it to your own to see what you have changed.
This is where the config is stored:


It might just be easier for you to copy paste it from here, if you didn’t want to find out what was wrong. It would be useful if you did though, since this will be good information to help other in the future.

oh ok, i’ll take a look then, ill be back in a bit

im an idiot, cant figure out how to get to the cfg file for retroarch, using winscp

Could you perhaps start a new thread? This is clogging things up here and COMPLETELY off topic.

oh sure, sorry bout that

And back on topic, here is a modified skin file that corresponds to the file structure of the 0.5 official image. It also substitutes some of the thematic icons to take the place of items that would otherwise be blank:

Decompress the folder, and drag it into the skins directory.

If you want the extra edge lord hacker thematic files from the DEOT OS (they’re actually just for show), then decompress the “Extra”, select the individual folders and copy them to ~/launcher/Menu/Gameshell.

The font of the DEOT is a custom one, and if you want it you’ll have to specify it. I don’t know any better way to do it other than replacing the skin manager, but I’m working on it. Let me know if you know.
In the skin manager directory in my shared folder, there are two files: and The first one is the DEOT version, with paths leading to the fonts. Copy this over the existing one, found in ~/
If you want to her revert to the original one, is a backed up copy. Just remove the .bak extension and copy it over.

There are some extra fonts found in the file. Decompress this, and copy them to ~/launcher/skin/default/truetype

There are a few items in the settings menu that are different in DEOT OS; Airplane, Brightness, ButtonsLayout, Sound and Storage. Decompress, and copy the individual folders into ~/launcher/Menu/GameShell/10_Settings. Likewise, Tiny Cloud looks slightly different in DEOT. DO the same thing, just copying to ~/launcher/Menu/GameShell. This will overwrite all of the above, so make backups if you intend on restoring them ever.

That should be most of the DEOT features copied over. Unfortunately, the clean cut minimalistic icon layout has had to be cut, if I wanted to have this theme match up to whatever the 0.5 official firmware uses.

Now! Onto preferences for the new theme! Feel free to vote for as many as you want. This is just to get an idea of what to do for the future release that is coming up soon.

  • Would you want me to include the DEOT Fonts?
  • Would you like to be able to revert back to the stock 0.5 white theme?
  • Do you want to include the OP-1 theme?
  • Do you care about the edge lord hacker apps?
  • Would you want me to make more icons to match the DEOT theme?
  • Does having a custom boot/loading screen via an edited kernel appeal to you?
  • Do you even care about the DEOT theme?
  • Would you want to have a custom launcher icon layout chooser?
  • Do you even use the Hexen/Heretic/Strife wad wrappers?
  • Is having a remove mail script useful for you?
  • Do you care about having global volume control, ie in standalone emulators etc?
  • Was having all of the cores pertaining to retroarch moved to the ./config/Retroarch/cores directory (instead of applications/emulators) something that was useful?
  • Does having all retroarch features (eg, XMB interface) appeal to you?

0 voters

In other news, all of the features in this post have now been implemented. Surprise! Retroarch 1.8.2 is installed on it!
I am just testing the image and polishing it up around the edges a bit. Let me know if anyone would like me to upload an incomplete beta version for testing, and reporting back. Note: It WILL be buggy! :smiley:

Happy new year! Just released DEOT v2.0+


Could someone upload the DEOT to a torrent so ppl can actually download it without it being too big and windows blocking it and not scanning it and therefore it wnt complete the download

i finally realized its not even completing the dl just freezing and 0 b/s at the end… no wonder my images didnt work and i spent all that time on wifi power settings and flashing images

Torrenting and seeding aren’t easily doable from my country without proxies. They will be far slower than anything currently hosted. Sorry.